Skip to main content
Topic solved
This topic has been marked as solved and requires no further attention.
Topic: [Solved] Ctrl+A / Ctrl+E doesn’t work in the console (Read 154 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

[Solved] Ctrl+A / Ctrl+E doesn’t work in the console

Whether or not I’m in Wayland or at the console TTY, using the Ctrl+A / Ctrl+E keyboard shortcuts to jump the cursor to the beginning or end of a command string doesn’t work. When pressing the combinations, “^A / ^E” is put onto the command line.

Re: Ctrl+A / Ctrl+E don’t work in the console

Reply #1
It works for me with XFCE and X using OpenRc, in XFCE terminal and in another getty login - also the Home and End keys have the same effect.

Re: Ctrl+A / Ctrl+E don’t work in the console

Reply #2
Wrong set  keyboard layout?

Re: Ctrl+A / Ctrl+E don’t work in the console

Reply #3
Works here, both in gnome-terminal and TTY console. Probably you need to
Code: [Select]
setxkbmap us

Re: Ctrl+A / Ctrl+E don’t work in the console

Reply #4
I just followed these instructions on the wiki.

https://wiki.artixlinux.org/Main/Installation#Set_the_keyboard_layout

When I used “sudo loadkeys us”, this had no effect on my system. I created a “conf.d” directory in the “/etc” directory, and added “keymap=“us”, rebooted, and still have the same issue.

Since I don’t use Xorg, the “setxkbmap us” setting has no effect as well.

I also tried adding “export KEYMAP=“us” to the “rc.local” file and that didn’t work. I always added “KEYMAP=“us” and “!KEYMAP=“us” to the “s6.conf” file and that didn’t work either.



Re: Ctrl+A / Ctrl+E doesn’t work in the console

Reply #5
If it helps any, the Home and End keys only change letters from upper to lowercase.

Re: Ctrl+A / Ctrl+E doesn’t work in the console

Reply #6
Hmm, does anyone know if it works in runit? All my machines are s6 and I also have this same issue. s6's keymap/console stuff is mostly copied over from runit

Re: Ctrl+A / Ctrl+E doesn’t work in the console

Reply #7
Wait nevermind I realized what it is. You're using zsh aren't you? You'll have to configure it to catch those keys. There shouldn't be any problems in bash.

Sidenote: You can set keymaps in /etc/vconsole.conf, but us is already the default so you don't need to do anything.

Re: Ctrl+A / Ctrl+E doesn’t work in the console

Reply #8
That was it! Thank you so much! I do use zsh, and for some reason “bindkey -v” was used instead of “bindkey -e” in my “.zshrc” file. Making the change fixed the issue.