Skip to main content
Topic solved
This topic has been marked as solved and requires no further attention.
Topic: [SOLVED] how to turn off screen locking  (Read 130 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

[SOLVED] how to turn off screen locking

I don't need it on this desktop machine. have turned off power management and screen locking under display.
But it keeps locking the session on 'inactivity'.
it makes it impossible to use Artix for Zoom sessions. (the sessions involve yoga movements and stuff, the screen blanks and locks and i have to enter password to unlock).
If only blanking was the problem it would be manageable as I know how to turn that off.
Is it possible to disable screen locking entirely or is it coded in?

Re: how to turn off screen locking

Reply #1
 ;D   :-[  overlooked the Screensaver settings. Disabling screen lock, see if that fixes it. Xfce, have not used a distro before with this active screen lock settings  ;D

Re: how to turn off screen locking

Reply #2
please use archlinux wiki first, then internet and then if you are sure there is a problem artixlinux write a comment.
you will save a lot of work for us and yourself. Thank you.

Re: how to turn off screen locking SOLVED

Reply #3
Fixed. Now maybe find a way to easily turn off screen blanking. have not tried yet but assume that with all locking and screensaver turned off it will still blank the screen as all distros I've seen so far.
the Debian based antiX has a nifty utility for turning off screen blanking, try to install it here.

Re: how to turn off screen locking SOLVED

Reply #4
Yes of course Alium, sorry, point taken.

Re: how to turn off screen locking SOLVED

Reply #5
It actually seems that the settings after turning off all I can using gui settings are the most optimal for me in any distro I've used before. It takes quite some time before blanking occurs, will test more today.

Re: how to turn off screen locking SOLVED

Reply #6
Blanking is usually under power management / power saving. It may also need setting in the BIOS menus of the computer you are using, and some monitors have various menus that could put the display to sleep. Good that Artix is keeping you exercised mentally and physically.
There are also "mouse jiggler's" if your hw won't respect normal config, e.g.
https://fitzcarraldoblog.wordpress.com/2018/08/06/how-to-move-a-mouse-pointer-automatically-in-linux-to-simulate-user-activity/
I can't see anything equivalent in the AUR from a brief search, however it seems to only require a simple script or two to do this.

Re: how to turn off screen locking SOLVED

Reply #7
Thanks that script looks very useful.