Skip to main content
Topic solved
This topic has been marked as solved and requires no further attention.
Topic: [SOLVED] enable Tux logo at boot time (Read 116 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

[SOLVED] enable Tux logo at boot time

Hello,
this is nothing urgent but how can I enable tux logo at boot time?
It works in Gentoo (OpenRC/EFI and the same kernel config in Graphic support section) and Slackware (SysV, SysV/EFI).

Thank you


Re: enable Tux logo at boot time

Reply #2
Such graphical thing will only slow down startup of your machine.
If the startup takes too long think about saving a bit a buy some small SSD.
Man is as good as his tools.

Re: enable Tux logo at boot time

Reply #3
The tux logo on boot in gentoo/slackware is a kernel option. To enable this you would have to build the kernel yourself and enable the option.

Gentoo/slackware have it enabled in the kernel by default. 95% of distros don't enable the tux logo in the kernel.
Chris Cromer

Re: enable Tux logo at boot time

Reply #4
@alium
no, no playmouth :)
I am talking about kernel:
-> Device Drivers -> Graphics support -> Bootup logo


@SGOrava

Quote
Such graphical thing will only slow down startup of your machine.
If the startup takes too long think about saving a bit a buy some small SSD.
No, it does not slow down anything.

Default Artix kernel is 75.4MB plus initramfs
My custom kernel is 44MB and it runs without initramfs (so fs and disk is build in)
So even with logo build in custom kernel is smaller and loads "faster" ("" +/- some seconds - that does not count).

My laptop is i7 with 32GB RAM and SSD, so it is few years old but adding logo to kernel is not going to slow down anything.

My kernel config is ok (as it works in other distros), how can I enable tux in Artix?

@ChrisCromer
I build my kernels last 20yrs (I am not claiming thtat I am an expert though),
-> Device Drivers -> Graphics support -> Bootup logo
fb_simple (Simple framebuffer support), needed for tux on efi is enabled also and no dice.
This setup works in other distros, for some reason not in Artix. That is why I am asking for the solution

In fact vanilla kernel includes Tux logo
Here you have my custom logo for Slack and Gentoo
https://ibb.co/9bdx8GM
https://ibb.co/p6qjGxg
So I know what I am doing

thank you

Re: enable Tux logo at boot time

Reply #5
The artix kernel doesn't have the option enabled. Did you build your own kernel and enable it?
Chris Cromer

Re: enable Tux logo at boot time

Reply #6
@Chris Cromer
I just edited my post above.
Yes I enabled logo in Artix kernel
Grub has:
GRUB_GFXMODE="1024x768,800x600"

so this should work, unless I should remove 800x600?

Re: enable Tux logo at boot time

Reply #7
ok,
got it working:
https://ibb.co/SXs6cyW

 :D pretty easy, just removed "quiet" from grub (heh forgot about first thing to look for)

although it is a bit different than Gentoo and Slackware ("earlier"?)

Re: enable Tux logo at boot time

Reply #8
Looks beautiful
Chris Cromer