Skip to main content
Topic solved
This topic has been marked as solved and requires no further attention.
Topic: [SOLVED] user without permissions after update (Read 213 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

[SOLVED] user without permissions after update

Since the last update:

Code: [Select]
[2020-09-16T07:37:56-0700] [PACMAN] Running 'pacman -S -y -u --disable-download-timeout --config /etc/pacman.conf --'
[2020-09-16T07:37:56-0700] [PACMAN] synchronizing package lists
[2020-09-16T07:38:14-0700] [PACMAN] starting full system upgrade
[2020-09-16T07:38:59-0700] [ALPM] transaction started
[2020-09-16T07:39:06-0700] [ALPM] removed opentmpfiles (0.2-9)
[2020-09-16T07:39:06-0700] [ALPM] removed opensysusers (0.6-1)
[2020-09-16T07:39:06-0700] [ALPM] warning: directory permissions differ on /tmp/
filesystem: 755  package: 1777
[2020-09-16T07:39:06-0700] [ALPM] upgraded filesystem (2020.08.21-1 -> 2020.09.03-1)
[2020-09-16T07:39:06-0700] [ALPM] upgraded pambase (20200721.1-2 -> 20200721.1-2.1)
[2020-09-16T07:39:06-0700] [ALPM] upgraded libldap (2.4.50-2 -> 2.4.52-1)
[2020-09-16T07:39:06-0700] [ALPM] upgraded s6-scripts (20200826-1 -> 20200915-1)
[2020-09-16T07:39:06-0700] [ALPM] upgraded libeudev (3.2.9-4 -> 3.2.9-5)
[2020-09-16T07:39:06-0700] [ALPM] upgraded dbus-s6 (20200829-1 -> 20200913-1)
[2020-09-16T07:39:06-0700] [ALPM] upgraded eudev (3.2.9-4 -> 3.2.9-5)
[2020-09-16T07:39:06-0700] [ALPM] installed eudev-s6 (20200915-1)
[2020-09-16T07:39:07-0700] [ALPM] upgraded elogind-s6 (20200829-1 -> 20200914-1)
[2020-09-16T07:39:07-0700] [ALPM] installed esysusers (246.5-2)
[2020-09-16T07:39:07-0700] [ALPM] installed etmpfiles (246.5-2)
[2020-09-16T07:39:07-0700] [ALPM] upgraded glib2 (2.64.5-1 -> 2.66.0-1)
[2020-09-16T07:39:07-0700] [ALPM] upgraded base (2-2.1 -> 2-2.3)
[2020-09-16T07:39:07-0700] [ALPM] upgraded brotli (1.0.7-3.1 -> 1.0.9-1)
[2020-09-16T07:39:07-0700] [ALPM] upgraded ghostscript (9.53.0-1 -> 9.53.1-1)
[2020-09-16T07:39:07-0700] [ALPM] upgraded glib-networking (2.64.3-2 -> 2.66.0-1)
[2020-09-16T07:39:08-0700] [ALPM] upgraded glib2-docs (2.64.5-1 -> 2.66.0-1)
[2020-09-16T07:39:08-0700] [ALPM] upgraded gstreamer (1.16.2-2 -> 1.18.0-1)
[2020-09-16T07:39:08-0700] [ALPM] upgraded libgudev (233-2 -> 234-1)
[2020-09-16T07:39:08-0700] [ALPM] upgraded gst-plugins-base-libs (1.16.2-2 -> 1.18.0-1)
[2020-09-16T07:39:08-0700] [ALPM] upgraded gst-libav (1.16.2-2 -> 1.18.0-1)
[2020-09-16T07:39:08-0700] [ALPM] upgraded gst-plugins-bad-libs (1.16.2-13 -> 1.18.0-1)
[2020-09-16T07:39:08-0700] [ALPM] upgraded gst-plugins-good (1.16.2-3 -> 1.18.0-1)
[2020-09-16T07:39:08-0700] [ALPM] installed libavtp (0.1.0-2)
[2020-09-16T07:39:08-0700] [ALPM] installed svt-hevc (1.5.0-1)
[2020-09-16T07:39:08-0700] [ALPM] installed libmicrodns (0.1.2-1)
[2020-09-16T07:39:08-0700] [ALPM] installed zxing-cpp (1.1.1-1)
[2020-09-16T07:39:08-0700] [ALPM] upgraded gst-plugins-bad (1.16.2-13 -> 1.18.0-1)
[2020-09-16T07:39:08-0700] [ALPM] upgraded gst-plugins-base (1.16.2-2 -> 1.18.0-1)
[2020-09-16T07:39:08-0700] [ALPM] upgraded gst-plugins-ugly (1.16.2-4 -> 1.18.0-1)
[2020-09-16T07:39:08-0700] [ALPM] upgraded gstreamer-vaapi (1.16.2-2 -> 1.18.0-1)
[2020-09-16T07:39:08-0700] [ALPM] upgraded htop (3.0.1-2 -> 3.0.2-1)
[2020-09-16T07:39:08-0700] [ALPM] upgraded lib32-glib2 (2.64.5-1 -> 2.66.0-1)
[2020-09-16T07:39:08-0700] [ALPM] upgraded lib32-systemd (246.4-1 -> 246.5-1)
[2020-09-16T07:39:08-0700] [ALPM] upgraded metis (5.1.0.p9-1 -> 5.1.0.p10-1)
[2020-09-16T07:39:09-0700] [ALPM] upgraded qpdfview (0.4.18-1 -> 0.4.18-2)
[2020-09-16T07:39:10-0700] [ALPM] upgraded ungoogled-chromium (85.0.4183.83-1 -> 85.0.4183.102-1)
[2020-09-16T07:39:11-0700] [ALPM] upgraded vim-runtime (8.2.1634-1 -> 8.2.1684-1)
[2020-09-16T07:39:12-0700] [ALPM] upgraded vim (8.2.1634-1 -> 8.2.1684-1)
[2020-09-16T07:39:14-0700] [ALPM] transaction completed
[2020-09-16T07:39:14-0700] [ALPM] running '20-sysusers.hook'...
[2020-09-16T07:39:15-0700] [ALPM] running '30-tmpfiles.hook'...
[2020-09-16T07:39:15-0700] [ALPM] running '30-udev-hwdb.hook'...
[2020-09-16T07:39:15-0700] [ALPM] running '30-udev-reload.hook'...
[2020-09-16T07:39:15-0700] [ALPM] running '50-sysvcompat.hook'...
[2020-09-16T07:39:15-0700] [ALPM-SCRIPTLET] ==> Found s6-init
[2020-09-16T07:39:15-0700] [ALPM] running '90-mkinitcpio-install.hook'...
[2020-09-16T07:39:16-0700] [ALPM-SCRIPTLET] ==> Building image from preset: /etc/mkinitcpio.d/linux.preset: 'default'
[2020-09-16T07:39:16-0700] [ALPM-SCRIPTLET]   -> -k /boot/vmlinuz-linux -c /etc/mkinitcpio.conf -g /boot/initramfs-linux.img
[2020-09-16T07:39:17-0700] [ALPM-SCRIPTLET] ==> Starting build: 5.8.8-artix1-1
[2020-09-16T07:39:17-0700] [ALPM-SCRIPTLET]   -> Running build hook: [base]
[2020-09-16T07:39:20-0700] [ALPM-SCRIPTLET]   -> Running build hook: [udev]
[2020-09-16T07:39:20-0700] [ALPM-SCRIPTLET]   -> Running build hook: [autodetect]
[2020-09-16T07:39:21-0700] [ALPM-SCRIPTLET]   -> Running build hook: [modconf]
[2020-09-16T07:39:21-0700] [ALPM-SCRIPTLET]   -> Running build hook: [block]
[2020-09-16T07:39:26-0700] [ALPM-SCRIPTLET]   -> Running build hook: [filesystems]
[2020-09-16T07:39:26-0700] [ALPM-SCRIPTLET]   -> Running build hook: [keyboard]
[2020-09-16T07:39:27-0700] [ALPM-SCRIPTLET]   -> Running build hook: [fsck]
[2020-09-16T07:39:29-0700] [ALPM-SCRIPTLET] ==> Generating module dependencies
[2020-09-16T07:39:29-0700] [ALPM-SCRIPTLET] ==> Creating gzip-compressed initcpio image: /boot/initramfs-linux.img
[2020-09-16T07:39:31-0700] [ALPM-SCRIPTLET] ==> Image generation successful
[2020-09-16T07:39:31-0700] [ALPM-SCRIPTLET] ==> Building image from preset: /etc/mkinitcpio.d/linux.preset: 'fallback'
[2020-09-16T07:39:31-0700] [ALPM-SCRIPTLET]   -> -k /boot/vmlinuz-linux -c /etc/mkinitcpio.conf -g /boot/initramfs-linux-fallback.img -S autodetect
[2020-09-16T07:39:31-0700] [ALPM-SCRIPTLET] ==> Starting build: 5.8.8-artix1-1
[2020-09-16T07:39:32-0700] [ALPM-SCRIPTLET]   -> Running build hook: [base]
[2020-09-16T07:39:32-0700] [ALPM-SCRIPTLET]   -> Running build hook: [udev]
[2020-09-16T07:39:32-0700] [ALPM-SCRIPTLET]   -> Running build hook: [modconf]
[2020-09-16T07:39:32-0700] [ALPM-SCRIPTLET]   -> Running build hook: [block]
[2020-09-16T07:39:33-0700] [ALPM-SCRIPTLET] ==> WARNING: Possibly missing firmware for module: aic94xx
[2020-09-16T07:39:33-0700] [ALPM-SCRIPTLET] ==> WARNING: Possibly missing firmware for module: wd719x
[2020-09-16T07:39:39-0700] [ALPM-SCRIPTLET] ==> WARNING: Possibly missing firmware for module: xhci_pci
[2020-09-16T07:39:41-0700] [ALPM-SCRIPTLET]   -> Running build hook: [filesystems]
[2020-09-16T07:39:47-0700] [ALPM-SCRIPTLET]   -> Running build hook: [keyboard]
[2020-09-16T07:39:50-0700] [ALPM-SCRIPTLET]   -> Running build hook: [fsck]
[2020-09-16T07:39:54-0700] [ALPM-SCRIPTLET] ==> Generating module dependencies
[2020-09-16T07:39:55-0700] [ALPM-SCRIPTLET] ==> Creating gzip-compressed initcpio image: /boot/initramfs-linux-fallback.img
[2020-09-16T07:40:03-0700] [ALPM-SCRIPTLET] ==> Image generation successful
[2020-09-16T07:40:03-0700] [ALPM] running 'gio-querymodules.hook'...
[2020-09-16T07:40:04-0700] [ALPM] running 'gtk-update-icon-cache.hook'...
[2020-09-16T07:40:04-0700] [ALPM] running 's6-rc-db-update.hook'...
[2020-09-16T07:40:05-0700] [ALPM-SCRIPTLET] Switched to a new database. Feel free to remove any old unwanted/unneeded database directories in /etc/s6/rc.
[2020-09-16T07:40:05-0700] [ALPM] running 'update-desktop-database.hook'...

the account has no rights to do basic stuff like connecting to the network, shutdown, reboot.

I'm getting this message from lightdm:
Code: [Select]
[+2.18s] WARNING: Error getting user list from org.freedesktop.Accounts: GDBus.Error:org.freedesktop.DBus.Error.NoReply: Message recipient disconnected from message bus without replying

But it's not a lightdm related issue because it's the same if i start manually with startxfce4.

Maybe it's because of the replace of 'opensysusers' whith 'esysusers' but I'm not sure.

I had no problem with runit and openrc with pretty much the same stuff.

Any Idea of what I can do?

------------------------
(it's the base distro version of artix s6)

Re: user without permissions after update

Reply #1
Hmm appears to be a elogind/dbus issue. You need an elogind session up and running to do things like shutdown/network/etc. from a GUI. What's the output of "ps aux | grep elogind" for you?

Re: user without permissions after update

Reply #2
Hmm appears to be a elogind/dbus issue. You need an elogind session up and running to do things like shutdown/network/etc. from a GUI. What's the output of "ps aux | grep elogind" for you?

this is the output:

Code: [Select]
 ~  ps aux | grep elogind
root       215  0.0  0.0   2800  1056 ?        S    11:40   0:00 s6-supervise elogind-log
root       222  0.0  0.0   2800  1064 ?        S    11:40   0:00 s6-supervise elogind-srv
root       758  0.0  0.0   4200  3284 ?        S    11:41   0:00 elogind-daemon
artix    28603  0.0  0.0   8856  2324 pts/1    R+   12:23   0:00 grep --colour=auto elogind

Re: user without permissions after update

Reply #3
Yup, that's definitely not right. It should look something like this.

Code: [Select]
root       220  0.0  0.0   2800  1048 ?        S    08:49   0:00 s6-supervise elogind-srv
root       226  0.0  0.0   2800  1064 ?        S    08:49   0:00 s6-supervise elogind-log
s6log      673  0.0  0.0   2668   988 ?        Ss   08:49   0:00 s6-log -d3 -b n3 s2000000 T /var/log/elogind
root       693  0.0  0.0   4088  3316 ?        Ss   08:49   0:00 /usr/lib/elogind/elogind
user      4722  0.0  0.0   7356  2272 pts/2    S+   14:28   0:00 grep elogind

Yeah I think this is a race condition in the lightdm script. I recently changed dbus to start as soon as possible (as part of the boot bundle) because some services may need it extremely early in the boot process. However, lightdm only waits on dbus (not elogind). This means it probably started before the elogind daemon was brought up and likely dbus tried to do some weird elogind autostarting thing (which causes problems). I'll change lightdm to wait on elogind and that should probably fix your problem. Thanks for reporting!

Edit: Just pushed the new version. Let me know how it goes after you get the update.

Re: user without permissions after update

Reply #4
Yup, that's definitely not right. It should look something like this.

Code: [Select]
root       220  0.0  0.0   2800  1048 ?        S    08:49   0:00 s6-supervise elogind-srv
root       226  0.0  0.0   2800  1064 ?        S    08:49   0:00 s6-supervise elogind-log
s6log      673  0.0  0.0   2668   988 ?        Ss   08:49   0:00 s6-log -d3 -b n3 s2000000 T /var/log/elogind
root       693  0.0  0.0   4088  3316 ?        Ss   08:49   0:00 /usr/lib/elogind/elogind
user      4722  0.0  0.0   7356  2272 pts/2    S+   14:28   0:00 grep elogind

Yeah I think this is a race condition in the lightdm script. I recently changed dbus to start as soon as possible (as part of the boot bundle) because some services may need it extremely early in the boot process. However, lightdm only waits on dbus (not elogind). This means it probably started before the elogind daemon was brought up and likely dbus tried to do some weird elogind autostarting thing (which causes problems). I'll change lightdm to wait on elogind and that should probably fix your problem. Thanks for reporting!

Even if I remove lightdm, lightdm-s6 lightdm-gtk-greeter. And I manually login and manually execute startxfce4, the permission problems is still there.

I also tried downgrading dbus-s6 and elogind-s6 to the previous version but still not working.

Re: user without permissions after update

Reply #5
Unless you killed the "elogind-daemon" process, brought up the elogind daemon via s6-rc, and then logged out and logged back in, I would expect the problem to persist because you don't have a properly running elogind process.

Re: user without permissions after update

Reply #6
....

Edit: Just pushed the new version. Let me know how it goes after you get the update.

I got two updates:

Code: [Select]
[2020-09-16T13:03:41-0700] [ALPM] upgraded s6-linux-init (1.0.4.1-1 -> 1.0.4.1-2)
which made the boot process without output, just the login line.

and

Code: [Select]
[2020-09-16T13:20:41-0700] [ALPM] upgraded lightdm-s6 (20200713-1 -> 20200916-1)
which seems makes no difference to my permissions issue.


Re: user without permissions after update

Reply #7
Hmm, could you list the output of "ps aux | grep elogind", "s6-rc -a list", and "loginctl"?

Re: user without permissions after update

Reply #8
Hmm, could you list the output of "ps aux | grep elogind", "s6-rc -a list", and "loginctl"?

Sure:
Code: [Select]
 ~  ps aux | grep -e elogind
root       215  0.0  0.0   2800  1056 ?        S    13:40   0:00 s6-supervise elogind-log
root       222  0.0  0.0   2800  1060 ?        S    13:40   0:00 s6-supervise elogind-srv
root       770  0.0  0.0   4200  3284 ?        S    13:41   0:00 elogind-daemon
artix     7017  0.0  0.0   8856  2312 pts/1    R+   13:48   0:00 grep --colour=auto -e elogind

Code: [Select]
 ~  sudo s6-rc -a list
[sudo] password for artix:
s6rc-oneshot-runner
s6rc-fdholder
NetworkManager-log
NetworkManager-srv
agetty-tty2
agetty-tty3
agetty-tty4
agetty-tty5
agetty-tty6
dbus-log
dbus-srv
lightdm
udevd-log
udevd-srv
binfmt
cleanup
console-setup
dmesg
hostname
hwclock
kmod-static-nodes
modules
mount-cgroups
mount-devfs
mount-filesystems
mount-net
mount-procfs
mount-sysfs
net-lo
random-seed
rc-local
swap
sysctl
sysuser
tmpfiles-dev
tmpfiles-setup
udevadm

Code: [Select]
 ~  loginctl
SESSION  UID USER  SEAT  TTY
      1 1000 artix seat0   

1 sessions listed.

Re: user without permissions after update

Reply #9
Yeah that s6-rc output indicates that the elogind-srv/elogind-log service isn't starting for you and yet the lightdm service is starting. That's very odd. What should have happened was that s6-rc saw the new elogind dependency and started that first and then started lightdm. If elogind wasn't up, then lightdm should never have gone up either. I'll have to test it myself later I suppose.

Re: user without permissions after update

Reply #10
I was not able to reproduce your issue. However, I did decide to change how the elogind service was handled among some other things. Try updating to the latest stable (you should have new versions of s6-scripts, lightdm-s6, elogind-s6, etc.) when the mirror syncs. I'm not sure how you are launching lightdm exactly but add it to the default bundle and give it a reboot and see if that works.

Re: user without permissions after update

Reply #11
Thank you so much for your effort. The mirror has not sync yet.

But I have solved the problem.

I was looking for some sort of log of s6 without success but then I look at the dbus log and noted a lot of lines like this:
Code: [Select]
2020-09-17 09:13:54.135751767  dbus-daemon[465]: [system] Activating service name='org.freedesktop.PolicyKit1' requested by ':1.1' (uid=0 pid=754 comm="/usr/lib/elogind/elogind ") (using servicehelper)
2020-09-17 09:13:54.140095297  /usr/lib/polkit-1/polkitd: error while loading shared libraries: libmozjs-60.so: cannot open shared object file: No such file or directory
2020-09-17 09:13:54.140810497  dbus-daemon[465]: [system] Activated service 'org.freedesktop.PolicyKit1' failed: Launch helper exited with unknown return code 127
2020-09-17 09:13:54.143450158  dbus-daemon[465]: [system] Activating service name='org.freedesktop.PolicyKit1' requested by ':1.75' (uid=1000 pid=810 comm="xfce4-session ") (using servicehelper)
2020-09-17 09:13:54.147997638  /usr/lib/polkit-1/polkitd: error while loading shared libraries: libmozjs-60.so: cannot open shared object file: No such file or directory
2020-09-17 09:13:54.148841688  dbus-daemon[465]: [system] Activated service 'org.freedesktop.PolicyKit1' failed: Launch helper exited with unknown return code 127
2020-09-17 09:13:54.151090829  dbus-daemon[465]: [system] Activating service name='org.freedesktop.PolicyKit1' requested by ':1.75' (uid=1000 pid=810 comm="xfce4-session ") (using servicehelper)
2020-09-17 09:13:54.155230034  /usr/lib/polkit-1/polkitd: error while loading shared libraries: libmozjs-60.so: cannot open shared object file: No such file or directory
2020-09-17 09:13:54.155933939  dbus-daemon[465]: [system] Activated service 'org.freedesktop.PolicyKit1' failed: Launch helper exited with unknown return code 127
2020-09-17 09:13:54.158923689  dbus-daemon[465]: [system] Activating service name='org.freedesktop.PolicyKit1' requested by ':1.1' (uid=0 pid=754 comm="/usr/lib/elogind/elogind ") (using servicehelper)
2020-09-17 09:13:54.163432855  /usr/lib/polkit-1/polkitd: error while loading shared libraries: libmozjs-60.so: cannot open shared object file: No such file or directory
2020-09-17 09:13:54.164227755  dbus-daemon[465]: [system] Activated service 'org.freedesktop.PolicyKit1' failed: Launch helper exited with unknown return code 127
2020-09-17 09:13:54.171450191  dbus-daemon[465]: [system] Activating service name='org.freedesktop.PolicyKit1' requested by ':1.75' (uid=1000 pid=810 comm="xfce4-session ") (using servicehelper)
2020-09-17 09:13:54.176211466  /usr/lib/polkit-1/polkitd: error while loading shared libraries: libmozjs-60.so: cannot open shared object file: No such file or directory
2020-09-17 09:13:54.176854401  dbus-daemon[465]: [system] Activated service 'org.freedesktop.PolicyKit1' failed: Launch helper exited with unknown return code 127
2020-09-17 09:13:54.179943701  dbus-daemon[465]: [system] Activating service name='org.freedesktop.PolicyKit1' requested by ':1.1' (uid=0 pid=754 comm="/usr/lib/elogind/elogind ") (using servicehelper)
2020-09-17 09:13:54.185539952  /usr/lib/polkit-1/polkitd: error while loading shared libraries: libmozjs-60.so: cannot open shared object file: No such file or directory
2020-09-17 09:13:54.186366962  dbus-daemon[465]: [system] Activated service 'org.freedesktop.PolicyKit1' failed: Launch helper exited with unknown return code 127
2020-09-17 09:13:54.193554228  dbus-daemon[465]: [system] Activating service name='org.freedesktop.PolicyKit1' requested by ':1.75' (uid=1000 pid=810 comm="xfce4-session ") (using servicehelper)
2020-09-17 09:13:54.198679888  /usr/lib/polkit-1/polkitd: error while loading shared libraries: libmozjs-60.so: cannot open shared object file: No such file or directory
2020-09-17 09:13:54.199509038  dbus-daemon[465]: [system] Activated service 'org.freedesktop.PolicyKit1' failed: Launch helper exited with unknown return code 127
2020-09-17 09:13:54.202521884  dbus-daemon[465]: [system] Activating service name='org.freedesktop.PolicyKit1' requested by ':1.1' (uid=0 pid=754 comm="/usr/lib/elogind/elogind ") (using servicehelper)
2020-09-17 09:13:54.206961284  /usr/lib/polkit-1/polkitd: error while loading shared libraries: libmozjs-60.so: cannot open shared object file: No such file or directory
2020-09-17 09:13:54.207641854  dbus-daemon[465]: [system] Activated service 'org.freedesktop.PolicyKit1' failed: Launch helper exited with unknown return code 127
2020-09-17 09:13:54.213507745  dbus-daemon[465]: [system] Activating service name='org.freedesktop.PolicyKit1' requested by ':1.75' (uid=1000 pid=810 comm="xfce4-session ") (using servicehelper)
2020-09-17 09:13:54.218095540  /usr/lib/polkit-1/polkitd: error while loading shared libraries: libmozjs-60.so: cannot open shared object file: No such file or directory
2020-09-17 09:13:54.218736870  dbus-daemon[465]: [system] Activated service 'org.freedesktop.PolicyKit1' failed: Launch helper exited with unknown return code 127
2020-09-17 09:24:01.207095940  dbus-daemon[465]: [system] Activating service name='org.freedesktop.PolicyKit1' requested by ':1.1' (uid=0 pid=754 comm="/usr/lib/elogind/elogind ") (using servicehelper)
2020-09-17 09:24:01.386278538  dbus-daemon[465]: [system] Successfully activated service 'org.freedesktop.PolicyKit1'
2020-09-17 09:24:04.829390011  dbus-daemon[465]: [system] Activating service name='org.freedesktop.nm_dispatcher' requested by ':1.3' (uid=0 pid=762 comm="NetworkManager -d ") (using servicehelper)
2020-09-17 09:24:04.845287658  dbus-daemon[465]: [system] Successfully activated service 'org.freedesktop.nm_dispatcher'

where 'libmozjs' are mentioned.

So I did a little research and findout that is part of some javascript project named spidermonkey that leads me to the 'libproxy-mozjs' package.

I installed the libproxy-mozjs and everything is back to normal.

Strange thing, I have never had this package before, so I didn't belive I have accidentally removed along with some orphans or something.

Anyway, thank you and sorry not realize this before I not so good at this linux things.


-------------------------------------------------------
edit:

the package: libproxy-mozjs , installed also js60 (JavaScript interpreter and libraries).

js60 is all that my issue needed.

I installed js60 --asexplicit, and remove libproxy-mozjs.

Now I see my mistake. Can't find the date of installation of js60 in pacman, probably Yay install it, but I remove it becase it was an orphan just after the update that started my issue. Well, maybe not a mistake because js60 should be a dependency of the elogind package I guess, right now it's say that no package needs it.

---------------------
edit 2:

js60 seems an outdate package, I do have js68 installed because it's a dependency of polkit.

polkit package is who needs js, not elogind as I previously stated.

The weird thing is that is asking for the outdated js60.

Code: [Select]
ldd /usr/lib/polkit-1/polkitd 
linux-vdso.so.1 (0x00007ffe959f2000)
libpolkit-gobject-1.so.0 => /usr/lib/libpolkit-gobject-1.so.0 (0x00007fa5a9f68000)
libgio-2.0.so.0 => /usr/lib/libgio-2.0.so.0 (0x00007fa5a9dac000)
libgobject-2.0.so.0 => /usr/lib/libgobject-2.0.so.0 (0x00007fa5a9d54000)
libglib-2.0.so.0 => /usr/lib/libglib-2.0.so.0 (0x00007fa5a9c24000)
libelogind.so.0 => /usr/lib/libelogind.so.0 (0x00007fa5a9b98000)
libexpat.so.1 => /usr/lib/libexpat.so.1 (0x00007fa5a9b68000)
libmozjs-60.so => /usr/lib/libmozjs-60.so (0x00007fa5a837b000)
libstdc++.so.6 => /usr/lib/libstdc++.so.6 (0x00007fa5a819e000)
libgcc_s.so.1 => /usr/lib/libgcc_s.so.1 (0x00007fa5a8184000)
libpthread.so.0 => /usr/lib/libpthread.so.0 (0x00007fa5a8162000)
libc.so.6 => /usr/lib/libc.so.6 (0x00007fa5a7f99000)
libgmodule-2.0.so.0 => /usr/lib/libgmodule-2.0.so.0 (0x00007fa5a7f94000)
libz.so.1 => /usr/lib/libz.so.1 (0x00007fa5a7f78000)
libmount.so.1 => /usr/lib/libmount.so.1 (0x00007fa5a7f1a000)
libresolv.so.2 => /usr/lib/libresolv.so.2 (0x00007fa5a7f00000)
libffi.so.7 => /usr/lib/libffi.so.7 (0x00007fa5a7ef4000)
libpcre.so.1 => /usr/lib/libpcre.so.1 (0x00007fa5a7e82000)
/lib64/ld-linux-x86-64.so.2 => /usr/lib64/ld-linux-x86-64.so.2 (0x00007fa5a9fd5000)
libdl.so.2 => /usr/lib/libdl.so.2 (0x00007fa5a7e7c000)
libm.so.6 => /usr/lib/libm.so.6 (0x00007fa5a7d34000)
libblkid.so.1 => /usr/lib/libblkid.so.1 (0x00007fa5a7ce2000)
librt.so.1 => /usr/lib/librt.so.1 (0x00007fa5a7cd7000)

Code: [Select]
Name            : polkit
Version         : 0.117-1
Description     : Application development toolkit for controlling system-wide privileges
Architecture    : x86_64
URL             : https://www.freedesktop.org/wiki/Software/polkit/
Licenses        : LGPL
Groups          : None
Provides        : None
Depends On      : glib2  pam  expat  elogind  js68
Optional Deps   : None
Required By     : accountsservice  colord  lib32-polkit  lightdm  networkmanager  polkit-gnome  rtkit  xfce4-session
Optional For    : elogind  gparted
Conflicts With  : None
Replaces        : None
Installed Size  : 1887.54 KiB
Packager        : Artix Build Bot <[email protected]>
Build Date      : Mon 03 Aug 2020 01:51:05 AM PDT
Install Date    : Wed 05 Aug 2020 06:46:56 AM PDT
Install Reason  : Installed as a dependency for another package
Install Script  : No
Validated By    : Signature


I happen to have the runit and openrc version of artix and both ask for js68

Re: user without permissions after update

Reply #12
No worries. I would have never guessed that package was the issue either (never even heard of it before). Glad it all worked out. Let me know if the new update breaks anything again haha.

Re: user without permissions after update

Reply #13
No worries. I would have never guessed that package was the issue either (never even heard of it before). Glad it all worked out. Let me know if the new update breaks anything again haha.

Still working after installing your update. Thanks.