Skip to main content
Topic: Total Noob Question re gui displays (Read 131 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

Total Noob Question re gui displays

This is embarrassing... many (but not all) guis display (there seems to be a default somewhere) with black text  on an almost-black background (vlc is an example). I have looked through everything xfce and cannot find where to set the background  and text colour "default" .

Re: Total Noob Question re gui displays

Reply #1
You might try Applications - Settings - Appearance - Style (Adwaita) and Applications - Settings - Window Manager - Style (Default)

Re: Total Noob Question re gui displays

Reply #2
If that do many guis, your qt/gtk theme is not set or is set wrong.
Look archlinux wiki how to set gtk/qt theme properly, please.

Re: Total Noob Question re gui displays

Reply #3
On the XFCE version, I noticed that some windows show wrong colors when I choose the Adwaita theme.

I have consistently had this problem on different PCs after a fresh install without using AUR packages.

For example in some configuration windows such as Gimp preferences, the text appears black on a black background, and the Gimp System theme looks the same ...

I failed to fix/work around this issue even after much research and testing ...

Finally, I found a "nag" type solution: Reinstall all the packages present.
sudo pacman -S $ (pacman -Qnq)

After this "cure", all the colors are correct everywhere ... provided that you comment in /etc/environment the two lines:
# QT_QPA_PLATFORMTHEME = gtk2
# QT_STYLE_OVERRIDE = gtk

For Dolphin, which I add to XFCE4, the icons background is black instead of light gray, with black text :-/
To work around, you have to edit ~/.config/kdeglobals and modify modify:
[Colors: View]
BackgroundNormal = 220,220,220