Skip to main content
Topic solved
This topic has been marked as solved and requires no further attention.
Topic: [SOLVED]USB audio device (Read 163 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

[SOLVED]USB audio device

[SOLVED]The USB audio device (Unitek Y-247A) fails to load.   It works in Mint 19.3 Mate, Solus 4.1 Mate, Void Mate, and MX 19.2.  These are the 5 distro's installed on this Intel Nuc.   How can I load this  device?

Re: USB audio device

Reply #1
One moment, I'll look into the oracle ball, how it could have failed, when you didn't even bother to put more info about the system and logs here ....

That's the only thing I can do according to your description... 8)

Re: USB audio device

Reply #2
Can you send more details about your machine, aka UEFI/Legacy BIOS, which DE are you using and so on?

You are asking us for a h/w that we are not aware of, and the reason for not loading a USB audio device, which we are not aware of too.

@alium is correct.

If you are asking for help, you must provide detailed info.

Re: USB audio device

Reply #3
Sorry about that guys. I'm using the Mate DE on an Intel NUC.

artix:[jim]:~$ sudo inxi -b
[sudo] password for jim:
System:
  Host: artix Kernel: 5.9.1-artix1-1 x86_64 bits: 64 Desktop: MATE 1.24.1
  Distro: Artix Linux
Machine:
  Type: Desktop System: ���������������������������������
  product: ���������������������������������
  v: ���������������������������������
  serial: ���������������������������������
  Mobo: Intel model: NUC5i5RYB v: H40999-502 serial: GERY50500D2Q
  UEFI [Legacy]: Intel v: RYBDWi35.86A.0137.2015.0107.1700 date: 01/07/2015
CPU:
  Info: Dual Core Intel Core i5-5250U [MT MCP] speed: 967 MHz
  min/max: 500/2700 MHz
Graphics:
  Device-1: Intel HD Graphics 6000 driver: i915 v: kernel
  Display: server: X.org 1.20.9 driver: intel
  unloaded: fbdev,modesetting,vesa resolution: <xdpyinfo missing>
  Message: Unable to show advanced data. Required tool glxinfo missing.
Network:
  Device-1: Intel Ethernet I218-V driver: e1000e
  Device-2: Intel Wireless 7265 driver: iwlwifi
Drives:
  Local Storage: total: 232.89 GiB used: 21.73 GiB (9.3%)
Info:
  Processes: 179 Uptime: 47m Memory: 7.66 GiB used: 963.7 MiB (12.3%)
  Shell: Bash inxi: 3.1.07
artix:[jim]:~$

I tried sudo pacman -S qlxinfo, but  got:   error: target not found: qlxinfo                  same for xdpyinfo

There's a bunch of /var/logs, which ones would help the most?



Re: USB audio device

Reply #4
xdpyinfo is xorg-xdpyinfo

I use either pkgfile(pacman -S pkgfile ; pkgfile -u) or pacman -F to find things such as that

Re: USB audio device

Reply #5
We need relevant infos.

All need run under root or use sudo:

Code: [Select]
lspci -v
dmesg
lsusb
lsmod

Use paste.artixlinux.org and put here links with logs.

Use you alsa or pulseaudio?

Without this relevant informations (need all 4 logs!!) we can't help you. 8) Thanks

Re: USB audio device

Reply #6
I copied the 4 links you asked for to paste.artixlinux.org (I don't know how to get this to you)
In the lsusb, my audio adapter (Unitek Y-247A) is listed. As  far as I know, there are no drivers for this type device, so it should be working.
I installed pulseaudio and it now shows up with the sound icon, but still no sound.
 As I mentioned in my 1st comment,  the audio on 4 other distros is working fine.

Re: USB audio device

Reply #7
https://paste.artixlinux.org/view/e1684e8a

Quote
The USB audio device (Unitek Y-247A) fails to load.
ok, seems, that device is initialized and installed correctly.

so install pavucontrol (gtk3) or pavucontrol-qt (qt5) and check, if pavucontrol find it.

seems, that you have another soundcard installed, by intel - snd_hda_intel driver

Re: USB audio device

Reply #8
Thanks Alium, installing pavucontrol got me sound!

Intel NUC's don't have any sound devices, hence the need for the USB device.

I akso have a HD PRO Webcam C920 installed.

I marked my original comment as [SOLVED]

Thanks again to all!