Skip to main content
Topic: grub-mkconfig - no canonical path (Read 93 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

grub-mkconfig - no canonical path

I am trying to install Artix  from https://eu-mirror.artixlinux.org/iso/artix-base-openrc-20200214-x86_64.iso  on an external disk, UEFI .

I goth the message about no canonical path, then I read a little more and followed the advice to go to the Arch Linux wiki, where  I tried to follow the advice to use arch-root    as described in the linked BBS POst  https://bbs.archlinux.org/viewtopic.php?pid=1225067#p1225067  in https://wiki.archlinux.org/index.php/GRUB#UEFI.

I tried to use arch-chroot but got a message "command not found". Then I ran     pacman  -Ss arch-chroot      and and got no answer at all, tried      pacman  -S arch-root   and     pacman -Sy arch-chroot     and     got    *target not found".

Looked into   https://wiki.archlinux.org/index.php/GRUB/Tips_and_tricks#UEFI_further_reading  but could  not find anything there.  Long time at google to no avail. 

Went through the forum and the closest I got was this post https://forum.artixlinux.org/index.php/topic,1507.msg10373.html#msg10373  which made me aware that I may be in a difficult situation  and thought it would be appropriate to beg your counsel.


Re: grub-mkconfig - no canonical path

Reply #1
I don't know about your error message but if you just need to chroot, you can use "artools-chroot" (for Artix). Note that both "arch-chroot" and "artools-chroot" are just convenience wrappers for the chroot command so you don't have to mount a bunch of filesystems manually in the place you want to chroot to.

Re: grub-mkconfig - no canonical path

Reply #2
Should look at our wiki for install and some other things before looking at Arch