Skip to main content
Topic: Installation Boot Terminal doesn't fit all prompts on screen (Read 84 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

Installation Boot Terminal doesn't fit all prompts on screen

Hi all. I'm trying to install Artix on my Macbook Pro (13", mid-2017, no touchbar) with the base runit iso. I have no trouble booting up to the initial terminal prompts, but it appears that the system is mismatching my laptop's resolution. In other words, the most recent ~7 lines in the terminal will go beyond the bottom of my display, so I can't see those ~7 lines. Does anyone have any pointers/tips to fix this?


Re: Installation Boot Terminal doesn't fit all prompts on screen

Reply #2
Thanks for the links, they appear to be useful, but now I’m at another obstacle. I’m following what both articles say and have edited /etc/default/grub to fit my needs, resolution-wise. But afterwards, when I run “sudo update-grub”, I get an error saying
Code: [Select]
“/usr/bin/grub-probe: error: failed to get canonical path of ‘overlay’
. I’ve managed to workaround that error by getting “realpath ‘overlay’” and making the missing directory. Now when I run “sudo update-grub” I get an error line
Code: [Select]
“/usr/bin/grub-mkconfig: line 248: /boot/grub/grub.cfg.new: No such file or directory.”
This is when I noticed that the iso doesn’t even have a /boot/grub directory (which I’m not sure is normal or not). So, I did a similar workaround and made the /boot/grub.cfg.new file. Now when I run update-grub, this is what I get:
Code: [Select]
Generating grub configuration file...
Found linux image: /boot/vmlinuz-linux
Found initrd image: /boot/intel-ucode.img /boot/amd-ucode.img
/usr/bin/grub-probe: error: unknown filesystem
/usr/bin/grub-probe: error: unknown filesystem
WARNING: Failed to connect to lvmetad. Falling back to device scanning.
done.

I’ve searched online, but of the ones that are relevant to my situation, it was suggested that there may had been a mistake when preparing my live usb.
The command I used to prepare my usb was this (based on ArchLinux wiki guide for doing so on macos.
Code: [Select]
dd if=<directory of iso file> of=/dev/rdisk3 bs=1m
Any tips would be appreciated. Thanks