Skip to main content
Topic solved
This topic has been marked as solved and requires no further attention.
Topic: A lib32-elogind glitch (Read 119 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

A lib32-elogind glitch

Not sure where to put this, but this place seemed close.

elogind package provides /usr/lib/pkgconfig/libsystemd.pc however lib32-elogind doesn't provide /usr/lib32/pkgconfig/libsystemd.pc

This means trying to compile some 32bit libraries that use pkg-config to locate elogind's 32bit libraries will fail. lib32-pipewire for example. Not sure where the fix should go. Doesn't seem to be included in the source github so I guess it would need a patch?

For a short term fix you can copy /usr/lib/pkgconfig/libsystemd.pc to /usr/lib32/pkgconfig/libsystemd.pc, then edit it: libdir=/usr/lib32

But really it needs to find itself in to the original package somehow. Cheers.

Re: A lib32-elogind glitch

Reply #1
Hi mogs,

After comparing PKGBUILD's for elogind and lib32-elogind, i found that indeed lib32-elogind doesnt provide /usr/lib32/pkgconfig/libsystemd.pc.
But, it is easily fixable, since /usr/lib/pkgconfig/libsystemd.pc is really only a soft link to libelogind.pc.

I will fix it so it will provide it by default, but for now you can just do
Code: [Select]
ln -sfv /usr/lib32/pkgconfig/libelogind.pc  /usr/lib32/pkgconfig/libsystemd.pc
to circumvent that problem, since this is literally what elogind package does while installing.


Cheers,
duck

Re: A lib32-elogind glitch

Reply #2
Issue fixed in lib32-elogind=243.7-2, now it creates /usr/lib32/pkgconfig/libsystemd.pc too.

Mark as solved?