Skip to main content
Topic solved
This topic has been marked as solved and requires no further attention.
Topic: [SOLVED] startx on Nvidia (Artix base) doesn't work (Read 64 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

[SOLVED] startx on Nvidia (Artix base) doesn't work

I'm using Artix on my Asus laptop (ATI Radeon) without problems, but I wanted to also install it on my desktop computer, which uses Nvidia GTX 650. On my desktop, I also wanted to try out base install, without any display manager (the suckless way). However, I'm having trouble with configuring X to start through the startx command.

When initially installing packages with pacman upon first boot, I installed the xorg group, nvidianvidia-modeset and nvidia-drm packages and loaded the driver into the kernel by
Code: [Select]
modprobe nvidia
The command was successful, as
Code: [Select]
$ lsmod | grep nvidia
returns:
Code: [Select]
nvidia_drm             61440  0
nvidia_modeset       1220608  1 nvidia_drm
nvidia              27746304  1 nvidia_modeset
drm_kms_helper        266240  1 nvidia_drm
drm                   585728  4 drm_kms_helper,nvidia_drm,ttm
However, when I run startx, I get the following output:

Here's my Xorg.0.log ("Offensive content"? Good one Pastebin 🙄) and the output of inxi -F.

I also tried using the nouveau, with the same result.

I must add that lightdm works without error on this setup. It is only when I try startx without lightdm that I encounter problems.

Any help is appreciated.

EDIT: I solved it myself. The problem was the contents of my ~/.xinitrc, which apparently needs to have a specific format of executing the WM. Any programs listed in this script will be executed, but the last one needs to have exec prepended, for example to start dwm one needs to have:
Code: [Select]
#!/bin/sh

# ... other stuff...

# For example:
xterm &

# Last line containing programs to be started below,
# needs to have "exec" in front
exec dwm