Skip to main content
Topic solved
This topic has been marked as solved and requires no further attention.
Topic: Artix-lxqt-runit no me reconoce la swap. (Read 107 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

Artix-lxqt-runit no me reconoce la swap.

Hola, llevo dos días tratando de reinstalar Artix-lxqt-runit, versión estable del 08-12-2020, integridad del iso verificada, en vivo lee la swap sin problemas pero al instalar en el DD ya no la reconoce, he probado sin formatear o formateando la swap pero el resultado es el mismo. Se agradece sugerencias.

Re: Artix-lxqt-runit no me reconoce la swap.

Reply #1
Hola.

Con la información que das, la cual es poca, voy a asumir que tienes una partición preparada para la memoria swap.

Puedes verificar si la swap está activa con este comando:

Code: [Select]
sudo swapon --show

También te recomiendo que pegues acá la salida del siguiente comando:

Code: [Select]
cat /etc/fstab 

Puede ser que tengas la partición asignada para la SWAP pero al no estar en el fstab puede ser que al arrancar el sistema simplemente no te la reconozca. Es una teoría.

Cordial saludo.
Artix Linux Colombia

Re: Artix-lxqt-runit no me reconoce la swap.

Reply #2
Hola.

Con la información que das, la cual es poca, voy a asumir que tienes una partición preparada para la memoria swap.

Puedes verificar si la swap está activa con este comando:

Code: [Select]
sudo swapon --show

También te recomiendo que pegues acá la salida del siguiente comando:

Code: [Select]
cat /etc/fstab 

Puede ser que tengas la partición asignada para la SWAP pero al no estar en el fstab puede ser que al arrancar el sistema simplemente no te la reconozca. Es una teoría.

Cordial saludo.
Code: [Select]
nodran:[karibe]:~$ sudo swapon --show
[sudo] password for karibe:
nodran:[karibe]:~$
Code: [Select]
nodran:[karibe]:~$ cat /etc/fstab
# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a device; this may
# be used with UUID= as a more robust way to name devices that works even if
# disks are added and removed. See fstab(5).
#
# <file system>             <mount point>  <type>  <options>  <dump>  <pass>
UUID=d950a7d4-dc0a-44d8-b954-43c31c31433b /              ext4    defaults,noatime 0 1
UUID=25bfa4f0-ef1e-4313-8d10-9b373108c1ee /home          ext4    defaults,noatime 0 2
nodran:[karibe]:~$ sudo blkid
[sudo] password for karibe:
/dev/sda1: UUID="07b1e88a-5c01-4ea4-9067-96222bd7dd76" TYPE="swap" PARTUUID="00011b78-01"
/dev/sda2: UUID="d950a7d4-dc0a-44d8-b954-43c31c31433b" BLOCK_SIZE="4096" TYPE="ext4" PARTUUID="00011b78-02"
/dev/sda5: UUID="25bfa4f0-ef1e-4313-8d10-9b373108c1ee" BLOCK_SIZE="4096" TYPE="ext4" PARTUUID="00011b78-05"
/dev/sda6: UUID="83882c32-2677-468e-8701-4a404b83c7e4" BLOCK_SIZE="4096" TYPE="ext4" PARTUUID="00011b78-06"
nodran:[karibe]:~$

Gracias por tu atención. Saludos

Re: Artix-lxqt-runit no me reconoce la swap.

Reply #3
Quote
/dev/sda1: UUID="07b1e88a-5c01-4ea4-9067-96222bd7dd76" TYPE="swap" PARTUUID="00011b78-01"
swap missing in your fstab.
Code: [Select]
mkswap /dev/sda1
Code: [Select]
swapon /dev/sda1 
and add line to your fstab:

Code: [Select]
#swap
UUID=07b1e88a-5c01-4ea4-9067-96222bd7dd76 none swap defaults 0 0

and it will works again  ;)

 

Re: Artix-lxqt-runit no me reconoce la swap.

Reply #4
swap missing in your fstab.
Code: [Select]
mkswap /dev/sda1
Code: [Select]
swapon /dev/sda1 
and add line to your fstab:

Code: [Select]
#swap
UUID=07b1e88a-5c01-4ea4-9067-96222bd7dd76 none swap defaults 0 0

and it will works again  ;)

Muchas gracias por la asistencia, un cordial saludo.