Skip to main content
Topic solved
This topic has been marked as solved and requires no further attention.
Topic: [SOLVED] libcap (2.46) breaks dependency 'libcap=2.45' required by lib32-libcap  (Read 345 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

[SOLVED] libcap (2.46) breaks dependency 'libcap=2.45' required by lib32-libcap

Can't update today. Found this.

Code: [Select]
:: Synchronizing package databases...
 gremlins is up to date
 system is up to date
 world is up to date
 galaxy is up to date
 lib32 is up to date
 testing is up to date
 extra is up to date
 community is up to date
 multilib is up to date
:: Starting full system upgrade...
resolving dependencies...
looking for conflicting packages...
error: failed to prepare transaction (could not satisfy dependencies)
:: installing libcap (2.46-1) breaks dependency 'libcap=2.45' required by lib32-libcap
error installing repo packages


Re: libcap (2.46-1) breaks dependency 'libcap=2.45' required by lib32-libcap

Reply #1
lib32-libcap updated . Bug in archlinux  is irrelevant.

Re: [SOLVED] libcap (2.46) breaks dependency 'libcap=2.45' required by lib32-libcap

Reply #2
Thank you alium, but I have the same error, still.

Re: [SOLVED] libcap (2.46) breaks dependency 'libcap=2.45' required by lib32-libcap

Reply #3
Quote
:: Synchronizing package databases...
 gremlins is up to date
 system is up to date
 world is up to date
 galaxy is up to date
 lib32 is up to date
 testing is up to date
 extra is up to date
 community is up to date
 multilib is up to date

becase you have enabled only [testing[ repo, which  alone is not enough for full upgrade ;-)
if you enable [testing] repo, as you did, you need  enable community-testing, lib32-testing and multilib-testing too  ;)  8)

Re: [SOLVED] libcap (2.46) breaks dependency 'libcap=2.45' required by lib32-libcap

Reply #4
Correct, hadn't noticed they weren't enabled! Thanks :)

Re: [SOLVED] libcap (2.46) breaks dependency 'libcap=2.45' required by lib32-libcap

Reply #5
So this is probably the same case, so I'm posting it here. Can't upgrade because of the same dependency.

Code: [Select]
error: failed to prepare transaction (could not satisfy dependencies)
:: installing libpcap (1.10.0-1) breaks dependency 'libpcap=1.9.1' required by lib32-libpcap

 

Re: [SOLVED] libcap (2.46) breaks dependency 'libcap=2.45' required by lib32-libcap

Reply #6
Sorry, the original maintainer of multilib was delayed with the package upgrade.

i added lib32-libpcap to lib32-testing (multilib-testing) now.