Skip to main content
Topic: How Do I Suppress Console Output in TTY1? (Read 104 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

How Do I Suppress Console Output in TTY1?

When I boot up my system I will get messages in tty1 when I go to log in. For example:

Code: [Select]
Artix Linux 5.10.4-artix2-1 (tty1)
artix login: mc
wlp5s0: authenticate with 00:cb:51:fb:9a:df
wlp5s0: send auth to 00:cb:51:fb:9a:df (try 1/3)
wlp5s0: authenticated
wlp5s0: associate with 00:cb:51:fb:9a:df (try 1/3)
wlp5s0: RX AssocResp from 00:cb:51:fb:9a:df (capab=0x11 status=0 aid=1)
wlp5s0: associated
Password:

This looks like it is from `NetworkManager` which is a service I have set up to run at boot (runit):

Code: [Select]
$ ls /run/runit/service
NetworkManager  acpid  agetty-tty1  agetty-tty2  agetty-tty3  agetty-tty4  agetty-tty5  agetty-tty6  cronie  dbus  elogind  sshd  udevd  device-mapper  lvm2



I can still type in my password but it's still really annoying. How do I suppress these messages?

 

Re: How Do I Suppress Console Output in TTY1?

Reply #1
Well, that seems to be a bug related to wireless managers which work with NetworkManager, wpa_supplicant in the first place. Actually, it spams messages not to tty1 directly, but to /dev/console. There is a recipe somewhere on the forum, but in a brief. Here how I overcame this issue.

First, install iwd and make NetworkManager use it instead of wpa_supplicant:

/etc/NetworkManager/conf.d/iwd.conf
Code: [Select]
[device]
wifi.backend=iwd

This feature is described as "experimental", but it works. Then, enable logging for iwd service:

/etc/runit/sv/iwd/log/run
Code: [Select]
#!/bin/sh
exec svlod -t /var/log/iwd
(Make this file executable, of course)

And then, enable iwd service as usual:
Code: [Select]
ln -sf /etc/runit/sv/iwd /run/runit/service

NetworkManager enables wpa_supplicant automatically, and you don't need to activate it, but iwd must be activated. With logging is enabled for iwd, no messages appear in /dev/console.