Skip to main content
Topic solved
This topic has been marked as solved and requires no further attention.
Topic: os-prober doesn't detect windows (Read 100 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

os-prober doesn't detect windows

I have already dual booted arch with windows before, so I pretty much repeated the same steps. I installed grub, os-prober and efibootmgr, I mounted my windows rfi partition into /mnt2, the ran grub-install --target=x86_64-efi --efi-directory=/boot --bootloader-id=grub and  grub-mkconfig -o /boot/grub/grub.cfg.
For some reason, no matter how many times I tried, os-prober simply won't detect my windows partition. I finished the install anyways and only artix appears into the grub menu. I can boot windows from my uefi settings but it's quite annoying and I would rather have it show up on the grub menu.

Re: os-prober doesn't detect windows

Reply #1
hi, 
and the wiki instruction works for you not? https://wiki.archlinux.org/index.php/GRUB#Dual-booting  or you not read it ;-)

Quote
Often, partitions containing Windows will be automatically discovered by os-prober. However, NTFS partitions may not always be detected when mounted with the default Linux drivers. If GRUB is not detecting it, try installing NTFS-3G and remounting.
(from same wiki)


Re: os-prober doesn't detect windows

Reply #3
You should install the ntfs-3g package in order to make NTFS partitions visible to os-prober.

Re: os-prober doesn't detect windows

Reply #4
that fixed
You should install the ntfs-3g package in order to make NTFS partitions visible to os-prober.
That fixed it, thank you a ton
I actually tried to install this package during the install and it didn't detect windows, after install I tried it again and it worked!