Skip to main content
Topic solved
This topic has been marked as solved and requires no further attention.
Topic: Can't launch Xorg (Read 90 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

Can't launch Xorg

I can't launch Xorg.

I don't know what is the problem, but I think what's happening is that X is getting elogind's PID from before the early getty went down, for some reason.

If I logout and login back again it works as expected.

PS: I use autologin in tty1.

Re: Can't launch Xorg

Reply #1
How are  you autologging into tty1? Are you using the /etc/s6/sv/agetty-tty1-conf option in the file?

Re: Can't launch Xorg

Reply #2

Re: Can't launch Xorg

Reply #3
Hello, I don't know if this has something to do with the elogind update but in my case I cannot login since TTY1, I had to open tty2 and then use the command "startx" to have xorg working.

Best regards.
Artix Linux Colombia

Re: Can't launch Xorg

Reply #4
I disabled autologin on tty1 and the issue persists. If I login to another tty or logout and back in, it works.


Re: Can't launch Xorg

Reply #5
According to the log, it seems that either no graphic drivers are installed for your graphic card (nvidia?), or there is no xorg.conf file. Try to run

Code: [Select]
# X -configure

and then copy /root/ to /etc/X11/xorg.conf.

Also, check if xf86-video-nouveau or proprietary nvidia drivers are installed.

Re: Can't launch Xorg

Reply #6
Solved it. I removed `nvidia-drm.modeset=1` (which enables Kernel Mode Setting) from the kernel parameters. I think what caused the issue was the update from nvidia-dkms 455.45.01-1 to nvidia-dkms 460.32.03-1.