Skip to main content
Topic: greetd not workgin with xdm-openrc (Read 197 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

greetd not workgin with xdm-openrc

Hello,

I have installed xdm-openrc from the artix repos and greetd from the AUR.

I have the file /etc/conf.d/xdm with contents:
Code: [Select]
CHECKVT=7

DISPLAYMANAGER="greetd"

I then have /etc/greetd/config.toml with contents:
Code: [Select]
[terminal]
# The VT to run the greeter on. Can be "next", "current" or a number
# designating the VT.
vt = 7

# The default session, also known as the greeter.
[default_session]

# `agreety` is the bundled agetty/login-lookalike. You can replace `$SHELL`
# with whatever you want started, such as `sway`.
command = "tuigreet --time --remember --asterisks --cmd startx"

# The user to run the command as. The privileges this user must have depends
# on the greeter. A graphical greeter may for example require the user to be
# in the `video` group.
user = "greetd"

I have enabled xdm on the default run level.

The problem is, when my system boots, it shows the default XDM login screen, so it's as if it's ignoring the
Code: [Select]
DISPLAYMANAGER="greetd"
line I have in my my /etc/conf.d/xdm file.

I've tried changing the greetd user, the vt number, and checked file permissions, all to no avail (this is configured exactly how it is on my Gentoo desktop).

If I could get any help with this it would be appreciated, thank you.


Re: greetd not workgin with xdm-openrc

Reply #2
So since there is no greetd-openrc package I guess I am out of luck.

 

Re: greetd not workgin with xdm-openrc

Reply #3
So since there is no greetd-openrc package I guess I am out of luck.
You can write your own /etc/init.d/greetd init script. It's not so hard. That's current lightdm init script:

Code: [Select]
#!/usr/bin/openrc-run

command="/usr/bin/lightdm"
pidfile="/run/${RC_SVCNAME}.pid"
command_background=true

depend() {
    need localmount

    after bootmisc consolefont modules netmount
    after ypbind autofs openvpn gpm lircmd
    after quota keymaps acpid
    before alsasound
    want elogind
    use xfs
}

Try to change lightdm to greetd.