Skip to main content
Topic solved
This topic has been marked as solved and requires no further attention.
Topic: [SOLVED] Audio not working after log out and login (Read 122 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

[SOLVED] Audio not working after log out and login

Hello, I am quite new to Artix and don't know how to solve this problem. When I first start up the system, audio works fine, but if I log out and then log in again, I have no sound output, the only thing that can do is reboot, or do
Code: [Select]
pulseaudio -k & pulseaudio --start
I don't know what is causing the problem so any help would be appreciated.

lspci -v
https://paste.artixlinux.org/48242185

dmesg
https://paste.artixlinux.org/04126c89

lsusb
Code: [Select]
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 003 Device 002: ID 04d9:a09f Holtek Semiconductor, Inc. E-Signal LUOM G10 Mechanical Gaming Mouse
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 003: ID 0d8c:0012 C-Media Electronics, Inc. USB Audio Device
Bus 001 Device 002: ID 1532:0243 Razer USA, Ltd Razer Huntsman Tournament Edition
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

lsmod
https://paste.artixlinux.org/c07903fc


Re: Audio not working after log out and login

Reply #2
without more relevant informations or log, we are not able  help you

read please https://forum.artixlinux.org/index.php/topic,1923.0.html
I did not include this logs cause I didn't find anything related to my problem. But if you think it could help, I will paste all the commands. Hope this helps

Re: Audio not working after log out and login

Reply #3
We need know how you start pulseaudio, which DE, DM and init you use ?

 whether you modified your pa setting files, please put it here too
/etc/pulse/default.pa or your user's default.pa (if exist)

Re: Audio not working after log out and login

Reply #4
I use runit as my init and xmonad as WM. I don't have user default.pa and  in /etc/pulse/default.pa only commented the "load-module module-role-cork" line cause I don't want it.
Code: [Select]
### Network access (may be configured with paprefs, so leave this commented
### here if you plan to use paprefs)
#load-module module-esound-protocol-tcp
#load-module module-native-protocol-tcp
#load-module module-zeroconf-publish

### Load the RTP receiver module (also configured via paprefs, see above)
#load-module module-rtp-recv

### Load the RTP sender module (also configured via paprefs, see above)
#load-module module-null-sink sink_name=rtp format=s16be channels=2 rate=44100 sink_properties="device.description='RTP Multicast Sink'"
#load-module module-rtp-send source=rtp.monitor

### Load additional modules from GSettings. This can be configured with the paprefs tool.
### Please keep in mind that the modules configured by paprefs might conflict with manually
### loaded modules.
.ifexists module-gsettings.so
.nofail
load-module module-gsettings
.fail
.endif


### Automatically restore the default sink/source when changed by the user
### during runtime
### NOTE: This should be loaded as early as possible so that subsequent modules
### that look up the default sink/source get the right value
load-module module-default-device-restore

### Make sure we always have a sink around, even if it is a null sink.
load-module module-always-sink

### Honour intended role device property
load-module module-intended-roles

### Automatically suspend sinks/sources that become idle for too long
load-module module-suspend-on-idle

### If autoexit on idle is enabled we want to make sure we only quit
### when no local session needs us anymore.
.ifexists module-console-kit.so
load-module module-console-kit
.endif
.ifexists module-systemd-login.so
load-module module-systemd-login
.endif

### Enable positioned event sounds
load-module module-position-event-sounds

### Cork music/video streams when a phone stream is active
#load-module module-role-cork

### Modules to allow autoloading of filters (such as echo cancellation)
### on demand. module-filter-heuristics tries to determine what filters
### make sense, and module-filter-apply does the heavy-lifting of
### loading modules and rerouting streams.
load-module module-filter-heuristics
load-module module-filter-apply

### Make some devices default
#set-default-sink output
#set-default-source input
I don't really know how does pulseaudio starts, just installed it and changed nothing other than commenting the line I said before.
This is what I get when launching htop and searching "pulseaudio":

Re: Audio not working after log out and login

Reply #5
put here please output from /etc/pulse/client.conf

Re: Audio not working after log out and login

Reply #6
/etc/pulse/client.conf
Code: [Select]
# This file is part of PulseAudio.
#
# PulseAudio is free software; you can redistribute it and/or modify
# it under the terms of the GNU Lesser General Public License as published by
# the Free Software Foundation; either version 2 of the License, or
# (at your option) any later version.
#
# PulseAudio is distributed in the hope that it will be useful, but
# WITHOUT ANY WARRANTY; without even the implied warranty of
# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
# General Public License for more details.
#
# You should have received a copy of the GNU Lesser General Public License
# along with PulseAudio; if not, see <http://www.gnu.org/licenses/>.

## Configuration file for PulseAudio clients. See pulse-client.conf(5) for
## more information. Default values are commented out.  Use either ; or # for
## commenting.

; default-sink =
; default-source =
; default-server =
; default-dbus-server =

autospawn = yes
; autospawn = yes
; daemon-binary = /usr/bin/pulseaudio
; extra-arguments = --log-target=syslog

; cookie-file =

; enable-shm = yes
; shm-size-bytes = 0 # setting this 0 will use the system-default, usually 64 MiB

; auto-connect-localhost = no
; auto-connect-display = no

Re: Audio not working after log out and login

Reply #7
which DM you use?

Re: Audio not working after log out and login

Reply #8
LightDM

Re: Audio not working after log out and login

Reply #9
can you please try another DM? like SDDM? pacman -S sddm-runit

Re: Audio not working after log out and login

Reply #10
After some time looking at log files, I found that I had the same problem that is described here: https://wiki.archlinux.org/index.php/PulseAudio/Troubleshooting#Daemon_already_running
So I tried the solutions proposed on the wiki. Deleting the file at /etc/xdg/autostart/pulseaudio.desktop solved my problem, now when I log out and log in again audio is working and can control pulseaudio using pavucontrol.

Thanks for the help.