Skip to main content
Topic: Не запускаются X? (Read 195 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

Не запускаются X?

Не знаю в иксах дело или нет, но эта фича (проблема) не только у меня судя по топикам на форуме. Ранее создавал тему здесь, но её удалили.
Не важно какая видеокарта nvidia или radeon. Такое бывает особенно после использования mkinitcpio, например, когда обновляется ядро.
/var/log/Xorg.1.log
Code: [Select]
[    58.207] (EE) RADEON(0): [drm] failed to set drm interface version.
[    58.207] (EE) RADEON(0): Kernel modesetting setup failed
[    58.207] (II) UnloadModule: "radeon"
[    58.207] (EE) Screen(s) found, but none have a usable configuration.
[    58.207] (EE)
Fatal server error:
[    58.207] (EE) no screens found(EE)
Думал, что дело в lightdm, но /var/log/lightdm/x-1.log
Code: [Select]
(II) [KMS] Kernel modesetting enabled.
(EE)
Fatal server error:
(EE) no screens found(EE)
В артиксе это зачётная хрень! Ни разу не сталкивался с подобным. В archlinux gentoo debian такого не было. Понятия не имею в чем дело. Блин, уже надоело!
Нашел статью. Надеюсь это решение.

Re: Не запускаются X?

Reply #1
и расскажите, какая у вас карта?
Code: [Select]
sudo lspci -v

вы уверены, что у вас есть драйвер radeon? Драйвер radeon не следует использовать на новых видеокартах !!
https://wiki.archlinux.org/index.php/Xorg#AMD

Re: Не запускаются X?

Reply #2
вы уверены, что у вас есть драйвер radeon?
https://wiki.archlinux.org/index.php/Xorg#AMD
Уверен? Я знаю, что все необходимое установлено.
Драйвер radeon не следует использовать на новых видеокартах !!
На данный момент используется единственная древняя видеокарта (ATI chip REDWOOD).

https://forum.artixlinux.org/index.php/topic,1593.0.html

artix x86_64 lxde runit-init

Re: Не запускаются X?

Reply #3
поместите сюда свои конфиги из /etc/X11/xorg.conf.d/ полные списки всех файлов в этом каталоге

Re: Не запускаются X?

Reply #4
Там только 00-keyboard.conf
Code: [Select]
# Read and parsed by systemd-localed. It's probably wise not to edit this file
# manually too freely.
Section "InputClass"
        Identifier "system-keyboard"
        MatchIsKeyboard "on"
        Option "XkbLayout" "us,ru"
        Option "XkbOptions" "grp:ctrl_shift_toggle"
EndSection

Re: Не запускаются X?

Reply #5
/var/log/lightdm/lightdm.log
Spoiler (click to show/hide)


/var/log/lightdm/seat0-greeter.log
Spoiler (click to show/hide)


Re: Не запускаются X?

Reply #6
Quote
lightdm-gtk-greeter: Fatal IO error 11 on X server :0.
подойдет ли вам какой-либо другой дистрибутив или live ISO? Если это так, и вы не можете обнаружить проблему, я рекомендую переустановить вашу систему.

 any other distro or live ISO work for you? If this is the case and you cannot detect the problem, then I recommend reinstalling your system.

Re: Не запускаются X?

Reply #7
подойдет ли вам какой-либо другой дистрибутив или live ISO?

 any other distro or live ISO work for you?
Artix или другой дистр?

Мне кажется, что причину надо искать где-то в dbus+lightdm+connman.

 

Re: Не запускаются X?

Reply #8
Попробуйте наш живой ISO. Если ISO сапоги в настольных средах (XFCE, плазме, Gnome, Mate), то Xserver работает хорошо, и что-то не так, на вашем компьютере.

LightDM является проблематичным, не так много разработано, попробуйте SDDM, сетевой администратор CONNMAN, он не должен влиять на графику.

Try our Live ISO. If ISO boots in Desktop Environment (XFCE, Plasma, Gnome, Mate), then xserver works well, and something is wrong set on your computer.
Lightdm is problematic, not SO MUCH developed, try SDDM, Connman's network administrator, it should not affect graphics.

Re: Не запускаются X?

Reply #9
сетевой администратор CONNMAN, он не должен влиять на графику.

Connman's network administrator, it should not affect graphics.
Возможно.

Мне не нравится это
Code: [Select]
connmand[1128]: ++++++++ backtrace ++++++++
connmand[1172]: Failed to find URL:http://ipv4.connman.net/online/status.html
lightdm[1367]: pam_elogind(lightdm-greeter:session): Failed to release session: No session 'c1' known

У меня два HDD. На одном установлен artix, а на другом - devuan-beowulf (ранее был gentoo). Если отключить второй диск то проблем с запуском artix нет. Работает tty и нормально загружается lightdm.