Skip to main content
Topic solved
This topic has been marked as solved and requires no further attention.
Topic: [SOLVED] Can't make amd overclock parameter permanent at every boot (Read 212 times) previous topic - next topic
0 Members and 2 Guests are viewing this topic.

[SOLVED] Can't make amd overclock parameter permanent at every boot

Solved, check the replies.
I can overclock, but I need to edit the kernel parameter everytime I boot. This I mean: amdgpu.ppfeaturemask=0xffffffff.
It works, I have advanced options in corectrl when I do this, though I can't make it permanent.  This must be done to make it permanent at every boot but it doesn't work:
Edit /etc/default/grub and append your kernel options between the quotes in the GRUB_CMDLINE_LINUX_DEFAULT line:
        GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
    And then automatically re-generate the grub.cfg file with:
        # grub-mkconfig -o /boot/grub/grub.cfg

I have ENCRYPTED disk btw, could this be a problem? Here is my /etc/default/grub (UUID's are shadowed due to security reasons):

GRUB_CMDLINE_LINUX_DEFAULT="quiet cryptdevice=UUID=someuuid:luks-someluks root=/dev/mapper/luks-somethingblabla amdgpu.ppfeaturemask=0xffffffff"

Re: Can't make amd overclock parameter permanent at every boot

Reply #1
It seems correct, you can verify if the kernel gets the arguments after boot:
Code: [Select]
$ cat /proc/cmdline
Do this first and see what it shows.

Re: Can't make amd overclock parameter permanent at every boot

Reply #2
It seems correct, you can verify if the kernel gets the arguments after boot:
Code: [Select]
$ cat /proc/cmdline
Do this first and see what it shows.
This:
BOOT_IMAGE=/boot/vmlinuz-linux-zen root=UUID=someuuid rw net.ifnames=0 quiet cryptdevice=UUID=someuuid:luks-someuuid root=/dev/mapper/luks-someuuid

I tried it the both ways. Maybe I should add the parameters IN BETWEEN? Is it possible that I shouldn't add them to the end?

Re: Can't make amd overclock parameter permanent at every boot

Reply #3
Hm, for some reason the amdgpu argument didn't make it in grub.cfg. Try adding it to GRUB_CMDLINE_LINUX instead of GRUB_CMDLINE_LINUX_DEFAULT and re-generate /boot/grub/grub.cfg.

Re: Can't make amd overclock parameter permanent at every boot

Reply #4
Hm, for some reason the amdgpu argument didn't make it in grub.cfg. Try adding it to GRUB_CMDLINE_LINUX instead of GRUB_CMDLINE_LINUX_DEFAULT and re-generate /boot/grub/grub.cfg.
Nope, still nothing.

Re: Can't make amd overclock parameter permanent at every boot

Reply #5
Another troll, do not bother any more

Re: Can't make amd overclock parameter permanent at every boot

Reply #6
question is, what you expect  from amdgpu.ppfeaturemask=0xfffffff in GRUB_CMD_LINE....
because by appending this kernel parameter will just  only unlock the access to adjust clocks and voltages ;-)
if you want overlocking, you still need do it manually or use a script/command:

for AMD GPU see https://wiki.archlinux.org/index.php/AMDGPU#Overclocking and https://www.reddit.com/r/Amd/comments/agwroj/how_to_overclock_your_amd_gpu_on_linux/

Re: Can't make amd overclock parameter permanent at every boot

Reply #7
question is, what you expect  from amdgpu.ppfeaturemask=0xfffffff in GRUB_CMD_LINE....
because by appending this kernel parameter will just  only unlock the access to adjust clocks and voltages ;-)
if you want overlocking, you still need do it manually or use a script/command:

for AMD GPU see https://wiki.archlinux.org/index.php/AMDGPU#Overclocking and https://www.reddit.com/r/Amd/comments/agwroj/how_to_overclock_your_amd_gpu_on_linux/

That, and also it opens a very advanced menu in the corectrl app. Otherwise you can't do much changes.

I solved it anyway, I just used grub-customizer to add that parameter, to the given line. Then saved it. It works on every boot now. Dunno why it didn't work with the wiki way, but it didn't work.