Skip to main content
Topic solved
This topic has been marked as solved and requires no further attention.
Topic: [SOLVED] Rtcwake not waking up from poweroff? (Read 134 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

[SOLVED] Rtcwake not waking up from poweroff?

I dont know if this is due to my bios, but rtcwake doesnt wake up my machine after a shutdown.
Code: [Select]
 rtcwake -u -m no -s 90 
works, and sets the timer alright in /sys/class/rtc/rtc0/wakealarm, and if i suspend my machine or give it -m mem then it will wake it up fine. The problem is that it wont power up from complete shutdown. I dont know if this is suposed to be happening, but if i shut it down manually and power it up, before the timer, /sys/class/rtc/rtc0/wakealarm is empty. Also some dmesg:
Code: [Select]
[    0.157641] PM: RTC time: 07:11:18, date: 2021-03-29
[    0.341327] rtc_cmos 00:03: RTC can wake from S4
[    0.341799] rtc_cmos 00:03: registered as rtc0
[    0.341897] rtc_cmos 00:03: setting system clock to 2021-03-29T07:11:18 UTC (1617001878)
[    0.341909] rtc_cmos 00:03: alarms up to one month, y3k, 242 bytes nvram, hpet irqs

Re: Rtcwake not waking up from poweroff?

Reply #1
This (complete power-off and wake up) is very BIOS-dependent and not officially supported by ACPI; it works in many setups though.
You can try to mess with the BIOS HPET timer by appending hpet=disable tsc=unstable to your boot commandline and see if that works. If not, your only options are either the builtin BIOS wakeup scheduler or a WOL signal from another computer.

Re: Rtcwake not waking up from poweroff?

Reply #2
This (complete power-off and wake up) is very BIOS-dependent and not officially supported by ACPI; it works in many setups though.
You can try to mess with the BIOS HPET timer by appending hpet=disable tsc=unstable to your boot commandline and see if that works. If not, your only options are either the builtin BIOS wakeup scheduler or a WOL signal from another computer.
Unfurtunately, it doesnt work, even with hpet and tsc set. I dont want to use wol and the bios doesnt have a wakeup scheduler.