Skip to main content
Topic: Gnome-Disk-Utility - Additional Dependency "libsystemd-dummy" Needed to Launch (Read 503 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

Gnome-Disk-Utility - Additional Dependency "libsystemd-dummy" Needed to Launch

Hello Artix Users!  I just registered on your forums because I noticed something while testing the newest LiveUSB.  I installed gnome-disk-utility (aka gnome-disks) but when I tried to launch it I was given this error message:
Code: [Select]
[[email protected] ~]$ gnome-disks
gnome-disks: error while loading shared libraries: libsystemd.so.0: cannot open shared object file: No such file or directory

An additional dependency has to be installed In order to get gnome-disks to properly launch.  This dependency is "libsystemd-dummy", which is available from the World repo.  Simply install it with this command:
Code: [Select]
sudo pacman -S libsystemd-dummy

Afterward, gnome-disks launched just fine.  I hope this post will help some of you who also had difficulty getting the gnome-disks package to work themselves.

Can this additional dependency be added to the gnome-disk-utility package so others will not need to install it separately?  If not, no big deal.  Just remember to add it yourselves when using any new Artix installation or LiveUSB.

    ~ Ev