Skip to main content
Topic: Gstreamer is not upgrading (Read 222 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

Gstreamer is not upgrading

Code: [Select]
gremlins/gstreamer              1.12.4-1              1.13.90+5+gcbd03e26c-1    0.57 MiB    

error: failed to commit transaction (conflicting files)
gstreamer: /usr/include/gstreamer-1.0/gst/base/gstaggregator.h exists in filesystem
gst-plugins-base-libs: /usr/include/gstreamer-1.0/gst/allocators/gstphysmemory.h exists in filesystem
gst-plugins-base-libs: /usr/include/gstreamer-1.0/gst/audio/gstaudioaggregator.h exists in filesystem
gst-plugins-base-libs: /usr/include/gstreamer-1.0/gst/gl/egl/gstegl.h exists in filesystem
gst-plugins-base-libs: /usr/include/gstreamer-1.0/gst/gl/egl/gsteglimage.h exists in filesystem
gst-plugins-base-libs: /usr/include/gstreamer-1.0/gst/gl/egl/gstgldisplay_egl.h exists in filesystem
gst-plugins-base-libs: /usr/include/gstreamer-1.0/gs ...
...
...
..
.
.


The list goes on and on.

Re: Gstreamer is not upgrading

Reply #1
Code: [Select]
gremlins/gstreamer              1.12.4-1              1.13.90+5+gcbd03e26c-1    0.57 MiB    

error: failed to commit transaction (conflicting files)
gstreamer: /usr/include/gstreamer-1.0/gst/base/gstaggregator.h exists in filesystem
gst-plugins-base-libs: /usr/include/gstreamer-1.0/gst/allocators/gstphysmemory.h exists in filesystem
gst-plugins-base-libs: /usr/include/gstreamer-1.0/gst/audio/gstaudioaggregator.h exists in filesystem
gst-plugins-base-libs: /usr/include/gstreamer-1.0/gst/gl/egl/gstegl.h exists in filesystem
gst-plugins-base-libs: /usr/include/gstreamer-1.0/gst/gl/egl/gsteglimage.h exists in filesystem
gst-plugins-base-libs: /usr/include/gstreamer-1.0/gst/gl/egl/gstgldisplay_egl.h exists in filesystem
gst-plugins-base-libs: /usr/include/gstreamer-1.0/gs ...
...
...
..
.
.


The list goes on and on.
Just delete or change the names of the existing files

Re: Gstreamer is not upgrading

Reply #2
They're from extra/gst-plugins-bad, either remove it or --force install.

Re: Gstreamer is not upgrading

Reply #3
what happened here? is gst-plugins-bad (and gst-plugins-ugly) not needed anymore? or do they need to be added to the artix rep (instead of extra) so they can be at the same version?
from what I can see, vlc/qt5-multimedia/gvfs all depend on gst-plugins-bad

 

Re: Gstreamer is not upgrading

Reply #4
I took @nous advice and forced it on and don't really see any problems with it yet.  Are they also a requirement for webkit2?
If coexistence results in any problematic behavior, that I can identify, I will report back.
Removing one thing to make room for another is not a good practice, I don't think. 

(Like a loop we may be going back to a debate that remained unsolved to the point of illogical, about sddm-runscripts.  Are they not necessary and if not why are they there?  If they are there they bring dbus-runscripts, and dbus-runscripts had to be replaced with dbus-runit, when there is no runit anywhere in the installation.  The solution was to remove sddm-runscripts.  Not good enough.  Insignificant little issues but reveal a slight sloppiness.)