Skip to main content
Topic: Fingerprint Scanner HP Elitebook 8440p (Read 1567 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

Fingerprint Scanner HP Elitebook 8440p

Hi everybody! I am trying to make my fingerprint scanner work but unfortunately I can't seem to do ANYTHING with it no matter what I do... The HP forums are VERY unhelpful, see for yourself:

Its like the HP forums are all just bots or something, I swear! Look at the response I got from that guy -.-
Its quite obvious I am asking HOW TO ENABLE, not disable!!

I've made YET ANOTHER post on the HP forums, in hopes that someone who has an actual brain in their head will reply.
"Please install Windows OS, then do this, then you can re-install Linux OS"  LOL! 
I was simply asking how to enable my fingerprint scanner in the BIOS settings. I really HATE people like this, the BIOS settings in my laptop are very confusing & I have absolutely no idea how to enable fingerprint scanning in there, but I do know for a fact that the BIOS can control fingerprint scanning because there was a fingerprint scanning option for the previous owner of this laptop when I first got it.

I've tried checkmarking the thing about resetting the fingerprint scanner on reboot, but it seems to have no effect on anything.

My goal is to have the fingerprint scanner working as an alternative to a CMOS power-on password, meaning its not working in Linux but on the BIOS.

Now, alternatively, I would like to make the fingerprint scanner work inside of Linux, but I am unsure of how to go about this.

lsusb gives me this info:
Bus 001 Device 003: ID 138a:0007 Validity Sensors, Inc. VFS451 Fingerprint Reader

 Not a clue how I am supposed to make this thing work in Linux, I have installed fprintd, libfprint but can't seem to make them do anything.

I made another post and yet I still get the same kind of brain-dead answers, the HP forums are full of illiterate people or bots.


Re: Fingerprint Scanner HP Elitebook 8440p

Reply #2
I figured out what I had to do, turns out I need Windows just to set the fingerprint scanner up so it works on boot-up.
Thankfully I kept the harddrive with windows on it that I got the computer with :P