Skip to main content
Topic: How to configure xinput for dolphin-emu? (Read 120 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

How to configure xinput for dolphin-emu?

Hello again everyone, I have been trying to play GameCube games on the dolphin-emu but it seems the controller input has a slight lag... I read that I should use Xinput, but the only options I see is the eudev ones... How do I make the Xinput work? I'm using a PS3 controller via bluetooth.

I've tried to do xinput enable but it doesn't seem to actually work... Could somebody please explain this to me? I really am having a tough time understanding this :(

I also have no "DirectInput" or "Dinput" options either, why is this? I just want my controller to work without rediculous input lag.... The game does not lag, its just the controller's input, I'm using a new NVIDIA card with VULKAN.

I only see Xinput2/0/Virtual core pointer in dolphin-emu's controller settings(as well as a few eudev ones, showing my PS3 controller, but no xinput one like that)... Why is this???

I don't get this input lag on other emulators...

Re: How to configure xinput for dolphin-emu?

Reply #1
I can't answer all your questions, but I can clear up some I hope.

Hello again everyone, I have been trying to play GameCube games on the dolphin-emu but it seems the controller input has a slight lag... I read that I should use Xinput, but the only options I see is the eudev ones... How do I make the Xinput work? I'm using a PS3 controller via bluetooth.

Well you more likely than not already have libinput and xf86-input-libinput installed. That's all you should need for xinput. I don't know if using bluetooth affects this though.

Quote
I also have no "DirectInput" or "Dinput" options either, why is this?

Because you aren't on Windows.

Quote
I only see Xinput2/0/Virtual core pointer in dolphin-emu's controller settings(as well as a few eudev ones, showing my PS3 controller, but no xinput one like that)... Why is this???

Xinput2 sounds right to me. Are you sure that's just not the name of whatever port you are using? I don't know how bad your input lag is, but I would expect simply using bluetooth would result in some input lag. If you are using the same setup on other emulators (i.e. ps3 + bluetooth) without getting so much input lag, then I don't know what the problem is.

Re: How to configure xinput for dolphin-emu?

Reply #2
I can't answer all your questions, but I can clear up some I hope.

Well you more likely than not already have libinput and xf86-input-libinput installed. That's all you should need for xinput. I don't know if using bluetooth affects this though.

Because you aren't on Windows.

Xinput2 sounds right to me. Are you sure that's just not the name of whatever port you are using? I don't know how bad your input lag is, but I would expect simply using bluetooth would result in some input lag. If you are using the same setup on other emulators (i.e. ps3 + bluetooth) without getting so much input lag, then I don't know what the problem is.


I don't get input lag on other emulators, my bluetooth works very well so its not my bluetooth. Why would bluetooth not be sufficient? I have version 4.1 or 4.0, with CSR and some other acronyms... There's also no delay whatsoever on sound that goes through my bluetooth too so I reject the idea that its just bluetooth.... the PS3 & 4 use bluetooth for their controllers also, so........

Re: How to configure xinput for dolphin-emu?

Reply #3
Xinput2 sounds right to me. Are you sure that's just not the name of whatever port you are using?

But I can't actually use xinput2 as an option!!!

Xinput2/0/Virtual core pointer      <--- does nothing for the controller, I can't configure controller buttons with this thing... only with the eudev option, I need xinput to work!

this is the only option I have for xinput!!! There has to be a way to make the controller be the default xinput device, but I don't know how to do that :( I tried xinput enable 13, 9, and some other numbers but I can't make it work.... Please does someone know anything about how to use xinput? I read that I have to use xinput because its the best but I just cannot figure it out!!!

Re: How to configure xinput for dolphin-emu?

Reply #4
If anyone knows how to get xinput configured, or has a link to good documentation about this, I would be very greatful for a bit of help. eudev seems to work OK with a decent bluetooth connection, but I hear xinput is better.