Skip to main content
Topic: virtualbox incompatible qt5 library [SOLVED] (Read 380 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

virtualbox incompatible qt5 library [SOLVED]

Since yesterday, I pressume due to an update (with gremlins on), I get this error trying to start virtualbox
Code: [Select]
 % virtualbox        
Qt FATAL: Cannot mix incompatible Qt library (version 0x50b01) with this library (version 0x50b00)

Trying to revert those three pkgs didn't make a difference, although I did not reboot because I thought libraries do not get loaded into ram they are just accessible on demand (??).
Code: [Select]
 pyqt5-common-5.10.1-6-x86_64
 python-pyqt5-5.10.1-6-x86_64
 qt5-webkit-5.212.0alpha2-18-x86_64

Code: [Select]
gremlins/pyqt5-common 5.10.1-6 [installed: 5.10.1-3]
gremlins/python-pyqt5 5.10.1-6 [installed: 5.10.1-3]
world/pyqt5-common 5.10.1-3 [installed]
world/python-pyqt5 5.10.1-3 [installed]
gremlins/qt5-webkit 5.212.0alpha2-18 (qt qt5) [installed: 5.212.0alpha2-15]
world/qt5-webkit 5.212.0alpha2-15 (qt qt5) [installed]

Since this didn't revert the problem cause I am clueless what the problem now is





21/6/2018:   SOLVED:  Qr5-base needed an update and this is where the discrepancy was coming from