Skip to main content
Topic solved
This topic has been marked as solved and requires no further attention.
Topic: Linux-zen kernel panic init error (Read 239 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

Linux-zen kernel panic init error

Hey guys, the linux-zen 4.17.3 kernel is causing me kernel panics, I have tried adding in init=/usr/bin/runit-init
but so far no luck. I have tried init=/usr/bin/runit too.

Code: [Select]
Failed to execute /init (error -2)
Kernel panic - not syncing: Requested init /usr/bin/runit-init failed (error -2).
CPU: 3 PID: 1 Comm: swapper/0 Not tainted 4.17.3-1-zen #1
Hardware name: To be filled by O.E.M. to be filled by O.E.M./M5A97 R2.0, BIOS 2603 06/26/2015
Call Trace:
dump_stack+0x5c/0x77
? rest_init+0xf/0xc5
panic+0xe7/0x247
? do_execveat_common.isra.40+0xb2/0xf60
? rest_init+0xc5/0xc5
kernel_init+0xab/0xfa
ret_from_fork+0x22/0x40
Kernel Offset: 0x17000000 from 0xffffffff81000000 (relocation range: 0xffffffff8000000-0xfffffffbffffff
---[ end Kernel panic - not syncing: Requested init /usr/bin/runit-init failed (error -2). [---

And when I don't add an init= it says
"No working init found. Try passing init= option to kernel."

I tried downgrading back to 4.17.2 but its also doing the same thing now.... wtf????
the linux-lts kernel I installed is doing the same thing too!!! OMG!

One of my other computers upgraded to 4.17.3 just fine -.- ugh


Re: Linux-zen kernel panic init error

Reply #2
Try to regenerate the initramfs. Looks like the initramfs is borked.

Also, are you sure /usr/bin/init (or at least /usr/bin/runit-init) exist in your installation?
the runit guy on artix

Re: Linux-zen kernel panic init error

Reply #3
No Chris I have that, its in the 'base' group, my runit installation is fairly new so of course it has it. I have checked that.
I did a re-install but now its doing this to me.... AGAIN!

Yes, /usr/bin/runit and runit-init both exist.

Re: Linux-zen kernel panic init error

Reply #4
I just tried chroot'ing into it and it looks like its impossible to save... I refreshed the initramfs and re-updated the grub but its STILL doing this.... this is the second time its done this now, I re-installed initially, but its doing it again now!! and its both Linux-zen and Linux kernels...

Re: Linux-zen kernel panic init error

Reply #5
Can you show me the output of these commands:
Code: [Select]
ls -al /
ls -al /usr
ls -al /usr/bin

The output will likely be large on the last one, please use a pastebin service.
Chris Cromer

Re: Linux-zen kernel panic init error

Reply #6
I just did ANOTHER fresh install, and its doing it AGAIN on the "linux" kernel because there was an update for the "linux" kernel...  I am blocking updates for linux-zen now, this is beyond rediculous.... I don't have time to do a fresh install every time there's a kernel update... I don't wanna have to do a full re-install every week, its extremely tiresome & I have better things to be doing, why is it doing this? This literally makes no sense.... I am installing Artix runit through basestrap with the unstable repos disabled. What is causing this!? I just don't get it.... re-installing the kernel doesn't help.... now I am afraid to mess with anything because it'll force me into having to do another re-install...

https://pastebin.com/QtBg4PyB

Code: [Select]
total 48
drwxr-xr-x   1 root root  122 Jul  7 14:54 .
drwxr-xr-x   1 root root  122 Jul  7 14:54 ..
lrwxrwxrwx   1 root root    7 Jan  9 09:13 bin -> usr/bin
drwxr-xr-x   1 root root  278 Jul  7 19:07 boot
drwxr-xr-x  19 root root 3300 Jul  7 19:42 dev
drwxr-xr-x   1 root root 2740 Jul  7 19:42 etc
drwxr-xr-x   1 root root    4 Jul  7 14:58 home
lrwxrwxrwx   1 root root    7 Jan  9 09:13 lib -> usr/lib
lrwxrwxrwx   1 root root    7 Jan  9 09:13 lib64 -> usr/lib
drwxr-xr-x   1 root root    0 Jan  9 09:13 mnt
drwxr-xr-x   1 root root   90 Jul  7 18:39 opt
dr-xr-xr-x 279 root root    0 Jul  7 19:42 proc
drwxr-x---   1 root root   60 Jul  7 18:46 root
drwxr-xr-x  21 root root  540 Jul  7 19:42 run
lrwxrwxrwx   1 root root    7 Jan  9 09:13 sbin -> usr/bin
drwxr-xr-x   1 root root   14 Jul  7 14:54 srv
dr-xr-xr-x  13 root root    0 Jul  7 19:42 sys
drwxrwxrwt   7 root root  280 Jul  7 19:42 tmp
drwxr-xr-x   1 root root   94 Jul  7 17:50 usr
drwxr-xr-x   1 root root  100 Jul  7 14:54 var

Code: [Select]
total 20
drwxr-xr-x 1 root root     94 Jul  7 17:50 .
drwxr-xr-x 1 root root    122 Jul  7 14:54 ..
drwxr-xr-x 1 root root  78544 Jul  7 19:16 bin
drwxr-xr-x 1 root root  23262 Jul  7 17:46 include
drwxr-xr-x 1 root root 168818 Jul  7 18:36 lib
drwxr-xr-x 1 root root  46070 Jul  7 19:07 lib32
drwxr-xr-x 1 root root     32 Jul  7 17:23 lib64
drwxr-xr-x 1 root root     46 Jul  7 17:52 libexec
drwxr-xr-x 1 root root     72 Jul  7 14:54 local
lrwxrwxrwx 1 root root      3 Jan  9 09:13 sbin -> bin
drwxr-xr-x 1 root root   4420 Jul  7 18:45 share
drwxr-xr-x 1 root root     46 Jul  7 16:05 src

Re: Linux-zen kernel panic init error

Reply #7
And yes artix-sysvcompat is installed, even though I am using runit.... could that be a problem? Should that be there when I am using runit? sysvcompat for runit? Kind of odd, but I don't really know what that package is, so....

What else could possibly be going wrong?! Whenever there's a kernel update, any kernel update, it borks my system & then I have to chroot into it from a usb to save my precious files.... I've never encountered a problem like this til I switched to artix runit....

the only things I really change in text files is

scsi_mod.use_blk_mq=1 rd.md=0 rd.dm=0 in /etc/default/grub

________________________________________________________

# set deadline scheduler for non-rotating disks
ACTION=="add|change", KERNEL=="sd[a-z]", TEST!="queue/rotational", ATTR{queue/scheduler}="mq-deadline"
ACTION=="add|change", KERNEL=="sd[a-z]", ATTR{queue/rotational}=="0", ATTR{queue/scheduler}="mq-deadline"

# set cfq scheduler for rotating disks
ACTION=="add|change", KERNEL=="sd[a-z]", ATTR{queue/rotational}=="1", ATTR{queue/scheduler}="bfq"

in /etc/udev/rules.d/60-schedulers.rules

____________________________________________________________

and, discard is enabled in /etc/lvm/lvm.conf, dofstrim enabled in /etc/cron.weekly, and crypttab config'ed for discard.

Those are the only things I really change, other than maybe like, auto-logging with LXDM, qt5ct settings, pacaur settings, I can't think of anything else I am changing.... Nothing that I can think of... I know its not when nvidia-dkms updates because otherwise my linux-zen kernel would've just been made unuseable just a few minutes ago. IDK what to do, I'm officially lost & confused.

Re: Linux-zen kernel panic init error

Reply #8
And yes artix-sysvcompat is installed, even though I am using runit.... could that be a problem? Should that be there when I am using runit? sysvcompat for runit? Kind of odd, but I don't really know what that package is, so....

What else could possibly be going wrong?! Whenever there's a kernel update, any kernel update, it borks my system & then I have to chroot into it from a usb to save my precious files.... I've never encountered a problem like this til I switched to artix runit....

the only things I really change in text files is

scsi_mod.use_blk_mq=1 rd.md=0 rd.dm=0 in /etc/default/grub

________________________________________________________

# set deadline scheduler for non-rotating disks
ACTION=="add|change", KERNEL=="sd[a-z]", TEST!="queue/rotational", ATTR{queue/scheduler}="mq-deadline"
ACTION=="add|change", KERNEL=="sd[a-z]", ATTR{queue/rotational}=="0", ATTR{queue/scheduler}="mq-deadline"

# set cfq scheduler for rotating disks
ACTION=="add|change", KERNEL=="sd[a-z]", ATTR{queue/rotational}=="1", ATTR{queue/scheduler}="bfq"

in /etc/udev/rules.d/60-schedulers.rules

____________________________________________________________

and, discard is enabled in /etc/lvm/lvm.conf, dofstrim enabled in /etc/cron.weekly, and crypttab config'ed for discard.

Those are the only things I really change, other than maybe like, auto-logging with LXDM, I can't think of anything else I am changing.... Nothing that I can think of... I know its not when nvidia-dkms updates because otherwise my linux-zen kernel would've just been made unuseable just a few minutes ago. IDK what to do, I'm officially lost & confused.
I believe I see the problem. Could you run this for me:
Code: [Select]
ls -al /usr/lib64
Chris Cromer

Re: Linux-zen kernel panic init error

Reply #9
WOW you're good Chris, thanks man. I really appreciate this.


Code: [Select]
total 8
drwxr-xr-x 1 root root   32 Jul  7 17:23 .
drwxr-xr-x 1 root root   94 Jul  7 17:50 ..
-rw-r--r-- 1 root root 4812 Jul  7 17:10 libdiscord-rpc.a

Re: Linux-zen kernel panic init error

Reply #10
When I installed dolphin-emu-fresh it told me /usr/lib64 already exists & it wouldn't install unless I did sudo pacman -U --force

so is that the problem? That's really weird, its like, the wrong permissions for that directory thats causing this?

Code: [Select]
pkgname=dolphin-emu-fresh
pkgver=5.0
pkgrel=1
pkgdesc='A GameCube / Wii / Triforce emulator'
arch=('x86_64')
url='http://www.dolphin-emu.org/'
license=('GPL')
depends=('alsa-lib' 'bluez-libs' 'cairo' 'enet' 'gcc-libs' 'gdk-pixbuf2'
         'glib2' 'glibc' 'gtk2' 'hidapi' 'libevdev' 'libgl' 'libpng' 'libpulse'
         'libsm' 'libx11' 'libxi' 'libxrandr' 'libxxf86vm' 'lzo' 'mbedtls'
         'miniupnpc' 'pango' 'sfml' 'zlib' 'pulseaudio' 'ffmpeg' 'pugixml'
'bluez' 'bluez-utils-compat' 'bluez-firmware' 'bluez-plugins'
'bluez-libs' 'bluez-qt' 'bluez-tools' 'curl' 'xorg-xinput'
         'libeudev' 'libusb' 'libgusb' 'libusb-compat' 'lib32-libusb' 'libtiger'
'pangomm' 'pangox-compat' 'libglvnd' 'sndio' 'alsa-plugins' 'alsa-firmware'
'alsa-utils' 'alsa-lib' 'pulseaudio-alsa' 'alsa-oss' 'vulkan-headers' 'vulkan-validation-layers'
'vulkan-trace' 'vulkan-extra-layers' 'vulkan-icd-loader' 'nvidia-utils' 'spirv-tools')

makedepends=('cmake' 'git' 'qt5-base' 'pango' 'fakeroot')
source=('dolphin::git+https://github.com/dolphin-emu/dolphin.git')
sha256sums=('SKIP')

build() {
#git clone https://github.com/dolphin-emu/dolphin.git
mkdir -p dolphin/build
cd dolphin/build

cmake .. \
-DOpenGL_GL_PREFERENCE=GLVND \
-DUSE_X11=1 \
-DUSE_EGL=1 \
-DUSE_SHARED_ENET=TRUE \
-DCMAKE_INSTALL_PREFIX=/usr \
-DENABLE_QT2=TRUE \
-DCMAKE_BUILD_TYPE=Release

make -j16
}

package() {
cd dolphin/build

make DESTDIR="${pkgdir}" install
install -Dm 644 ../Data/51-usb-device.rules -t "${pkgdir}"/usr/lib/udev/rules.d/
}


# vim: ts=2 sw=2 et:


Re: Linux-zen kernel panic init error

Reply #11
WOW you're good Chris, thanks man. I really appreciate this.


Code: [Select]
total 8
drwxr-xr-x 1 root root   32 Jul  7 17:23 .
drwxr-xr-x 1 root root   94 Jul  7 17:50 ..
-rw-r--r-- 1 root root 4812 Jul  7 17:10 libdiscord-rpc.a
Alright, run these commands:
Code: [Select]
mv /usr/lib64 /usr/lib64-bkp
ln -s lib /usr/lib64
cp /usr/lib64-bkp/* /usr/lib
rm -rf /usr/lib64-bkp

If this fixes it, I will tell you how and why it broke. If not, we keep searching.
Chris Cromer

Re: Linux-zen kernel panic init error

Reply #12
I don't think it fixed it... what should I do after I fix that, should I just try to boot up the "linux" kernel? Or is there something else I should do? Perhaps I should re-install the "linux" kernel now? idk... because it didn't seem to work...

Re: Linux-zen kernel panic init error

Reply #13
You should reinstall the default linux kernel and test with that first, after we get things working you can go back to zen. Also rebuild your initramfs.
Chris Cromer

Re: Linux-zen kernel panic init error

Reply #14
OMG! I think that fixed it! Thank you Chris! I re-installed "Linux" and now the "Linux" kernel works! woohoo!
Now please, explain to me what this is all about, I don't understand how this works, how does this affect that?
How does /usr/lib64 affect the kernel? O.o

And my linux-zen still works - it was the "Linux" kernel that stopped working because of an update.