Skip to main content
Topic: CMake / libsystemd (Read 286 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

CMake / libsystemd

Hai all,
 Does cmake  detect libeudev as libsystemd? I want to build an AUR pkg that requires libsystemd. But cmake's initial check stops, saying no libsystemd installed.
Thanks.
The sig to end all sigs.

Re: CMake / libsystemd

Reply #1
Hello,
AUR is a big world, can you name the package which you want to build ?

Udev should be recognized with pkgconfig when you search for module udev.
It works for systemd version and also for eudev.

When using cmake you can also create your own search modules,
so anything is possible.

If you want help, post link to the AUR package which you want to build,
so we (forum readers) can check it.
Happy falling


Re: CMake / libsystemd

Reply #3
Hello,
said program is searching for libsystemd.
https://github.com/anbox/anbox/blob/master/CMakeLists.txt#L71

As Artix does not support systemd, there is not an easy way to build said program.
Try to ask the program developers for help "How to build this without systemd"
Or investigate it and purge systemd from it
According to what i found they are using systemd for dbus support.
Happy falling

Re: CMake / libsystemd

Reply #4
The program's cmake probably needs to be patched to look for libudev instead.
Arch's libsystemd has libudev bundled with it, and usually, its the libudev functions other programs require for device management.

Re: CMake / libsystemd

Reply #5
Did you mean libeudev or actually libudev which should be a link to libeudev?
libsystemd-dummy doesn't provide this function in it, does it?

Re: CMake / libsystemd

Reply #6
I think their dependencies on systemd is deeper than just udev. Looking at a Gentoo ebuild and their AUR PKGBUILD, it seems their network stack also depends on systemd.
the runit guy on artix

Re: CMake / libsystemd

Reply #7
Busy with work. Thank you everyone for looking into this topic. :)
The sig to end all sigs.


Re: CMake / libsystemd

Reply #9
try to install and use libsystemd-dummy

Re: CMake / libsystemd

Reply #10
try to install and use libsystemd-dummy
that will not work when you want to compile this SW.
It is searching for systemd via pkgconfig.
Configuration / search module for pkgconfig is provided by systemd but not systemd-dummy.
This SW also needs systemd specific headers which are not provided by systemd-dummy.
It is not called dummy for no reason :D
Happy falling