Skip to main content
Topic: Steam-Native-Runtime [Solved] (Read 363 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

Steam-Native-Runtime [Solved]

Hey guys, I'd like to get Steam-Native-Runtime to work without systemd / systemd-dummy / libsystemd-dummy.

Any ideas on how we can do that? What does it depend on in systemd? Could we make it work through elogind or eudev or something?  Any ideas where upstream is? I checked the arch package but 'upstream' just links me to a wiki, do you guys think this is something we could compile without systemd? I don't know where the upstream for it is, or how to begin investigating this.

If I can understand it & make it work, I'd happily maintain upgrades on the AUR and/or in the Artix repos.

Re: Steam-Native-Runtime

Reply #1
Steam-Native-Runtime is just metapackage nothing more.
As it is described on wiki:
Quote
The steam-native script launches Steam with the STEAM_RUNTIME=0 environment variable making it ignore its runtime and only use system libraries.
https://wiki.archlinux.org/index.php/Steam/Troubleshooting#Steam_native_runtime

IIRC: Steam support only Ubuntu where systemd is standard.

Quote
Hey guys, I'd like to get Steam-Native-Runtime to work without systemd / systemd-dummy / libsystemd-dummy.
Because it is not OpenSource Software you can only ask Valve to not require systemd.
Happy falling

Re: Steam-Native-Runtime

Reply #2
steam-native-runtime doesn't have any systemd dependencies, unless I'm missing something.
the runit guy on artix


Re: Steam-Native-Runtime

Reply #4
Steam from Arch repos works without problems on Artix


Re: Steam-Native-Runtime

Reply #6
Well there is dbus.
dbus is different from systemd.


Code: [Select]
pactree -s steam-native-runtime

reveals that arch's libudev-shim package has a libsystemd depend. :)
Looking at its code, I think the only "systemd" part it depends on is udev. I'm rolling out updates for both libudev0-shim and lib32-libudev0-shim to make it depend on eudev.
the runit guy on artix

Re: Steam-Native-Runtime

Reply #7
I forgot about this post, oops. Glad to hear the package was fixed though! Thanks guys!