Skip to main content
Topic solved
This topic has been marked as solved and requires no further attention.
Topic: [SOLVED] getting rid of pulse audio (Read 12331 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

Re: getting rid of pulse audio

Reply #75
I think I mentioned it before, I installed apulse, created .asoundrc in my ~/ and I have not had any sound problems since.
apulse is not pulseaudio, it is alsa.

Re: getting rid of pulse audio

Reply #76
I like old FF design and functions so i was using Classic Theme Restorer.
I'm using Waterfox to this very day with that very addon. I have never used pulseaudio with Artix, but i have apulse just in case.

Re: getting rid of pulse audio

Reply #77
Sorry for necro, trying to remove pulseaudio but
Code: [Select]
$ pacman -R pulseaudio
complains that gnome-settings-daemon, paprefs, pulseaudio-alsa and pulseaudio-bluetooth depend on it. In return, gnome-bluetooth depends on pulseaudio-bluetooth. Is there a way to remove pulseaudio without having to recompile the entire GNOME from source?

Re: getting rid of pulse audio

Reply #78
one way is to force pacman to remove package without caring for deps.
If you do so you can get broken system (GNOME and such)

If you are brave enough, you can try:
Spoiler (click to show/hide)
Man is as good as his tools.

Re: getting rid of pulse audio

Reply #79
How can I get rid of pulse audio and still keep firefox?
I am using Firefox without pulseaudio:
sudo pacman -Rsu pulseaudio
sudo pacman -S qastools

Code: [Select]
jp-artix:[jp]:~$ neofetch
                   '                      [email protected]
                  'o'                     -----------
                 'ooo'                    OS: Artix Linux x86_64
                'ooxoo'                   Host: Aspire ES1-732 V1.18
               'ooxxxoo'                  Kernel: 5.7.12-artix1-1
              'oookkxxoo'                 Uptime: 3 hours, 24 mins
             'oiioxkkxxoo'                Packages: 1027 (pacman)
            ':;:iiiioxxxoo'               Shell: bash 5.0.17
               `'.;::ioxxoo'              Resolution: 1600x900
          '-.      `':;jiooo'             DE: Xfce
         'oooio-..     `'i:io'            WM: Xfwm4
        'ooooxxxxoio:,.   `'-;'           WM Theme: Daloa
       'ooooxxxxxkkxoooIi:-.  `'          Theme: Adwaita [GTK2], Artix-dark [GT
      'ooooxxxxxkkkkxoiiiiiji'            Icons: oxygen [GTK2], breeze [GTK3]
     'ooooxxxxxkxxoiiii:'`     .i'        Terminal: xfce4-terminal
    'ooooxxxxxoi:::'`       .;ioxo'       Terminal Font: Monospace 12
   'ooooxooi::'`         .:iiixkxxo'      CPU: Intel Pentium N4200 (4) @ 2.500G
  'ooooi:'`                `'';ioxxo'     GPU: Intel Celeron N3350/Pentium N420
 'i:'`                          '':io'    Memory: 2025MiB / 3758MiB

Re: getting rid of pulse audio

Reply #80
How can I get rid of pulse audio and still keep firefox?

Gday
I am one week into using artix

My solution after removing Pulse audio
was to use LibreWolf instead of Default Firefox or Waterfox Classic

LibreWolf works in ALSA only mode
It also supports disable third party cookies
It also works with ublock origin + noscript

I got it from AUR (pamac)
https://librewolf-community.gitlab.io/

Re: getting rid of pulse audio

Reply #81
Ohh, thanks for advice the librewolf, it's similar as ungoogled-chromium project. I will test it and probably i add this to our Artix's universe repo . 👍👍👍

Re: getting rid of pulse audio

Reply #82
Ohh, thanks for advice the librewolf, it's similar as ungoogled-chromium project. I will test it and probably i add this to our Artix's universe repo . 👍👍👍


Awesome , cheers

Since Waterfox sold its soul to another corporate company I was looking for a new browser
I actually first got told about it on IRC
then came across this video on censortube - https://www.youtube.com/watch?v=6lnG-YD_qNQ
Gave it a go and very impressed

It has some copy paste issues with gab.com, but besides that, everything else works
and it doesnt need PULSE AUDIO

Re: getting rid of pulse audio

Reply #83
At this point I would just recommend  Four browsers

*  LibreWolf  - https://librewolf-community.gitlab.io/
*  Iridium - https://iridiumbrowser.de/
* ungoogled chromium - https://github.com/Eloston/ungoogled-chromium
* Librefox over the top Tor Browser - https://github.com/intika/Librefox
https://www.ghacks.net/2018/12/24/librefox-firefox-with-privacy-enhancements/

I would get rid of
default tor
default chrome
default Firefox
default brave


Can we trust ANY corporation globally anymore ?

Re: getting rid of pulse audio

Reply #84
Ohh, thanks for advice the librewolf, it's similar as ungoogled-chromium project. I will test it and probably i add this to our Artix's universe repo . 👍👍👍

If you add Librewolf to Universe I will be the first to install it. I will be appreciate. I don't want to install more packages from AUR.
Artix Linux Colombia

Re: getting rid of pulse audio

Reply #85
If you add Librewolf to Universe I will be the first to install it. I will be appreciate. I don't want to install more packages from AUR.
LibreWolf delivered to the universe, pulseaudio is optional

Re: getting rid of pulse audio

Reply #86
I am using Firefox without pulseaudio:
sudo pacman -Rsu pulseaudio
sudo pacman -S qastools

I just used
Code: [Select]
pacman -Rc pulseaudio
That got rid of gnome-control-center and gnome-tweaks, but since I already switched to dwm and suckless tools in the meantime, I don't mind as much anymore. For videos/Youtube I either use Vivaldi or
Code: [Select]
youtube-dl <url> -o - | mpv -
:)