Skip to main content
Topic solved
This topic has been marked as solved and requires no further attention.
Topic: problem in linux 4.18.8.artix1-1 package (Read 317 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

problem in linux 4.18.8.artix1-1 package

Hi,
I've upgraded my system and the kernel 4.18.8.artix1-1 has been installed. I've rebooted my pc and now I can't enter my luks password. On the screen there is:
Code: [Select]
:: running early hook [udev]
:: running hook [udev]
calling: trigger
calling: trigger
calling: settle

So, I've booted  from a usb disk, I've entered my luks partition and I've installed /var/cache/pacman/pkg/linux-4.18.4.artix1-1-x86_64.pkg.tar.xz
Now I've rebooted and everything works fine. I've only installed the old kernel and I've changed nothing else, so there is a problem with linux-4.18.8.artix1-1-x86_64.pkg.tar.xz

Bye

Re: problem in linux 4.18.8.artix1-1 package

Reply #1
That is very odd. I have an LVM+LUKS setup on the latest artix kernel without any problems. The difference is that I use a keyfile instead of entering a password, but I don't see why that would really matter. I know this is a lame question, but are you totally certain that mkinitcpio built initramfs correctly? It's happened to me before where mkinitcpio randomly failed (I wasn't paying attention and didn't notice it until I checked the logs later) and thus messed up my encryption. I just ran it again later and it was fine.

Re: problem in linux 4.18.8.artix1-1 package

Reply #2
Thanks for your reply!
I've reinstalled latest (4.18.8)  kernel package,  mkinitcpio has built initramfs correctly but after rebooting, there is the same problem...

If I wait 60 seconds, there are other messages.

Then I've reinstalled the old kernel (4.18.4) and  the boot is ok.


Re: problem in linux 4.18.8.artix1-1 package

Reply #4
Yes!!! it is an old dual core intel! I'll wait 4.18.9 kernel.
Mistery solved: thanks a lot!!!!!!!!!  :)