Skip to main content
Topic: strange problem with plasma unresponsive (mostly) (Read 285 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

strange problem with plasma unresponsive (mostly)

The problem is a laptop I don't use too often (meaning I really don't know which update seemed to cause this)  After a recent update, plasma (started by sddm) was essentially unresponsive.  Clicking on things had no effect, but switching to a text console and back would update the screen (gkrellm, for example.) 

At first, I blamed baloo_file_extractor, which iotop said was using 99% of the io.  However, after multiple tries and reboots, I got that to no longer run, and top shows over 90% idle, but plasma is still essentially unresponsive.  Sometimes clicking on an app (konsole, for example) and on the background updates the screen, but running top, for example ONLY updates when I click off and then back on konsole.  I see nothing unusal in dmesg, /var/log/messages.log, or /var/log/Xorg.0.log.

ssh'ing in to the box works ok, and everything in one of the text colsoles works fine also.

I'm fully up to date - using gremlins, system, world, galaxy-gremlins, galaxy, extra, and community.  The only odd thing is that openrc 0.39.1-1 was newer than system 0.38.3-1.  I can only assume that was temporarily on gremlins and later pulled?  0.39.1 is also in the cache.  Reverting to 0.38.3-1 didn't make any difference.

Any suggestions on how to troubleshoot this? 

Re: strange problem with plasma unresponsive (mostly)

Reply #1
I am not familiar with plasma so you have to fill in the blank.  I am pretty sure you have an openbox option on sddm to start instead of plasma.   Try this, open a terminal, maybe xterm then your preferred terminal, and there should be some plasma-session command, so try to start the session from the terminal.  Errors and warnings will appear on that terminal that should give you a clue.

Also  /var/log/pacman.log will show you what has changed since your last good session and you can revert what you suspect or all.  This doesn't help identify the problem but at least gives you a functional workstation.
anti-X  - artix - obarun - Void - systemD Free Space

I can no longer participate in a public forum side by side with neo-nazis and NSA trolls in a moderated sterile environment that is good for business.
Obviously the terms Open and Free mean nothing to you, or your business!


Re: strange problem with plasma unresponsive (mostly)

Reply #2
Interesting thought, but didn't help.  I have the choice of KDE, openbox/KDE (both of which do the same, lxqt (still haven't tried yet - soon), and openbox, which gives me a gray screen with mouse pointer, but nothing else.  I was able to set DISPLAY and launch stuff from the text console, but then have the same problem of everything unresponsive unless I switch to a different console and back.  I'm not sure how to quit this particular session other than rebooting, but will try.  (I know I can just kill X, but I"m not sure if that's clean enough or will leave loose ends around.)

Re: strange problem with plasma unresponsive (mostly)

Reply #3
gremlins repos are for testing/beta packages. Is this intentional?

Re: strange problem with plasma unresponsive (mostly)

Reply #4
Yes, definitely intentional.  I've certainly gotten into some interesting positions with that, but (often with help from this group) I've managed to figure things out.  My main desktop is Gentoo, where the phrase (especially if you use testing versions of packages) that if things break, you get to pick up the pieces yourself :-).   Is there anything particular in gremlins that I should look at as a possible cause of my issue?

For some more details, I confirm I get essentially the same behaviour in KDE/Openbox, LXQt Desktop, and Plasma.  (Openbox gives me a gray screen with mouse pointer but nothing else.)  At first, the menus seem to work correctly, but once I run some application, in order to get the screen to update, I have to Alt-Tab or click off and back on the app, and sometimes even that doesn't work, and I need to switch to a different console and back.

I'm starting to look more deeply into X related stuff and video drivers.  This is a fairly new Lenovo Ideapad 320 laptop with Radeon R7 graphics as part of the A12-9720P CPU.  I suppose I can also try downgrading everything from gremlins and then upgrade one at a time to see if I can find the culprit.

Re: strange problem with plasma unresponsive (mostly)

Reply #5
Well, I still have no idea what caused the problem or what fixed it, but as of a week or two ago (maybe longer?) the system is behaving just fine.  I don't know whether to blame cosmic rays, phase of the moon, or a bug that crept into some package, and got fixed with a later update.