Skip to main content
Topic solved
This topic has been marked as solved and requires no further attention.
Topic: [SOLVED] nm-dispatcher spam (Read 154 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

[SOLVED] nm-dispatcher spam

I have a fresh install of the artix-base-openrc on a x220. No gui, the only packages I installed are sudo and lynx. Upon start-up this is what the login screen looks like:
Code: [Select]
Artix Linux 4.19.2-artix1-1-ARTIX (tty1)

hostname login: nm-dispatcher: req3 'up' [enp0xxx] : new request (1 scripts)
nm-dispatcher  req:3 'up' [enp0xxx]: start running ordered scripts
nm-dispatcher req:4 'connectivity-change' : new request (1 scripts)
nm-dispatcher req:4 'connectivity-change' : start running ordered scripts
The closest thing i could find to my problem is here:
https://forums.gentoo.org/viewtopic-t-1055866-start-0.html
The problem is a logger was not running for that person.  Here is what I did but it did not work:
Code: [Select]
$pacman -S syslog-ng
$cp /bin/syslog-ng /etc/init.d
$cd /etc/runlevel/boot
$ln -s /bin/syslog-ng
As far as i can tell the internet is working fine, i can ping with zero package loss.

Re: nm-dispatcher spam

Reply #1
You said you're on openrc, what you did is (roughly...) for runit; remove syslog-ng from /etc/init.d and /etc/runlevel/boot, install syslog-ng-openrc and activate  it:
Code: [Select]
% sudo pacman -S syslog-ng-openrc
% sudo rc-service syslog-ng start
% sudo rc-update add syslog-ng

 

Re: nm-dispatcher spam

Reply #2
Did a few reboots, the messages are gone. Thank you for your help.