Skip to main content
Topic: Internet issues after upgrade (Read 668 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

Re: Internet issues after upgrade

Reply #30
The 'dhcpcd timeout' error means that your wireless card lost connection with the access point. If this doesn't happen with Arch or Manjaro, then your wifi card doesn't work as it should with Artix which might be because it needs special firmware (most broadcomm cards do).
What's the output of lspci|grep -i net?
Also, install hwdetect and post the output of hwdetect --show-net

Re: Internet issues after upgrade

Reply #31
Hey, thank you for fast response :).

Well i do this trick to make dhcpcd usable, i basically create hook (wpa_supplicant and dhcpcd) and edit /etc/wpa_supplicant/wpa_supplicant.conf and i manage to get connection via dhcpcd interface (wlp3s0) while networkmanager is running and connected to wireless hotspot. If i don't connect to the connection using networkmanager then i get 'dhcpcd timeout' error. So i basically after fresh installation of /root what i do is connect to the hotspot using networkmanager and then dhcpcd will go through and connect me to it and i can then remove networkmanager and everything gonna be okay then and can use dhcpcd forever after this.

However it gets tricky when i tried to install artix base openrc today. I'v looked up wikis on gentoo but no luck. wpa_supplicant -B -i... command won't connect me as well... So i am not sure why networkmanager gets no problem with connecting to the hotspot but dhcpcd is tricky.
And i also was installing arch linux yesterday and majaro few days ago and i was able to configure dhcpcd and connect to it without any problem (while still in tty1 prompt).

So this is output of lspi|grep -i net
Code: [Select]
# lspci|grep -i net
03:00.0 Network controller: Qualcomm Atheros QCA9377 802.11ac Wireless Network Adapter (rev 31)
04:00.1 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 12)

and hwdetect --show-net
Code: [Select]
# hwdetect --show-net
NET      : r8169 fjes libphy ath10k_core ath10k_pci ath bluetooth mac80211 rfkill cfg80211

You may be right about firmware because i remember when i installed trisquel os and pureOS some derivatives of
Both of these distros wouldn't create any wireless scan because it didn't have any drivers, i think this wireless card here may be crapware stuff but not sure.
I was able to download drivers for it and make wifi run on pureOS, however Trisquel was no luck.

I keep thinking almost all the time about buying some nice USB wireless adapter.... I wonder if that would be better than the card provided with laptop.

Re: Internet issues after upgrade

Reply #32
Atheros cards are well and fully supported and I'm running out of ideas. Save /etc/wpa_supplicant from Arch or Manjaro somewhere and copy it over to Artix.

Re: Internet issues after upgrade

Reply #33
i have done it before ;).

i run out of ideas as well... Especially because if i don't set up watch -n10 -x dhcpcd wlp3s0 after i get carrier then i get resolve problems all the time on artix, arch or even manjaro... same issue... I guess i have to struggle with it and try to get proper wired connection at some point in the future...
I think that wireless is pain anyways and for some reason i never felt like this, but after i installed artix for first time i slowly started to become anti wifi and i slowly more and more dislike it... I'm not really into internet stuff but i think wifi is a joke.

Well today i installed arch linux but then i can't configure grub... It's too much problems. And manjaro has it's own grub and i don't like this fact. I wanted to try install base linux for first time, and obviously life happens and 1) don't have access to wired internet 2) setting up wifi in my case is pain.

I wondered if base .iso of artix has something from networkmanager... Well internet and all this stuff here on arch is very big mistery to me anyways... But then what else is there for me to use?? Devuan?? :PP.
And perhaps maybe it's easy to set up wireless connection but i think for linuxing and stuff wired is the way to go... Gotta aim for it ;). It's a shame that internet is so expensive nowadays. 30 or 40 pounds a month???

edit1: maybe simply dhcpcd service is off and i need to turn it on??
edit2: i also think that this wireless adapter i have here needs non-free drivers.
edit3: this is what happens when i try to connect using wpa supplicant
Code: [Select]
# wpa_supplicant -B -i wlp3s0 -c <(wpa_passphrase "correctssid" "correctpassword")
Successfully initialized wpa_supplicant
nl80211: Could not set interface 'p2p-dev-wlp3s0' UP
nl80211: deinit ifname=p2p-dev-wlp3s0 disabled_11b_rates=0
p2p-dev-wlp3s0: Failed to initialize driver interface

Re: Internet issues after upgrade

Reply #34
1 dhcpcd should be a running service  (depending on whether you are on runit or openrc look it up on the wiki for openrc/runit)
2 the drawback of running wifi cards that only properly run on non-free firmware ...  which is almost all.  (read up on the hyperbola site what it takes to run wifi with free software).
3 you might need a more expert advise than I can help you with.  Are you running this as user or root?  Does /etc/group have you as network authorized?  Wild guess.  Do you get the same error running the same command with $ sudo wpa.....
For group do:
$ cat /etc/group | grep netw
you should be getting something along these lines:
network:x:90:cynicfm                       (or whatever your user name is)

There are adapters you can buy that can plug next to your router in a electrical outlet where an ethernet cable goes in and a twin adapter next to your laptop in the same home/small office area that you plug another ethernet cable to.  Also there are wifi repeaters/eth adapters that can be programmed to login to the wifi through the browser and you connect through cable to them, so no wifi or firmware for wifi needed on the pc. 
Otherwise you must identify the specific chip that is in your wifi card and look for the appropriate firmware.  Your wifi card may be made by Zastava but your chip may be made by realtek.  You also need the specific chip number to locate the appropriate firmware family that covers it.

Do you have net-tools installed?
What does # ifconfig   show?


Re: Internet issues after upgrade

Reply #35
Yeah, i was on hyperbola wiki yesterday and read all stuff on it.
Of course as root, especially when i boot into base artix openrc iso it's all root before i get to installation. But if i install artix lxqt i have same thing, but if i connect to internet using networkmanager i can then use dhcpcd without any problems... Like i use dhcpcd wlp3s0 while networkmanager made a connection.
I think i may get one of these usb wireless adapters. I had one before but i lost it somewhere ;(.

Code: [Select]
# ifconfig
enp4s0f1: flags=4099<UP,BROADCAST,MULTICAST>  mtu 1500
        ether a8:1e:84:35:b6:ee  txqueuelen 1000  (Ethernet)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 0  bytes 0 (0.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
        inet  netmask
        inet6 ::1  prefixlen 128  scopeid 0x10<host>
        loop  txqueuelen 1000  (Local Loopback)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 0  bytes 0 (0.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

wlp3s0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet  netmask  broadcast
        inet6 fe80::88da:159a:2e0e:e9a9  prefixlen 64  scopeid 0x20<link>
        ether 58:00:e3:98:2e:03  txqueuelen 1000  (Ethernet)
        RX packets 7190  bytes 5561184 (5.3 MiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 4306  bytes 801466 (782.6 KiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0