Skip to main content
Topic solved
This topic has been marked as solved and requires no further attention.
Topic: tuxguitar-no sound (Read 180 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

tuxguitar-no sound

I downloaded and installed tuxguitar-common from the aur and was not able to get  the sound to work, although everything else seems to work fine. I could not find anything that I thought was relevant when i searched the internet except to have timidity installed, and to select that as the Midi Port, but that does not show as an option (timidity++ is installed). In Tools>Settings>Sounds there is no combination of Midi Sequencer or Midi Port that will produce sound.
My Midi Sequencer options are:
  • TuxGuitar Sequencer
  • Real Time Sequencer
My Midi Port options are:
  • TuxGuitar Synthesizer
  • Midi Port-0 [14:0]
  • Gervill
I'm not sure if this is needed but here are the plugins that ARE NOT enabled:
  • Gervill plugin
  • FluidSynth Output plugin
  • OSS output plugin
  • Jack Audio Connection Kit plugin support
  • Guitar Tuner
As i said, everything else seems to work fine. I am able to add notes to the tablature, the playback animation is working, there is just no sound.

Re: tuxguitar-no sound

Reply #2
Fire up timidity++ as an ALSA sequencer interface:
Code: [Select]
% timidity -iAD
A MIDI out driver named ALSA will appear with 4 devices; select TiMidity:0 and you should be a-ok. There are quite a few sound banks available in the repos or the AUR, just search for soundfont. I've got timidity-freepats installed and
Code: [Select]
soundfont /usr/share/soundfonts/timidity-freepats.sf2
in /etc/timidity++/timidity.cfg.

Re: tuxguitar-no sound

Reply #4
Thank you for your help.