Skip to main content
Topic solved
This topic has been marked as solved and requires no further attention.
Topic: Something delays the system start drastically. (Read 392 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

Something delays the system start drastically.

Hello everybody,
I had already looked for help in this thread, but the main problem does not seem to come from nm. The problem seems to be caused by another service.
In dmesg, the time difference between the following lines is particularly noticeable:
Code: [Select]
[    7.551828] IPv6: ADDRCONF(NETDEV_CHANGE): enp0s25: link becomes ready
[  154.276342] random: crng init done
If i added havged to the default runlevel, the timeout increases to over five minutes.

How can I narrow down the source of the error?

Edit:
The most time last line on display is: nm-dispatcher req:5, but if i record the desktop and play it very slow the next line is:
Code: [Select]
Checking your configfile (etc/syslog-ng/syslog-ng.conf) ...
WARNING: Configuration file format is too old, syslog-ng is running in compatibility mode.
Don't know what to do?  ::)

Thanks. :)

Re: Something delays the system start drastically.

Reply #1
Code: [Select]
Configuration file format is too old, syslog-ng is running in compatibility mode

You just need to change the first line of /etc/syslog-ng/syslog-ng.conf to
Code: [Select]
@version: 3.18

But that is not what is slowing the startup down.

I would guess there is not enough entropy ? havged should make it quicker not slower.
Without havged boot and keep hitting random keys on the keyboard. If this make the boot quicker then it's definitely to to with entropy.

Never had this issue so don't know much more

https://wiki.archlinux.org/index.php/Random_number_generation

Re: Something delays the system start drastically.

Reply #2
Youre right. With typing random keys, it's fast very fast. So it's an entropie problem, but how to solve?

I'm running Intel i5-3470 with 8GB DDR3 RAM.

Edit: adding haveged to boot runlevel not default solves the problem.  ;)

Two little questions:
Why does openrc with xdm doesn't start lightdm, but lxdm is no problem.
Why, when i log in xfce mousepad autostart everytime?

Re: Something delays the system start drastically.

Reply #3
I would start new topics as they are both questions unrelated to the topic and less likely to been seen by someone who knows.


Re: Something delays the system start drastically.

Reply #4

Why does openrc with xdm doesn't start lightdm, but lxdm is no problem.

Lightdm need special attention setting up /etc/pam.d/lightdm*, since it comes atm from arch repos to work with systemd.

I would not recommend lxdm, it does not work well with elogind.


Re: Something delays the system start drastically.

Reply #6
Lightdm need special attention setting up /etc/pam.d/lightdm*, since it comes atm from arch repos to work with systemd.
I would not recommend lxdm, it does not work well with elogind.
I couldn't anything how to configure... where can I find more about this?
I've already tried SLiM, but 'shutdown' and 'restart' is just a logout. Do you have an idea why?

Re: Something delays the system start drastically.

Reply #7
I couldn't anything how to configure... where can I find more about this?
I've already tried SLiM, but 'shutdown' and 'restart' is just a logout. Do you have an idea why?

slim is also notorious for being a PITA.

All display manager packages except for sddm currently come from arch repos.
We might add lightdm at some point to have a gtk based DM in repos.

If you use for example lightdm from arch, open the /etc/pam.d/lightdm* files, and replace any line contianing

Code: [Select]
session         optional pam_systemd.so

with

Code: [Select]
session         optional pam_elogind.so

and restart the DM or reboot.

Re: Something delays the system start drastically.

Reply #8
Doesn't solves my problem.
in the ligdm there is only
Code: [Select]
-session optional pam_gnome_keyring.so auto_start
only in the lightdm-greeter i've changed but same flashing cursor... :(

Re: Something delays the system start drastically.

Reply #9
The topic is already off track, so go with the flow, but somehow I have been reading the same problem in two threads and getting confused.

I thought the delay problem was cured, the problem now is DM behavior. May I ask what are you trying to achieve by a DM?  Is it remote login, is this a multiuser system, is it to have a choice of many desktops and window managers?  All mentioned DMs have been able to work without systemd in various systems, I don't think it takes much.  Maybe artix just picked sddm and went with it and there is no manpower to work on the rest.  But DMs have a reason for use.

Re: Something delays the system start drastically.

Reply #10
Doesn't solves my problem.
in the ligdm there is only
Code: [Select]
-session optional pam_gnome_keyring.so auto_start
only in the lightdm-greeter i've changed but same flashing cursor... :(


It could help if you tried to work out what was happening by looking in the log file (/var/log/lightdm/lightdm.log), if you haven't, and posting the log and also your /etc/lightdm/lightdm.conf
Or maybe try starting lightdm  ( from the console, with no X or dm running) with debugging and see what it says.
Code: [Select]
lightdm -d

It may well be that you don't have the greeter set up correctly ? Only guessing.

I use lightdm (believe it or not I had forgotten that, thought I was still on sddm !) with lightdm-slick-greeter.
I have used it both without  and with elogind installed (without atm) and the only issue I remember was to do with the greeter. But as I've just shown my memory is poor :)