Skip to main content
Topic solved
This topic has been marked as solved and requires no further attention.
Topic: Artix (OpenRC, xfce) problems (Read 829 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

Re: Artix (OpenRC, xfce) problems

Reply #15
Code: [Select]
** (process:2475): WARNING **: 19:57:11.379: Failed to open CK session: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name org.freedesktop.ConsoleKit was not provided by any .service files
Error writing X authority: Failed to open X authority /var/lib/lightdm/.Xauthority: No such file or directory


Code: [Select]
X.Org X Server 1.20.3
X Protocol Version 11, Revision 0
Build Operating System: Linux Arch Linux
Current Operating System: Linux hostname 4.20.0-gnu-1 #1 SMP PREEMPT Sun Jan 6 20:50:27 UTC 2019 x86_64
Kernel command line: BOOT_IMAGE=/vmlinuz-linux-libre root=UUID=e71e7b6e-24fa-424c-8e94-482dca5c8688 rw ipv6.disable=1 quiet
Build Date: 25 October 2018  04:42:32PM

Current version of pixman: 0.36.0
        Before reporting problems, check
        to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Thu Jan 10 19:57:10 2019
(==) Using system config directory "/usr/share/X11/xorg.conf.d"
The XKEYBOARD keymap compiler (xkbcomp) reports:
> Warning:          Unsupported high keycode 372 for name <I372> ignored
>                   X11 cannot support keycodes above 255.
>                   This warning only shows for the first high keycode.
Errors from xkbcomp are not fatal to the X server
(II) Server terminated successfully (0). Closing log file.

There is nothing more in the dir /var/log/lightdm/

Re: Artix (OpenRC, xfce) problems

Reply #16
Does that directory exist ? I'm only guessing but it looks like it's trying to write .Xauthority then trying to open it..

If it does exist what are the permissions, owner, group

Code: [Select]
ls -al /var/lib/lightdm/

Re: Artix (OpenRC, xfce) problems

Reply #17
The directory does not exist, what content should the file .Xauthority have?
Same like /var/lib/lightdm-data . It is not enough to create the folders.. :(

Re: Artix (OpenRC, xfce) problems

Reply #18
As root

Code: [Select]
mkdir /var/lib/lightdm
chown lightdm:lightdm /var/lib/lightdm
chmod 1770 /var/lib/lightdm

.Xauthority should hopefully be created for you.

I don't know why this and previously mentioned dir's were missing ?Some thing is wrong (I'm good at stating the obvious)

Re: Artix (OpenRC, xfce) problems

Reply #19
Yeah! This solved my problem. :)
Just to be on the safe side i've changed the rights also for the lightdm-data folder.

But why this is not set default...  ::)

Re: Artix (OpenRC, xfce) problems

Reply #20
But why this is not set default...  ::)

Glad to hear it :) Yes you were right to do the data folder as well.

It should have JUST worked as you say. Always has for me. I would hazard a guess at operator error in some way but who knows ?

For future reference if you run into problems, which you are going to post, try to find logs and config files and post them straight away. Saves a lot of messing around.
And properly read the logs. The answer is often right there. (searching for 'error' in the log, if it's long, is a good start and can speed things up)

Glad to have been of some help :)