Skip to main content
Topic: Soft lockup at boot (Read 129 times) previous topic - next topic
0 Members and 2 Guests are viewing this topic.

Soft lockup at boot

I updated last week, everything has been running as usual, but one boot earlier today I had a soft lockup. Pressing the power button and rebooting saw it boot as usual. Nothing was logged. I took some photos of the screen messages. I think it was quite early in the boot but I wasn't really paying attention until I saw it looking strange. There would be some error, then after a few seconds it would scroll through the next set of errors.  Also on the latest boot (not that one) I logged some alsa error, it wasn't saved in rc.log but was in consolelogga.log, this might not be related to the soft lockup as the btrfs scrub was clean and I have not changed anything since the last upgrade.
Photo links:
https://yadi.sk/i/rGHb9rSSngt6yA
https://yadi.sk/i/lb7XWUMbOhMvpQ
https://yadi.sk/i/5ZA5XhqB2tXWmQ
https://yadi.sk/i/vK8-wdY_qn3lKg

Code: [Select]
[2019-01-03 20:07] [PACMAN] Running 'pacman -Syyu'

$ sudo btrfs scrub start /
scrub started on /, fsid 7002a85b-74aa-4374-b55a-61067abb4e94 (pid=2567)
$ sudo btrfs scrub status /
scrub status for 7002a85b-74aa-4374-b55a-61067abb4e94
        scrub started at Wed Jan  9 19:34:03 2019 and finished after 00:02:14
        total bytes scrubbed: 26.25GiB with 0 errors


$ sudo inxi -zv7
System:    Host: ax Kernel: 4.19.12-artix1-1-ARTIX x86_64 bits: 64 compiler: gcc v: 8.2.1 Desktop: Xfce 4.12.4
           tk: Gtk 2.24.32 info: xfce4-panel wm: xfwm4 dm: startx Distro: Artix Linux
Machine:   Type: Portable System: Dell product: Precision M4400 v: N/A serial: <filter> Chassis: type: 8
           serial: <filter>
           Mobo: Dell model: 0NY980 serial: <filter> BIOS: Dell v: A29 date: 06/04/2013
Battery:   ID-1: BAT0 charge: 69.7 Wh condition: 69.7/73.3 Wh (95%) volts: 12.1/11.1 model: Sanyo DELL U726H8A
           type: Li-ion serial: <filter> status: Full
Memory:    RAM: total: 7.78 GiB used: 619.5 MiB (7.8%)
           RAM Report: missing: Required program dmidecode not available
CPU:       Topology: Dual Core model: Intel Core2 Duo T9900 bits: 64 type: MCP arch: Penryn rev: A
           L2 cache: 6144 KiB bogomips: 12240
           Speed: 1811 MHz min/max: 800/3068 MHz boost: enabled Core speeds (MHz): 1: 2063 2: 2131
           Flags: acpi aperfmperf apic arch_perfmon bts clflush cmov constant_tsc cpuid cx16 cx8 de ds_cpl
           dtes64 dtherm dts est flexpriority fpu fxsr ht ida lahf_lm lm mca mce mmx monitor msr mtrr nopl nx
           pae pat pbe pdcm pebs pge pni pse pse36 pti rep_good sep smx ss sse sse2 sse4_1 ssse3 syscall tm tm2
           tpr_shadow tsc vme vmx vnmi xsave xtpr
Graphics:  Device-1: NVIDIA G96GLM [Quadro FX 770M] vendor: Dell driver: nouveau v: kernel bus ID: 01:00.0
           chip ID: 10de:065c
           Display: server: X.Org 1.20.3 driver: nouveau unloaded: fbdev,modesetting,vesa alternate: nv
           resolution: 1440x900~60Hz
           Message: Unable to show advanced data. Required tool glxinfo missing.
Audio:     Device-1: Intel 82801I HD Audio vendor: Dell driver: snd_hda_intel v: kernel bus ID: 00:1b.0
           chip ID: 8086:293e
           Sound Server: ALSA v: k4.19.12-artix1-1-ARTIX
Network:   Device-1: Intel 82567LM Gigabit Network vendor: Dell driver: e1000e v: 3.2.6-k port: efe0
           bus ID: 00:19.0 chip ID: 8086:10f5
           IF: enp0s25 state: down mac: <filter>
           Device-2: Intel Ultimate N WiFi Link 5300 driver: iwlwifi v: kernel port: df00 bus ID: 0c:00.0
           chip ID: 8086:4235
           IF: wlp12s0 state: up mac: <filter>
           IP v4: <filter> type: noprefixroute scope: global broadcast: <filter>
           IP v6: <filter> scope: link
           WAN IP: <filter>
Drives:    Local Storage: total: 111.79 GiB used: 26.37 GiB (23.6%)
           ID-1: /dev/sda model: SSD2S120SF1200SA2 size: 111.79 GiB speed: 3.0 Gb/s serial: <filter> rev: BBF0
           scheme: GPT
           Optical-1: /dev/sr0 vendor: MATSHITA model: DVD+-RW UJ862A rev: 1.02 dev-links: cdrom
           Features: speed: 24 multisession: yes audio: yes dvd: yes rw: cd-r,cd-rw,dvd-r,dvd-ram
           state: running
RAID:      Message: No RAID data was found.
Partition: ID-1: / size: 30.00 GiB used: 26.31 GiB (87.7%) fs: btrfs dev: /dev/sda4 label: root1
           uuid: 7002a85b-74aa-4374-b55a-61067abb4e94
           ID-2: /boot size: 1024.0 MiB used: 61.8 MiB (6.0%) fs: btrfs dev: /dev/sda2 label: N/A
           uuid: 75c0faca-5886-4abb-aa12-ee239202ffa4
           ID-3: swap-1 size: 16.00 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/sda3 label: swap
           uuid: 402f9ace-25f8-4dc7-a7ab-c1ce4cbd34a8
Unmounted: ID-1: /dev/sda1 size: 1024 KiB fs: N/A label: N/A uuid: N/A
           ID-2: /dev/sda5 size: 30.00 GiB fs: btrfs label: rootantiX
           uuid: 3a0301c6-3c6c-4e27-9357-a0572cb201ce
           ID-3: /dev/sda6 size: 20.00 GiB fs: btrfs label: 20g_partition
           uuid: 463b5c9f-8668-4702-b40d-845ec7d4b098
USB:       Hub: 1-0:1 info: Full speed (or root) Hub ports: 6 rev: 2.0 speed: 480 Mb/s chip ID: 1d6b:0002
           Hub: 2-0:1 info: Full speed (or root) Hub ports: 6 rev: 2.0 speed: 480 Mb/s chip ID: 1d6b:0002
           Hub: 3-0:1 info: Full speed (or root) Hub ports: 2 rev: 1.1 speed: 12 Mb/s chip ID: 1d6b:0001
           Hub: 4-0:1 info: Full speed (or root) Hub ports: 2 rev: 1.1 speed: 12 Mb/s chip ID: 1d6b:0001
           Hub: 5-0:1 info: Full speed (or root) Hub ports: 2 rev: 1.1 speed: 12 Mb/s chip ID: 1d6b:0001
           Device-1: 5-1:2 info: Broadcom BCM5880 Secure Applications Processor with fingerprint touch sensor
           type: Smart Card driver: N/A interfaces: 2 rev: 1.1 speed: 12 Mb/s chip ID: 0a5c:5802
           serial: <filter>
           Hub: 6-0:1 info: Full speed (or root) Hub ports: 2 rev: 1.1 speed: 12 Mb/s chip ID: 1d6b:0001
           Hub: 7-0:1 info: Full speed (or root) Hub ports: 2 rev: 1.1 speed: 12 Mb/s chip ID: 1d6b:0001
           Hub: 8-0:1 info: Full speed (or root) Hub ports: 2 rev: 1.1 speed: 12 Mb/s chip ID: 1d6b:0001
Sensors:   System Temperatures: cpu: 30.0 C mobo: N/A sodimm: 37.0 C gpu: nouveau temp: 49 C
           Fan Speeds (RPM): cpu: 0
Info:      Processes: 191 Uptime: 30m Init: N/A v: N/A rc: OpenRC v: 0.40.3 runlevel: default Compilers:
           gcc: 8.2.1 alt: 5 Shell: bash (sudo) v: 4.4.23 running in: xfce4-terminal inxi: 3.0.26



Starting boot runlevel                                                                                                                                                        [ ok ]
 * Creating list of required static device nodes for the current kernel ...                                                                                                   [ ok ]
 * Setting system clock using the hardware clock [UTC] ...
 * Setting up tmpfiles.d entries for /dev ...                                                                                                                                 [ ok ]
 * Generating a rule to create a /dev/root symlink ...                                                                                                                        [ ok ]
 * Populating /dev with existing devices through uevents ...                                                                                                                  [ ok ]
Starting default runlevel                                                                                                                                                     [ ok ]
 * Mounting misc binary format filesystem ...                                                                                                                                 [ ok ]
 * Checking local filesystems  ...                                                                                                                                            [ ok ]
 * Loading custom binary format handlers ...                                                                                                                                  [ ok ]
 * Remounting filesystems ...                                                                                                                                                 [ ok ]
 * Updating /etc/mtab ...
 * Creating mtab symbolic link                                                                                                                                                [ ok ]
 * Activating swap devices ...                                                                                                                                                [ ok ]
 * Mounting local filesystems ...
 * Configuring kernel parameters ...                                                                                                                                          [ ok ]                                                                                                                                                                            [ ok ]
 * Creating user login records ...                                                                                                                                            [ ok ]
 * Starting dbus ...
 * Restoring Mixer Levels ...                                                                                                                                                 [ ok ]
 * Starting elogind ...                                                                                                                                                       [ ok ]
 * Setting hostname to flute from /etc/hostname ...                                                                                                                              [ ok ]
 * Setting terminal encoding [UTF-8] ...                                                                                                                                      [ ok ]
 * Setting keyboard mode [UTF-8] ...                                                                                                                                          [ ok ]
 * Loading key mappings [us] ...                                                                                                                                              [ ok ]
 * Bringing up network interface lo ...                                                                                                                                       [ ok ]
 * Bringing up interface lo
 *   Caching network module dependencies
need dbus
 *   127.0.0.1/8 ...                                                                                                                                                          [ ok ]
 *   Adding routes
 *     127.0.0.0/8 via 127.0.0.1 ...                                                                                                                                          [ ok ]                                                                                                                                                                            [ ok ]
 * Setting up sysusers.d entries ...                                                                                                                                          [ ok ]
 * Setting up tmpfiles.d entries ...                                                                                                                                          [ ok ]
 * Saving key mapping ...                                                                                                                                                     [ ok ]
 * Saving terminal encoding ...                                                                                                                                               [ ok ]
 * Initializing random number generator ...                                                                                                                                   [ ok ]
alsactl: unrecognized option '---'
Usage: alsactl <options> command

global options:
  -h,--help        this help
  -d,--debug       debug mode
  -v,--version     print version of this program

Available state options:
  -f,--file #      configuration file (default /var/lib/alsa/asound.state)
  -l,--lock        use file locking to serialize concurrent access
  -L,--no-lock     do not use file locking to serialize concurrent access
  -O,--lock-state-file #  state lock file path (default /var/lock/asound.state.lock)
  -F,--force       try to restore the matching controls as much as possible
                     (default mode)
  -g,--ignore      ignore 'No soundcards found' error
  -P,--pedantic    do not restore mismatching controls (old default)
  -I,--no-init-fallback 
                   don't initialize even if restore fails
  -r,--runstate #  save restore and init state to this file (only errors)
                     default settings is 'no file set'
  -R,--remove      remove runstate file at first, otherwise append errors
  -p,--period #    store period in seconds for the daemon command
  -e,--pid-file #  pathname for the process id (daemon mode)

Available init options:
  -E,--env #=#     set environment variable for init phase (NAME=VALUE)
  -i,--initfile #  main configuation file for init phase
                     (default /usr/share/alsa/init/00main)
  -b,--background  run daemon in background
  -s,--syslog      use syslog for messages
  -n,--nice #      set the process priority (see 'man nice')
  -c,--sched-idle  set the process scheduling policy to idle (SCHED_IDLE)

Available commands:
  store     <card>  save current driver setup for one or each soundcards
                      to configuration file
  restore   <card>  load current driver setup for one or each soundcards
                      from configuration file
  nrestore  <card>  like restore, but notify the daemon to rescan soundcards
  init      <card>  initialize driver to a default state
  daemon    <card>  store state periodically for one or each soundcards
  rdaemon   <card>  like daemon but do the state restore at first
  kill      <cmd>   notify daemon to quit, rescan or save_and_quit
  monitor   <card>  monitor control events
 * Errors while restoring defaults, ignoring                                                                                                                                  [ ok ]
 * Starting avahi-daemon ...                                                                                                                                                  [ ok ]
 * Starting cronie ...                                                                                                                                                        [ ok ]
 * ERROR: netmount needs service(s) net
 * Starting ntpd ...                                                                                                                                                          [ ok ]
 * Starting vnstatd ...                                                                                                                                                       [ ok ]
 * Starting local ...                                                                                                                                                         [ ok ]
 * Error: fopen(/run/openrc/rc.log) failed: No such file or directory


Re: Soft lockup at boot

Reply #1
Yes, I have not seen it again - but I had never seen it before either. I think it's helpful to post details of things like this though, if others had the same issue you might see a pattern that someone could investigate.
Yesterday I had a USB powered external esata drive plugged in, which was apparently not detected properly because when I went to mount another USB drive there was no "sdc" so I unplugged the esata and it's usb lead too and was able to mount the USB. Then I noticed my mouse pointer was sluggish and I had no touchpad scrolling. But when I rebooted it worked normally again. So for some reason that boot had not worked, but I figured that could have just been the esata connection not being plugged in quite 100% which then confused the boot, so it was probably a hardware issue side effect.
I don't know why the soft lock up happened. It could well be nothing, there is so much inside computers and their chips it's amazing they ever work at all!