Skip to main content
Topic: Upgrade GPG errors etc (Read 583 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

Upgrade GPG errors etc

Not sure what's going on, but tried everything and nothing works. Doing upgrade gives GPG errors or corrupt or whatever, so ran commands from wiki to repopulate and that doesn't work. Nothing helps from wiki about fixing GPG errors etc. The link to the https://gitea.artixlinux.org/packages/artix-mirrorlist/src/branch/master/repos/core-any/mirrorlist doesn't work and gives 404. How can we upgrade anything if the GPG keys or whatever are never right and don't get updated..

Code: [Select]
 sudo pacman -Sy gnupg archlinux-keyring artix-keyring --force
doesn't work/fix anything.
Code: [Select]
sudo pacman-key --init
doesn't work/fix anything
Code: [Select]
sudo pacman-key --populate archlinux artix
doesn't work/fix anything.


There's no point in having Artix available to download and use then. Also downloaded the BASE only install ISO has weird characters in the cfdisk, so it's tough to see clearly the options to choose... and some other error for grub couldn't connect to something over and over and over and over. So far... there's no valid reason to download and install Artix, but nothing works right lol. :P

Re: Upgrade GPG errors etc

Reply #1
Question, is there an old script of yours that I can use to remove SYSTEMD stuff and replace it with RUNIT just by downloading Arch linux itself and not have to deal with Artix?

Edit: Oh wait, I didn't know you had to run that 
Code: [Select]
sudo pacman-key --init
first, then the repopulate command second. See, it would be nice if this was in Wiki, so users do this before trying to update/upgrade things. Because wiki says IF you get errors for the keys, then do those commands. Then it doesn't work... crossing fingers.

Re: Upgrade GPG errors etc

Reply #2
Nope, doing those two commands first before doing upgrade for everything don't work either. Sorry, I can't use Artix... nothing works. Actually A LOT more errors than this but can only get this much into message. I can't keep fighting with a distro to get it to work and do an update/upgrade.. sorry



Code: [Select]
Do you want to delete it? [Y/n] 
error: gettext: missing required signature
:: File /var/cache/pacman/pkg/gettext-0.19.8.1-3-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n]
error: grep: missing required signature
:: File /var/cache/pacman/pkg/grep-3.3-1-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n]
error: groff: missing required signature
:: File /var/cache/pacman/pkg/groff-1.22.3-8-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n]
error: grub: missing required signature
:: File /var/cache/pacman/pkg/grub-2:2.02-8-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n]
error: wayland-protocols: missing required signature
:: File /var/cache/pacman/pkg/wayland-protocols-1.17-1-any.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n]
error: tar: missing required signature
:: File /var/cache/pacman/pkg/tar-1.31-2-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n]
error: libcanberra: missing required signature
:: File /var/cache/pacman/pkg/libcanberra-0.30+2+gc0620e4-2-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n]
error: js52: missing required signature
:: File /var/cache/pacman/pkg/js52-52.9.0-2-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n]
error: polkit: missing required signature
:: File /var/cache/pacman/pkg/polkit-0.115+24+g5230646-1-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n]
error: libsoup: missing required signature
:: File /var/cache/pacman/pkg/libsoup-2.64.2-1-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n]
error: gtk3: missing required signature
:: File /var/cache/pacman/pkg/gtk3-3.24.3-1-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n]
error: inetutils: missing required signature
:: File /var/cache/pacman/pkg/inetutils-1.9.4-7-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n]
error: inxi: missing required signature
:: File /var/cache/pacman/pkg/inxi-3.0.26-1-any.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n]
error: iptables: missing required signature
:: File /var/cache/pacman/pkg/iptables-1:1.8.2-1-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n]
error: iproute2: missing required signature
:: File /var/cache/pacman/pkg/iproute2-4.20.0-1-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n]
error: iputils: missing required signature
:: File /var/cache/pacman/pkg/iputils-20180629.f6aac8d-3-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n]
error: ipw2100-fw: missing required signature
:: File /var/cache/pacman/pkg/ipw2100-fw-1.3-9-any.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n]
error: ipw2200-fw: missing required signature
:: File /var/cache/pacman/pkg/ipw2200-fw-3.1-7-any.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n]
error: iso-codes: missing required signature
:: File /var/cache/pacman/pkg/iso-codes-4.1-1-any.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n]
error: jansson: missing required signature
:: File /var/cache/pacman/pkg/jansson-2.12-1-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n]
error: kcoreaddons: missing required signature
:: File /var/cache/pacman/pkg/kcoreaddons-5.54.0-1-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n]
error: kconfig: missing required signature
:: File /var/cache/pacman/pkg/kconfig-5.54.0-1-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n]
error: qt5-x11extras: missing required signature
:: File /var/cache/pacman/pkg/qt5-x11extras-5.12.0-1-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n]
error: kwindowsystem: missing required signature
:: File /var/cache/pacman/pkg/kwindowsystem-5.54.0-1-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n]
error: kactivities: missing required signature
:: File /var/cache/pacman/pkg/kactivities-5.54.0-1-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n]
error: karchive: missing required signature
:: File /var/cache/pacman/pkg/karchive-5.54.0-1-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n]
error: kauth: missing required signature
:: File /var/cache/pacman/pkg/kauth-5.54.0-2-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n]
error: kdbusaddons: missing required signature
:: File /var/cache/pacman/pkg/kdbusaddons-5.54.0-1-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n]

error: kcrash: missing required signature
:: File /var/cache/pacman/pkg/kcrash-5.54.0-1-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n]
error: kglobalaccel: missing required signature
:: File /var/cache/pacman/pkg/kglobalaccel-5.54.0-1-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n]
error: kwidgetsaddons: missing required signature
:: File /var/cache/pacman/pkg/kwidgetsaddons-5.54.0-1-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n]
error: kcompletion: missing required signature
:: File /var/cache/pacman/pkg/kcompletion-5.54.0-1-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n]

error: qt5-declarative: missing required signature
:: File /var/cache/pacman/pkg/qt5-declarative-5.12.0-1-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n]
error: ki18n: missing required signature
:: File /var/cache/pacman/pkg/ki18n-5.54.0-1-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n]
error: kservice: missing required signature
:: File /var/cache/pacman/pkg/kservice-5.54.0-1-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n]
error: qt5-svg: missing required signature
:: File /var/cache/pacman/pkg/qt5-svg-5.12.0-1-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n]
error: kcodecs: missing required signature
:: File /var/cache/pacman/pkg/kcodecs-5.54.0-1-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n]
error: kguiaddons: missing required signature
:: File /var/cache/pacman/pkg/kguiaddons-5.54.0-1-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n]

error: kconfigwidgets: missing required signature
:: File /var/cache/pacman/pkg/kconfigwidgets-5.54.0-1-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n]
error: kitemviews: missing required signature
:: File /var/cache/pacman/pkg/kitemviews-5.54.0-1-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n]
error: kiconthemes: missing required signature
:: File /var/cache/pacman/pkg/kiconthemes-5.54.0-1-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n]
error: sonnet: missing required signature
:: File /var/cache/pacman/pkg/sonnet-5.54.0-1-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n]
error: openal: missing required signature
:: File /var/cache/pacman/pkg/openal-1.19.1-1-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n]
error: qt5-multimedia: missing required signature
:: File /var/cache/pacman/pkg/qt5-multimedia-5.12.0-1-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n]
error: qt5-speech: missing required signature
:: File /var/cache/pacman/pkg/qt5-speech-5.12.0-1-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n]
error: ktextwidgets: missing required signature
:: File /var/cache/pacman/pkg/ktextwidgets-5.54.0-1-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n]
error: kxmlgui: missing required signature
:: File /var/cache/pacman/pkg/kxmlgui-5.54.0-1-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n]
error: kbookmarks: missing required signature
:: File /var/cache/pacman/pkg/kbookmarks-5.54.0-1-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n]

error: kidletime: missing required signature
:: File /var/cache/pacman/pkg/kidletime-5.54.0-1-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n]
error: media-player-info: missing required signature
:: File /var/cache/pacman/pkg/media-player-info-24-1-any.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n]
error: libusbmuxd: missing required signature
:: File /var/cache/pacman/pkg/libusbmuxd-1.0.10+29+g9db5747-1-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n]
error: usbmuxd: missing required signature
:: File /var/cache/pacman/pkg/usbmuxd-1.1.0+48+g1cc8b34-2-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n]
error: libimobiledevice: missing required signature
:: File /var/cache/pacman/pkg/libimobiledevice-1.2.0+87+g92c5462-1-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n]
error: upower: missing required signature
:: File /var/cache/pacman/pkg/upower-0.99.9-1-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n]
error: libaio: missing required signature
:: File /var/cache/pacman/pkg/libaio-0.3.111-2-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n]
error: lvm2: missing required signature
:: File /var/cache/pacman/pkg/lvm2-2.02.183-2-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n]
error: mdadm: missing required signature
:: File /var/cache/pacman/pkg/mdadm-4.0-2-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n]
error: parted: missing required signature
:: File /var/cache/pacman/pkg/parted-3.2-8-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n]
error: xfsprogs: missing required signature
:: File /var/cache/pacman/pkg/xfsprogs-4.19.0-2-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n]
error: solid: missing required signature
:: File /var/cache/pacman/pkg/solid-5.54.0-1-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n]
error: kjobwidgets: missing required signature
:: File /var/cache/pacman/pkg/kjobwidgets-5.54.0-1-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n]
error: libxslt: missing required signature
:: File /var/cache/pacman/pkg/libxslt-1.1.33-1-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n]
error: libdbusmenu-qt5: missing required signature
:: File /var/cache/pacman/pkg/libdbusmenu-qt5-0.9.3+16.04.20160218-2-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n]
error: knotifications: missing required signature
:: File /var/cache/pacman/pkg/knotifications-5.54.0-1-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n]
error: kwallet: missing required signature
:: File /var/cache/pacman/pkg/kwallet-5.54.0-1-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n]
error: qt5-script: missing required signature
:: File /var/cache/pacman/pkg/qt5-script-5.12.0-1-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n]
error: kio: missing required signature
:: File /var/cache/pacman/pkg/kio-5.54.1-1-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n]
error: kparts: missing required signature
:: File /var/cache/pacman/pkg/kparts-5.54.0-1-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n]
error: syntax-highlighting: missing required signature
:: File /var/cache/pacman/pkg/syntax-highlighting-5.54.0-1-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n]
error: libgit2: missing required signature
:: File /var/cache/pacman/pkg/libgit2-1:0.27.7-1-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n]
error: ktexteditor: missing required signature
:: File /var/cache/pacman/pkg/ktexteditor-5.54.0-2-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n]
error: kwayland: missing required signature
:: File /var/cache/pacman/pkg/kwayland-5.54.0-1-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n]
error: kwrite: missing required signature
:: File /var/cache/pacman/pkg/kwrite-18.12.1-1-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n]
error: libdbi: missing required signature
:: File /var/cache/pacman/pkg/libdbi-0.9.0-4-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n]
error: libevent: missing required signature
:: File /var/cache/pacman/pkg/libevent-2.1.8-2-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n]
error: libfm-extra: missing required signature
:: File /var/cache/pacman/pkg/libfm-extra-1.3.1-1-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n]
error: libfm: missing required signature
:: File /var/cache/pacman/pkg/libfm-1.3.1-1-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n]
error: libkscreen: missing required signature
:: File /var/cache/pacman/pkg/libkscreen-5.14.5-1-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n]
error: libmbim: missing required signature
:: File /var/cache/pacman/pkg/libmbim-1.18.0-1-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n]
error: libmpcdec: missing required signature
:: File /var/cache/pacman/pkg/libmpcdec-1:0.1+r475-2-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n]
error: libnm: missing required signature
:: File /var/cache/pacman/pkg/libnm-1.14.5dev+17+gba83251bb-2-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n]
error: libnm-glib: missing required signature
:: File /var/cache/pacman/pkg/libnm-glib-1.14.5dev+17+gba83251bb-2-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n]
error: libnm-gtk: missing required signature
:: File /var/cache/pacman/pkg/libnm-gtk-1.8.19dev+21+geebf7f95-1-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n]
error: mobile-broadband-provider-info: missing required signature
:: File /var/cache/pacman/pkg/mobile-broadband-provider-info-20190116-1-any.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n]
error: libnma: missing required signature
:: File /var/cache/pacman/pkg/libnma-1.8.19dev+21+geebf7f95-1-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n]
error: libnotify: missing required signature
:: File /var/cache/pacman/pkg/libnotify-0.7.7-2-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n]
error: vulkan-icd-loader: missing required signature
:: File /var/cache/pacman/pkg/vulkan-icd-loader-1.1.96+3009+32d33e965-1-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n]
error: spirv-tools: missing required signature
:: File /var/cache/pacman/pkg/spirv-tools-2018.5-1-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n]
error: glslang: missing required signature
:: File /var/cache/pacman/pkg/glslang-7.10.2984-1-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n]
error: shaderc: missing required signature
:: File /var/cache/pacman/pkg/shaderc-2018.0-3-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n]
error: libplacebo: missing required signature
:: File /var/cache/pacman/pkg/libplacebo-1.7.0-1-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n]
error: libqmi: missing required signature
:: File /var/cache/pacman/pkg/libqmi-1.22.0-1-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n]
error: libqtxdg: missing required signature
:: File /var/cache/pacman/pkg/libqtxdg-3.2.0-5-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n]
error: libsodium: missing required signature
:: File /var/cache/pacman/pkg/libsodium-1.0.17-1-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n]
error: libsynctex: missing required signature
:: File /var/cache/pacman/pkg/libsynctex-2018.48691-4-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n]
error: zeromq: missing required signature
:: File /var/cache/pacman/pkg/zeromq-4.3.1-1-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n]
error: libteam: missing required signature
:: File /var/cache/pacman/pkg/libteam-1.28-2-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n]
error: libxpm: missing required signature
:: File /var/cache/pacman/pkg/libxpm-3.5.12-2-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n]
error: libxvmc: missing required signature
:: File /var/cache/pacman/pkg/libxvmc-1.0.10-2-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n]
error: licenses: missing required signature
:: File /var/cache/pacman/pkg/licenses-20181104-1-any.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n]
error: linux-firmware: missing required signature
:: File /var/cache/pacman/pkg/linux-firmware-20181218.0f22c85-1-any.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n]

error: mkinitcpio: missing required signature
:: File /var/cache/pacman/pkg/mkinitcpio-25-1-any.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n]
error: linux: missing required signature
:: File /var/cache/pacman/pkg/linux-4.20.2.artix1-1-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n]
error: lua: missing required signature
:: File /var/cache/pacman/pkg/lua-5.3.5-2-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n]

error: lxmenu-data: missing required signature
:: File /var/cache/pacman/pkg/lxmenu-data-0.1.5-2-any.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n]
error: lxqt-panel: missing required signature
:: File /var/cache/pacman/pkg/lxqt-panel-0.13.0-4-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n]
error: lxqt-qtplugin: missing required signature
:: File /var/cache/pacman/pkg/lxqt-qtplugin-0.13.0-3-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n]
error: man-db: missing required signature
:: File /var/cache/pacman/pkg/man-db-2.8.5-1.1-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n]
error: memtest86+: missing required signature
:: File /var/cache/pacman/pkg/memtest86+-5.01-3-any.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n]
error: muparser: missing required signature
:: File /var/cache/pacman/pkg/muparser-2.2.6-1-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n]
error: nano: missing required signature
:: File /var/cache/pacman/pkg/nano-3.2-1-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n]
error: nm-connection-editor: missing required signature
:: File /var/cache/pacman/pkg/nm-connection-editor-1.8.19dev+21+geebf7f95-1-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n]
error: openssl-1.0: missing required signature
:: File /var/cache/pacman/pkg/openssl-1.0-1.0.2.q-1-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n]
error: wpa_supplicant: missing required signature
:: File /var/cache/pacman/pkg/wpa_supplicant-2:2.6-2-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n]
error: networkmanager: missing required signature
:: File /var/cache/pacman/pkg/networkmanager-1.14.5dev+17+gba83251bb-2-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n]
error: network-manager-applet: missing required signature
:: File /var/cache/pacman/pkg/network-manager-applet-1.8.19dev+21+geebf7f95-1-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n]
error: openssh: missing required signature
:: File /var/cache/pacman/pkg/openssh-7.9p1-1-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n]
error: poppler: missing required signature
:: File /var/cache/pacman/pkg/poppler-0.72.0-1-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n]
error: poppler-qt5: missing required signature
:: File /var/cache/pacman/pkg/poppler-qt5-0.72.0-1-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n]
error: powertop: missing required signature
:: File /var/cache/pacman/pkg/powertop-2.10-1-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n]
error: ppp: missing required signature
:: File /var/cache/pacman/pkg/ppp-2.4.7-5-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n]
error: qpdfview: missing required signature
:: File /var/cache/pacman/pkg/qpdfview-0.4.18beta1-1-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n]
error: qt5-location: missing required signature
:: File /var/cache/pacman/pkg/qt5-location-5.12.0-1-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n]
error: qt5-webchannel: missing required signature
:: File /var/cache/pacman/pkg/qt5-webchannel-5.12.0-1-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n]

error: re2: missing required signature
:: File /var/cache/pacman/pkg/re2-20190101-1-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n]
error: qt5-webengine: missing required signature
:: File /var/cache/pacman/pkg/qt5-webengine-5.12.0-1-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n]
error: qt5-xmlpatterns: missing required signature
:: File /var/cache/pacman/pkg/qt5-xmlpatterns-5.12.0-1-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n]
error: reiserfsprogs: missing required signature
:: File /var/cache/pacman/pkg/reiserfsprogs-3.6.27-2-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n]

error: rpcbind: missing required signature
:: File /var/cache/pacman/pkg/rpcbind-1.2.5-2-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n]
error: s-nail: missing required signature
:: File /var/cache/pacman/pkg/s-nail-14.9.11-2-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n]
error: xorg-xauth: missing required signature
:: File /var/cache/pacman/pkg/xorg-xauth-1.0.10-2-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n]
error: xorg-server-common: missing required signature
:: File /var/cache/pacman/pkg/xorg-server-common-1.20.3-1-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n]
error: xf86-input-libinput: missing required signature
:: File /var/cache/pacman/pkg/xf86-input-libinput-0.28.1-1-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n]
error: xorg-server: missing required signature
:: File /var/cache/pacman/pkg/xorg-server-1.20.3-1-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n]
error: sddm: missing required signature
:: File /var/cache/pacman/pkg/sddm-0.18.0-2-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n]
error: sed: missing required signature
:: File /var/cache/pacman/pkg/sed-4.7-1-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n]
error: startup-notification: missing required signature
:: File /var/cache/pacman/pkg/startup-notification-0.12-6-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n]
error: sudo: missing required signature
:: File /var/cache/pacman/pkg/sudo-1.8.27-1-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n]
error: syslog-ng: missing required signature
:: File /var/cache/pacman/pkg/syslog-ng-3.18.1-1-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n]
error: taglib: missing required signature
:: File /var/cache/pacman/pkg/taglib-1.11.1-2-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n]
error: terminus-font: missing required signature
:: File /var/cache/pacman/pkg/terminus-font-4.47-2-any.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n]
error: texinfo: missing required signature
:: File /var/cache/pacman/pkg/texinfo-6.5-2-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n]
error: ttf-bitstream-vera: missing required signature
:: File /var/cache/pacman/pkg/ttf-bitstream-vera-1.10-12-any.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n]
error: ttf-droid: missing required signature
:: File /var/cache/pacman/pkg/ttf-droid-20121017-6-any.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n]
error: ttf-liberation: missing required signature
:: File /var/cache/pacman/pkg/ttf-liberation-2.00.1-8-any.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n]
error: vlc: missing required signature
:: File /var/cache/pacman/pkg/vlc-3.0.6-1-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n]
error: which: missing required signature
:: File /var/cache/pacman/pkg/which-2.21-3-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n]
error: wireless-regdb: missing required signature
:: File /var/cache/pacman/pkg/wireless-regdb-2018.10.24-2-any.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n]
error: xarchiver: missing required signature
:: File /var/cache/pacman/pkg/xarchiver-0.5.4.13-2-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n]
error: xf86-input-vmmouse: missing required signature
:: File /var/cache/pacman/pkg/xf86-input-vmmouse-13.1.0-4-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n]
error: xf86-video-intel: missing required signature
:: File /var/cache/pacman/pkg/xf86-video-intel-1:2.99.917+855+g746ab3bb-1-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n]
error: failed to commit transaction (invalid or corrupted package (PGP signature))
Errors occurred, no packages were upgraded.

Re: Upgrade GPG errors etc

Reply #3
that is no problem of artix linux, i have udated all this package normally, so someting with your setting is wrong :-(

Re: Upgrade GPG errors etc

Reply #4
Not sure what's going on lol.... don't have time to waste to fix it. Out of the box and installed TWICE now for Artix in a Virtual Machine and first time trying to upgrade without doing anything to the keys, it didn't work. Two or three keys were corrupt, so tried those commands from wiki to fix keys and didn't work. Then deleted VM and reinstalled Artix second time (this time) and ran those two key commands first, then did upgrade and had more key errors than the first time. Out of box it should upgrade everything fine from get go.. Not have users playing hob finding fixes and etc...

Code: [Select]
[email protected] ~]$ sudo pacman-key --populate archlinux artix
[sudo] password for dt:
==> Appending keys from archlinux.gpg...
gpg: error while loading shared libraries: libreadline.so.8: cannot open shared object file: No such file or directory
==> Appending keys from artix.gpg...
gpg: error while loading shared libraries: libreadline.so.8: cannot open shared object file: No such file or directory
==> Locally signing trusted keys in keyring...
  -> Locally signing key DDB867B92AA789C165EEFA799B729B06A680C281...
==> ERROR: DDB867B92AA789C165EEFA799B729B06A680C281 could not be locally signed.
  -> Locally signing key 684148BB25B49E986A4944C55184252D824B18E8...
==> ERROR: 684148BB25B49E986A4944C55184252D824B18E8 could not be locally signed.
  -> Locally signing key 91FFE0700E80619CEB73235CA88E23E377514E00...
==> ERROR: 91FFE0700E80619CEB73235CA88E23E377514E00 could not be locally signed.
  -> Locally signing key 8AC1470E584E6AAB0BBBAC3FED587B6247A4152D...
==> ERROR: 8AC1470E584E6AAB0BBBAC3FED587B6247A4152D could not be locally signed.
  -> Locally signing key AB19265E5D7D20687D303246BA1DFB64FFF979E7...
==> ERROR: AB19265E5D7D20687D303246BA1DFB64FFF979E7 could not be locally signed.
  -> Locally signing key 0E8B644079F599DFC1DDC3973348882F6AC6A4C2...
==> ERROR: 0E8B644079F599DFC1DDC3973348882F6AC6A4C2 could not be locally signed.
  -> Locally signing key 2C69BCE8163847BC56401FD2CF18A351C0705F6A...
==> ERROR: 2C69BCE8163847BC56401FD2CF18A351C0705F6A could not be locally signed.
  -> Locally signing key 9CBF2CD86DB1BA4F278C69C260448B45A4ECBA8D...
==> ERROR: 9CBF2CD86DB1BA4F278C69C260448B45A4ECBA8D could not be locally signed.
  -> Locally signing key 664187F32A958D0ED06530067BFAD0C0864DA8E8...
==> ERROR: 664187F32A958D0ED06530067BFAD0C0864DA8E8 could not be locally signed.
  -> Locally signing key 80E461C30BE40AD3EFB57E18EA690BC73A4F1094...
==> ERROR: 80E461C30BE40AD3EFB57E18EA690BC73A4F1094 could not be locally signed.
[[email protected] ~]$

Re: Upgrade GPG errors etc

Reply #5
hmm, strange

Re: Upgrade GPG errors etc

Reply #6
@matteopa First, your mirrorlist link is wrong, use the one from the main site sidebar. Second, make sure your pacman.conf looks like this.
Having these sorted out, and because your errors seem to be caused by a partial update (if running gpg gives you a libreadline error) do the following:
 
Code: [Select]
# pacman -Syyw gnupg bash readline
# pacman -U /var/cache/pacman/pkg/{readline-8,bash-5,gnupg-2.2.12-2}*.tar.xz
# pacman -Su

Re: Upgrade GPG errors etc

Reply #7
Thanks nous, fixed the pacman.conf file but not sure where those artix repo list goes though, doesn't mention where or which file to put that list in on wiki? Tried running first command you gave above there and got error...

Code: [Select]
ackages (3) bash-5.0.0-1  gnupg-2.2.12-2  readline-8.0.0-1

Total Download Size:  0.00 MiB

:: Proceed with download? [Y/n] y
(3/3) checking keys in keyring                         [############################] 100%
error: GPGME error: Invalid crypto engine
error: GPGME error: Invalid crypto engine
error: GPGME error: Invalid crypto engine
(3/3) checking package integrity                       [############################] 100%
error: GPGME error: Invalid crypto engine
error: GPGME error: Invalid crypto engine
error: GPGME error: Invalid crypto engine
error: readline: missing required signature
:: File /var/cache/pacman/pkg/readline-8.0.0-1-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] y
error: bash: missing required signature
:: File /var/cache/pacman/pkg/bash-5.0.0-1-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n]


Re: Upgrade GPG errors etc

Reply #9
Don't delete the files when asked, that was the whole point...

Didn't know that, assumed it was to remove the old/bad stuff to be replaced by good stuff. I hope someone updates the wiki on all this complex stuff just to upgrade Artix.. i tried Artix before and it updated fine without gpg key errors etc. But anyway, I tried those commands above again and this time picked "N" for them all... and it downloaded the packages and I chose "Y" to install/update everything.. and oops... still key errors and nothing updated.
Code: [Select]
Error: qpdfview: key "Alad Wenter <[email protected]>" is disabled
:: File /var/cache/pacman/pkg/qpdfview-0.4.18beta1-1-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] n
error: vlc: signature from "Levente Polyak (anthraxx) <[email protected]>" is unknown trust
:: File /var/cache/pacman/pkg/vlc-3.0.6-1-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] n
error: failed to commit transaction (invalid or corrupted package)
Errors occurred, no packages were upgraded.
[[email protected] ~]$

 

Re: Upgrade GPG errors etc

Reply #10
Both those errors come from Arch.

You can't expect to be spoon fed every time pacman throws up an error whose solution is in the first google result.

Perhaps rolling-release distros aren't for you.

Re: Upgrade GPG errors etc

Reply #11
I'm just showing all the issues and hassles there are trying to install Artix ... the wiki will need updated with all this information. "in order to install artix, you can't do update out of box, without editing files, and fixing keys and populating keyrings, and this then and that, and this and that, and more that and this"... and its never ending... and when asking for help in forum the developers can be dicks and condesending with you and put you down, just cause their distro is shit and created while they were drunk and stoned...

ya know, that kinda stuff... and finding "fixes" via google search doesn't always help and fix anything anyway.... point proven when reading your crap wiki and nothing worked with those commands about the keys and that was AFTER the "IF" you get key errors... do this" So googling has TONS of possible "fixes" but not all will work... and could lead to someone fucking up their system more than if they didn't google for fixes to start with.

Never had this much issue and hassle with Arch before, but it sucks cause Arch has Systemd in it.. and you guys seemed to have a script in very beginning to remove it.. but where's the script so someone could download Arch itself, and then just run script to install Runit and remove systemd?

Re: Upgrade GPG errors etc

Reply #12
So after "googling" for fixes, which many different ones come up in various places...

Code: [Select]
[[email protected] ~]$ sudo pacman -S archlinux-keyring
warning: archlinux-keyring-20181218-1 is up to date -- reinstalling

1/1) reinstalling archlinux-keyring                   [############################] 100%
==> Appending keys from archlinux.gpg...
==> Locally signing trusted keys in keyring...
  -> Locally signing key DDB867B92AA789C165EEFA799B729B06A680C281...
  -> Locally signing key 684148BB25B49E986A4944C55184252D824B18E8...
  -> Locally signing key 91FFE0700E80619CEB73235CA88E23E377514E00...
  -> Locally signing key 0E8B644079F599DFC1DDC3973348882F6AC6A4C2...
  -> Locally signing key AB19265E5D7D20687D303246BA1DFB64FFF979E7...
==> Importing owner trust values...
==> Disabling revoked keys in keyring...
  -> Disabling key 8F76BEEA0289F9E1D3E229C05F946DED983D4366...
  -> Disabling key 63F395DE2D6398BBE458F281F2DBB4931985A992...
  -> Disabling key 50F33E2E5B0C3D900424ABE89BDCF497A4BBCC7F...
  -> Disabling key 27FFC4769E19F096D41D9265A04F9397CDFD6BB0...
  -> Disabling key 39F880E50E49A4D11341E8F939E4F17F295AFBF4...
  -> Disabling key 8840BD07FC24CB7CE394A07CCF7037A4F27FB7DA...
  -> Disabling key 5559BC1A32B8F76B3FCCD9555FA5E5544F010D48...
  -> Disabling key 0B20CA1931F5DA3A70D0F8D2EA6836E1AB441196...
  -> Disabling key 07DFD3A0BC213FA12EDC217559B3122E2FA915EC...
  -> Disabling key 4FCF887689C41B09506BE8D5F3E1D5C5D30DB0AD...
  -> Disabling key 5A2257D19FF7E1E0E415968CE62F853100F0D0F0...
  -> Disabling key 7FA647CD89891DEDC060287BB9113D1ED21E1A55...
  -> Disabling key BC1FBE4D2826A0B51E47ED62E2539214C6C11350...
  -> Disabling key 4A8B17E20B88ACA61860009B5CED81B7C2E5C0D2...
  -> Disabling key 5696C003B0854206450C8E5BE613C09CB4440678...
  -> Disabling key 8CF934E339CAD8ABF342E822E711306E3C4F88BC...
  -> Disabling key F5A361A3A13554B85E57DDDAAF7EF7873CFD4BB6...
  -> Disabling key 5E7585ADFF106BFFBBA319DC654B877A0864983E...
  -> Disabling key 65EEFE022108E2B708CBFCF7F9E712E59AF5F22A...
  -> Disabling key 40440DC037C05620984379A6761FAD69BA06C6A9...
  -> Disabling key 34C5D94FE7E7913E86DC427E7FB1A3800C84C0A5...
  -> Disabling key 81D7F8241DB38BC759C80FCE3A726C6170E80477...
  -> Disabling key E7210A59715F6940CF9A4E36A001876699AD6E84...
  -> Disabling key 5357F3B111688D88C1D88119FCF2CB179205AC90...
  -> Disabling key FB871F0131FEA4FB5A9192B4C8880A6406361833...
  -> Disabling key 66BD74A036D522F51DD70A3C7F2A16726521E06D...
  -> Disabling key B1F2C889CB2CCB2ADA36D963097D629E437520BD...
  -> Disabling key 9515D8A8EAB88E49BB65EDBCE6B456CAF15447D5...
  -> Disabling key 40776A5221EF5AD468A4906D42A1DB15EC133BAD...
  -> Disabling key D4DE5ABDE2A7287644EAC7E36D1A9E70E19DAA50...
  -> Disabling key 44D4A033AC140143927397D47EFD567D4C7EA887...
==> Updating trust database...
gpg: next trustdb check due at 2019-01-31


Then did this one...
Code: [Select]
[[email protected] ~]$ sudo pacman -Suu

Then had issues, then got


Code: [Select]
:: Proceed with installation? [Y/n] y
:: Retrieving packages...
 libldap-2.4.47-1-x86_64      282.6 KiB   368K/s 00:01 [############################] 100%
(295/295) checking keys in keyring                     [############################] 100%
(295/295) checking package integrity                   [############################] 100%
error: qpdfview: key "Alad Wenter <[email protected]>" is disabled
:: File /var/cache/pacman/pkg/qpdfview-0.4.18beta1-1-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] n
error: failed to commit transaction (invalid or corrupted package)
Errors occurred, no packages were upgraded.
[[email protected] ~]$ sudo pacman-key --edit-key alad

pub  ed25519/6BC26A17B9B7018A
     created: 2017-09-07  expires: 2019-03-29  usage: SC 
     trust: unknown       validity: full
*** This key has been disabled
sub  cv25519/56BC98A0ED1781EB
     created: 2017-09-07  expires: 2019-03-29  usage: E  
[  full  ] (1). Alad Wenter <[email protected]>
[ revoked] (2)  Alad Wenter <[email protected]>
[ revoked] (3)  Alad Wenter <[email protected]>
[marginal] (4)  [jpeg image of size 23265]

gpg> enable

gpg> save
Key not changed so no update needed.
==> Updating trust database...
gpg: marginals needed: 3  completes needed: 1  trust model: pgp
gpg: depth: 0  valid:   1  signed:  22  trust: 0-, 0q, 0n, 0m, 0f, 1u
gpg: depth: 1  valid:  22  signed:  99  trust: 0-, 0q, 0n, 22m, 0f, 0u
gpg: depth: 2  valid:  96  signed:  17  trust: 96-, 0q, 0n, 0m, 0f, 0u
gpg: next trustdb check due at 2019-01-31

Then tried...

Code: [Select]
[[email protected] ~]$ sudo pacman -Syu

Then got...

Code: [Select]
Total Installed Size:  2099.08 MiB
Net Upgrade Size:       234.59 MiB

:: Proceed with installation? [Y/n] y
(295/295) checking keys in keyring                     [############################] 100%
(295/295) checking package integrity                   [############################] 100%
(295/295) loading package files                        [############################] 100%
(295/295) checking for file conflicts                  [############################] 100%
error: failed to commit transaction (conflicting files)
filesystem: /etc/artix-release exists in filesystem
Errors occurred, no packages were upgraded.
[[email protected] ~]$

Ah yes, the wonderful fun-filled gamed of play pin tail on donkey with many "guess" fixes from google searches... lol

Re: Upgrade GPG errors etc

Reply #13
Quote
filesystem: /etc/artix-release exists in filesystem

This problem was discussed some time ago.
The solution is to ignore it.

Code: [Select]
pacman -Syu --overwrite etc/artix-release
Happy falling

Re: Upgrade GPG errors etc

Reply #14
This problem was discussed some time ago.
The solution is to ignore it.

Code: [Select]
pacman -Syu --overwrite etc/artix-release

Thanks, seems to be upgrading things now. See new users don't know that was discussed long ago, maybe wiki could be updated to reflect that? If having key issues, do this fix for specific guy's keys.. then run command above there you gave me.

Or in wiki, for "post installation" .. to check keys first, then provide valid fix for the keys, then your command above there. Like, "Before running an upgrade, check keys with this command... then refresh keys with this command... then apply fix for Alad's key with this command... then do your command " and upgrade will be fine.