Skip to main content
Topic solved
This topic has been marked as solved and requires no further attention.
Topic: Not authorized to control networking. with OpenRC (Read 708 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

Re: Not authorized to control networking. with OpenRC

Reply #15
some polkit hell ?
I don't know what you mean?  ::)

Where could i find the request for: org.freedesktop.NetworkManager.network-control ?
On my system there is many systemd-stuff ...  :o , but only systemd-dummy and libsystemd-dummy, not the real package.
Existing groups:
Code: [Select]
systemd-journal-remote:x:982:
systemd-network:x:981:
systemd-resolve:x:980:
systemd-timesync:x:979:
systemd-coredump:x:978:
folder with systemd-service-units
/usr/share/dbus-1/system-services -> org.freedesktop.NetworkManager.service, org.freedesktop.nm_dispatcher.service, org.freedesktop.PolicyKit1.service
Could this be a problem?
I've removed org.freedesktop.ModemManager1.service and now, the warning that this service could not acquire is gone.

Re: Not authorized to control networking. with OpenRC

Reply #16
The mainproblem seems to be be solved:
Ive forgot to change the group in the gentoo-workaround to network.

Only the problem with the lid and suspend i could not solve...

Re: Not authorized to control networking. with OpenRC

Reply #17
Try another desktop (LXQt). If it can suspend then you can narrow the problem down to xfce4.

Re: Not authorized to control networking. with OpenRC

Reply #18
Try another desktop (LXQt). If it can suspend then you can narrow the problem down to xfce4.
I've testet before KDE Plasma 5. There it works only in the wayland-session...  ::)
Seems that this could help, but I didn't know how...
Quote
Problem is that xfce4-power-manager (xf4pm) is letting logind handle the lid close, and that happens because the logind-handle-lid-switch field in xf4pm settings is by default set to true (no idea why). To make xf4pm have control over lid close, we have to set that field to false: xfconf-query -c xfce4-power-manager -p /xfce4-power-manager/logind-handle-lid-switch -s false.

Re: Not authorized to control networking. with OpenRC

Reply #19
Today I had this problem, but in Artix runit. After upgrading, I could not connect to the wifi. I opened edit conections, and in the general tab I left as it is in the image.
And solved, just to leave this tip if there is anyone else with this problem.



Sorry to be in Portuguese. :)