Skip to main content
Topic solved
This topic has been marked as solved and requires no further attention.
Topic: Not authorized to control networking. with OpenRC (Read 449 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

Not authorized to control networking. with OpenRC

Hello everybody,
I have now also run GNU / Linux with OpenRc as init on my laptop.
Unfortunately I was confronted with new problems there.
I'm runnig XFCE4 and lightdm as desktop engine.

1. I'm not able to add a W-Lan Network (LAN works):
If i  go thrue notification area "Connect to a hidden wireless network" (other networks are listed there) i get the error:
Code: [Select]
(1) Not authorized to control networking.
and if i go to networkconnections i get the error:
Code: [Select]
Insufficient privileges.
The questionable hereby, i'm able to shutdown restart and standy as a normal user so polkit-elogind should not be the problem.
Solution: this workaround change plugdev to network and add user.

2. My disk is fully encrypted with luks LVM (without /boot), however, I do not yet have the right keymap to decrypt even tough:
Code: [Select]
HOOKS=(base udev autodetect modconf block keyboard keymap encrypt lvm2 filesystems fsck)
Solution: Forgot to add the keymap also in: /etc/vconsole.conf and /etc/conf.d/keymaps

3. I'm not able to control the backlight Forgot install xf86-video...
3. Laptop doesn't suspend if i close the notebook lid, but if i manually suspend and open the lid, laptop starts...
Solution:
Code: [Select]
# xfconf-query -c xfce4-power-manager -p /xfce4-power-manager/logind-handle-lid-switch -n -t bool -s false


Hope you can help me.
Thank you. :)

 

Re: Problems on Laptop with OpenRC

Reply #1
Please, post more information about your system. Is it pure Artix install? Migrated from systemd?
For #1: post your group membership as reported by id. You should be a member of power group.
For #2: is your keymap included in initrd? For example, I explicitly specify my font file in /etc/mkinitcpio.conf:
Code: [Select]
FILES="/usr/share/kbd/consolefonts/ter-v16b.psf.gz"
For #3: Assuming elogind is up and running, you need a directive in /etc/elogind/logind.conf:
Code: [Select]
HandleLidSwitch=suspend

Re: Problems on Laptop with OpenRC

Reply #2
Thank you for your response.

It's a fresh openrc installation, no migration.
#1 My groups:
Code: [Select]
uid=1000(host) gid=985(users) Gruppen=985(users),3(sys),998(wheel),995(audio),994(disk),990(optical),988(storage),986(video)
I don't know why i must be in the group power, because shotdown and restart works perfect?

#2 I don't know how you mean this? I think my keymap is:
/usr/share/kbd/keymaps/i386/qwertz/de-latin1.map.gz

#3 I've uncommented the line, restartet but the laptop doesn't suspend altough ive set same in powersettings.


Re: Problems on Laptop with OpenRC

Reply #4
Code: [Select]
dmesg -wHT | grep -i lid
Open close the lid and see if it gets registered; you should get something similar to
Code: [Select]
[Sat Jan 19 01:28:11 2019] elogind-daemon[2397]: Lid closed.
[Sat Jan 19 01:28:14 2019] elogind-daemon[2397]: Lid opened.
If yes, then your Xfce is intercepting the action. But you're saying you have the same in power settings; this means Xfce inhibits elogind but can't convey the action. Try setting lid action to 'Ignore' and see if elogind takes over. Does LXQt work?

Networkmanager is confirmed to work in fresh Artix installations. Do you remember having tampered with any related settings or disabling any daemons? Do you get any additional messages in /var/log/everything.log? Post your 'rc-status --all' at our pastebin.


Re: Problems on Laptop with OpenRC

Reply #5
Can you try to follow this section on ArchWiki ?
https://wiki.archlinux.org/index.php/NetworkManager#Set_up_PolicyKit_permissions

In short you should also create (if it does not exist) and add user to "network" group.
This also doesn't solves the WiFi problem... :(

dmesg -wHT | grep -i lid:
Code: [Select]
[Fr Jan 18 23:09:24 2019] input: Lid Switch as /devices/LNXSYSTM:00/LNXSYBUS:00/PNP0C0D:00/input/input2
[Fr Jan 18 23:09:24 2019] ACPI: Lid Switch [LID0]
[Fr Jan 18 23:17:14 2019] ACPI: button: The lid device is not compliant to SW_LID.
In /var/log/everything.log
Code: [Select]
Jan 19 12:56:09 host root[3347]: LID closed
...
Jan 19 12:56:23 host root[3353]: LID opened

rc-status --all
Code: [Select]
Runlevel: default
 dbus                                                              [  started  ]
 elogind                                                           [  started  ]
 iptables                                                          [  stopped  ]
 syslog-ng                                                         [  started  ]
 wpa_supplicant                                                    [  started  ]
 NetworkManager                                                    [  started  ]
 acpid                                                             [  started  ]
 avahi-daemon                                                      [  started  ]
 netmount                                                          [  started  ]
 xdm                                                               [  started  ]
 alsasound                                                         [  started  ]
 ntp-client                                                        [  stopped  ]
 cronie                                                            [  started  ]
 local                                                             [  started  ]
 agetty.tty3                                           [  started 13:50:32 (0) ]
 agetty.tty6                                           [  started 13:50:32 (0) ]
 agetty.tty5                                           [  started 13:50:32 (0) ]
 agetty.tty2                                           [  started 13:50:32 (0) ]
 agetty.tty4                                           [  started 13:50:32 (0) ]
 agetty.tty1                                           [  started 13:50:32 (0) ]
Runlevel: sysinit
 devfs                                                             [  started  ]
 sysfs                                                             [  started  ]
 udev                                                              [  started  ]
 dmesg                                                             [  started  ]
 kmod-static-nodes                                                 [  started  ]
 udev-trigger                                                      [  started  ]
 cgroups                                                           [  started  ]
Runlevel: shutdown
 killprocs                                                         [  stopped  ]
 savecache                                                         [  stopped  ]
 mount-ro                                                          [  stopped  ]
Runlevel: nonetwork
 local                                                             [  started  ]
Runlevel: boot
 hwclock                                                           [  started  ]
 sysctl                                                            [  started  ]
 loopback                                                          [  started  ]
 modules                                                           [  started  ]
 dmcrypt                                                           [  started  ]
 lvm                                                               [  started  ]
 fsck                                                              [  started  ]
 root                                                              [  started  ]
 mtab                                                              [  started  ]
 swap                                                              [  started  ]
 localmount                                                        [  started  ]
 bootmisc                                                          [  started  ]
 procfs                                                            [  started  ]
 binfmt                                                            [  started  ]
 hostname                                                          [  started  ]
 haveged                                                           [  started  ]
 termencoding                                                      [  started  ]
 keymaps                                                           [  started  ]
 urandom                                                           [  started  ]
 net.lo                                                            [  started  ]
 opensysusers                                                      [  started  ]
Dynamic Runlevel: hotplugged
Dynamic Runlevel: needed/wanted
 lvmetad                                                           [  started  ]
 xdm-setup                                                         [  started  ]
Dynamic Runlevel: manual

Networkmanager is confirmed to work in fresh Artix installations. Do you remember having tampered with any related settings or disabling any daemons? Do you get any additional messages in /var/log/everything.log?

I've got nothing disabled. What exactly should I look for in the log?

Re: Problems on Laptop with OpenRC

Reply #6
elogind needs to be in the boot runlevel, remove it from default and add it to boot.

Re: Problems on Laptop with OpenRC

Reply #7
elogind needs to be in the boot runlevel, remove it from default and add it to boot.
This doesn't solve any of my problems. :(

Under systemd + KDE Plasma + WaylandSession closing the lid suspend the computer (same with xserver works non-reliable).

I don't understand why I should have the wrong permission to add a WiFi. Is there any workaround to add it with a configfile trough the terminal?

Re: Not authorized to control networking. with OpenRC

Reply #8
If i want to disconnect Wired connection, i get also an error...
Code: [Select]
(1) org.freedesktop.NetworkManager.network-control request failed: not autorized
does this focus the error?

Re: Not authorized to control networking. with OpenRC

Reply #9
if i
Code: [Select]
sudo nm-connection-editor
I am able to save the settings, but if I want to connect. Something ask for my WPA2 passphrase although i've set this in the connection editor?...

and if i
Code: [Select]
sudo nm-applet
Code: [Select]
** Message: 13:12:46.320: Remote error from secret service: org.freedesktop.DBus.Error.ServiceUnknown: The name org.freedesktop.secrets was not provided by any .service files
nm-applet-Message: 13:12:46.320: No keyring secrets found for Heimnetzwerk/802-11-wireless-security; asking user.
If i open nm-applet as normal user, there is really no passphrase seted, but if i opend as root there is.  :(

And I find out that there is no file:
/etc/dbus-1/system.d/org.freedesktop.NetworkManager.conf or something like nm

Re: Not authorized to control networking. with OpenRC

Reply #10
Quote
And I find out that there is no file:
/etc/dbus-1/system.d/org.freedesktop.NetworkManager.conf or something like nm

If you looks at NetworkManager files, you will see this file at
Code: [Select]
/usr/share/dbus-1/system.d/org.freedesktop.NetworkManager.conf
Happy falling

Re: Not authorized to control networking. with OpenRC

Reply #11
Oh.
Don't know what to doo...  :'(

Where should I look? on systemd I doesn't have these problems... :(

Re: Not authorized to control networking. with OpenRC

Reply #12
Add your user to 'dbus' group.
Code: [Select]
% sudo usermod -G dbus -a $(whoami)
Logout, login, check your group membership and retry NM.

Re: Not authorized to control networking. with OpenRC

Reply #13
Add your user to 'dbus' group.
Code: [Select]
% sudo usermod -G dbus -a $(whoami)
Logout, login, check your group membership and retry NM.
The same error.
Code: [Select]
(1) org.freedesktop.NetworkManager.network-control request failed: not autorized
I've got running an older version of the same GNU/Linux but with KDE Plasma instead of XFCE. Same groups, same services, there is no problem... It might be a problem with OpenRC and XFCE?

Re: Not authorized to control networking. with OpenRC

Reply #14
some polkit hell ?
Happy falling