Skip to main content
Topic solved
This topic has been marked as solved and requires no further attention.
Topic: [SOLVED] OpenRC, Thunar (caja, etc.), sshfs (Read 145 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

[SOLVED] OpenRC, Thunar (caja, etc.), sshfs

System was installed from last OpenRC base relise.  So: clear installation with XFCE4 as DE.  X-session fire-up with xfce4start . gvfs, sshfs installed. Thunar can mount/umount all external drive without any problem. Exept - ssh. When i try connect from this (let it be A) host to host B with ssh - this is unavailable.  Ask Browse network get answer "operation not support". And in preferences 'advanced tab' i look  "It looks like gvfs isn't available."
If try connect from host B to host A - is ok. 

Re: OpenRC, Thunar (caja, etc.), sshfs

Reply #1
gvfs is build with openssh support.

work gvfs- mount ?     like for example 'gvfs-mount sftp://[email protected]/home'

Re: OpenRC, Thunar (caja, etc.), sshfs

Reply #2
Not work:
[1]
Code: [Select]
gvfs-mount sftp://[email protected]/home 
This tool has been deprecated, use 'gio mount' instead.
See 'gio help mount' for more info.

gio: sftp://[email protected]/home: Connection failed

Is it right that sshfs no more need? (if gvfs is support ssh itself)

Re: OpenRC, Thunar (caja, etc.), sshfs

Reply #3
gvfs use openssh,

maybe is not ssh open, running ssh-agent ?

Re: OpenRC, Thunar (caja, etc.), sshfs

Reply #4
The problem was in config files (on gentoo host). Now solved.
Thank for your time and answer!