Skip to main content
Topic solved
This topic has been marked as solved and requires no further attention.
Topic: [Solved] hang on boot when launching syslog-ng (Read 120 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

[Solved] hang on boot when launching syslog-ng

TL;DR:
I'm experiencing a "boot hang" when launching syslog-ng. System was installed from artix-lxqt-openrc-20181008-x86_64.iso and updated using pacman -Syyu.
System itself runs fine when the hang is canceled by hitting Ctrl+C multiple times.
----

Short introduction of myself, as this is my first post:
I`ve been using Linux for some years now, my current main system is Manjaro - so you might guess what took me here: having the Arch-Style without systemd. :)
I know a bit about Linux in general, but i'm completely new to Artix or OpenRC.

I've installed Artix on my test system from the artix-lxqt-openrc-20181008-x86_64.iso and updated it to the latest version. Despite a small issue during boot everything runs fine and is looking nice. :)

Currently, the system "hangs" during boot. At this point, hitting Ctrl+C several times makes the boot process go further.


I than can login to LXQt and everything (including networking) is fine.

Searching around a bit i came across this topic, which seemed to describe the same problem. On my system syslog-ng was already installed and active, adding syslog-ng-openrc did not change anything.
So i thought the issue might be, that syslog-ng starts after NetworkManager and added i dependency in /etc/init.d/NetworkManager:
Code: [Select]
        use consolekit elogind syslog-ng

This led to the behavior, that now boot hangs upon syslog-ng Config Check:


So i went straight forward and commented the config check out of /etc/init.d/syslog-ng :
Code: [Select]
#syslog-ng -s -f "${SYSLOG_NG_CONFIGFILE}"

Now the boot process hangs on launching syslog-ng itself (no screen photo of that).

I appreciate every hint whats gone wrong with this installation and why syslog-ng wont launch on itself in a reasonable amount of time.

kind regards
guzzisti

Re: hang on boot when launching syslog-ng

Reply #1
What is "SYSLOG_NG_CONFIGFILE" in your configuration and does this file exist?

Re: hang on boot when launching syslog-ng

Reply #2
As seen in the second "screen photo", this variable resolves to /etc/syslog-ng/syslog-ng.conf - this file exists:
Code: [Select]
$ ls -l /etc/syslog-ng/syslog-ng.conf
-rw-r--r-- 1 root root 3661 30. Dez 03:54 /etc/syslog-ng/syslog-ng.conf

I have not messed with this one after installation. :)

Re: hang on boot when launching syslog-ng

Reply #3
Do you get the same behaviour if you set rc_parallel="YES" in /etc/rc.conf?

Re: hang on boot when launching syslog-ng

Reply #4
Behaviour stays the same. I disabled syslog-ng using rc-update delete syslog-ng default and the boot does not hang up albeit the nm-dispatcher message still show up - which makes me tend to believe that NetworkManager is not the issue.
Manually starting syslog-ng from a terminal after boot works without any hassle.

If installed Artix in a virtual machine as well, there i see the nm-dispatcher messages as well, but the boot process does not get stuck. Maybe i should compare the configs of the vm and my test machine to see if there's any difference.

I'm thinking about doing a fresh install from the base-iso on my test machine to see if this might change something.

Re: hang on boot when launching syslog-ng

Reply #5
thinking about doing a fresh install from the base-iso on my test machine to see if this might change something.

I think that's not necessary.

Please kick out or disable in syslog-ng.conf
Code: [Select]
use_dns()

and try again.

Re: hang on boot when launching syslog-ng

Reply #6
Thanks for your reply artoo, but dns was already disabled:
Code: [Select]
$ cat /etc/syslog-ng/syslog-ng.conf | grep use_dns
  use_dns (no);

Nevertheless your post pointed me to back to the direction "networking", digging a bit in the internet made me across this older gentoo bugreport: https://bugs.gentoo.org/228973#c34
So i added the an additional dependency in syslog-ng script:
Code: [Select]
$ cat /etc/init.d/syslog-ng | grep net
        need hostname localmount net

No everything is fine. Seems like the network interface on this machine needs 1 or 2 seconds to come up after NetworkManager is started, getting into a race with syslog-ng startup.

Gonna install Artix on my laptop now...  ;D

Re: [Solved] hang on boot when launching syslog-ng

Reply #7
Another possible cause we discussed with artoo on the IRC, was the absence of uucp group. If you're missing that group, it might be the reason for syslog-ng's behaviour. Latest filesystem and opensysusers fix that. Anyway, marking this as [SOLVED].