Skip to main content
Topic solved
This topic has been marked as solved and requires no further attention.
Topic: [SOLVED] MPD depends on old version of libnfs (Read 117 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

[SOLVED] MPD depends on old version of libnfs

Currently mpd can't be started since it is looking for libnfs.so.12, however libnfs version 4.0.0-3 provides libnfs.so.13.  Downgrading libnfs to version 3.0.0-2 fixes the problem as that package provides libnfs.so.12.

On a side note: I think a proper bug tracker would be better than using the forums for that. Your gitea instance would probably be better for that, but I can't find a way to register there.

Re: MPD depends on old version of libnfs

Reply #1
If you don't want to downgrade, a temporary solution would be to make a symlink for the required file, pointing to the existing file.

This kind of problem is expected, and will continue to happen as long as we use mixed repos (Arch+Artix). We will eventually package all of the software, and then this will not happen.

Re: MPD depends on old version of libnfs

Reply #2
Problem fixed with latest mpd package