Skip to main content
Topic solved
This topic has been marked as solved and requires no further attention.
Topic: Music files muted in VLC (Read 963 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

Re: Music files muted in VLC

Reply #15
If it doesn't work in other distros also, then it is clearly a hardware/driver issue.

Re: Music files muted in VLC

Reply #16
Code: [Select]
[[email protected] ~]$ locate /usr/lib/modules|grep -e 5.0.2|grep -e intel|grep -e pci|grep -ie sound -ie snd -ie hda -ie music
/usr/lib/modules/5.0.2-artix1-1-ARTIX/kernel/sound/pci/snd-intel8x0.ko.xz
/usr/lib/modules/5.0.2-artix1-1-ARTIX/kernel/sound/pci/snd-intel8x0m.ko.xz
/usr/lib/modules/5.0.2-artix1-1-ARTIX/kernel/sound/pci/hda/snd-hda-intel.ko.xz
/usr/lib/modules/5.0.2-artix1-1-ARTIX/kernel/sound/soc/intel/atom/sst/snd-intel-sst-pci.ko.xz
[[email protected] ~]$
If it doesn't work in other distros also, then it is clearly a hardware/driver issue.
I looked at the drivers but seems doesn’t have driver issues, so should be hardware issue mostly. What hardware issues can cause somewhat peripherals to be out of fuctions even with the right drivers?
Artix; OpenRC; SDDM
Plasma 5, LXQt, Lumina, Liri, TheShell, Trinity, Xfce :)

Re: Music files muted in VLC

Reply #17
So does sound not work for you only on Artix, or on every distro you've tried? Does it work, if you use, say an Ubuntu live boot?
No live sessions can boot up this card, on the all local distro even within the right drivers this card still doesn’t function properly like the above stated drivers that are ok.
Artix; OpenRC; SDDM
Plasma 5, LXQt, Lumina, Liri, TheShell, Trinity, Xfce :)

Re: Music files muted in VLC

Reply #18
By "hardware issue", I just meant that it either needs to be replaced, or taken to repair for inspection.

Re: Music files muted in VLC

Reply #19
Code: [Select]
# pacman -S alsa-utils alsa-utils-openrc
# rc-update add alsasound default
You need the alsa service enabled if it has not been done already. The controls and their settings are stored at shutdown by the alsa service in /var/lib/alsa/asound.state so that is not happening properly for some reason.
Some tests with the aplay and speaker-test commands might reveal something.

Re: Music files muted in VLC

Reply #20
I think we need to confirm if the soundcard is broken or not. Have you tried not just other GNU/Linux distros but any other operating systems actually? If it doesn't work on any other mainstream system, then we can safely assume that the hardware is broken, rendering this whole thread pretty much pointless.

Re: Music files muted in VLC

Reply #21
I think we need to confirm if the soundcard is broken or not. Have you tried not just other GNU/Linux distros but any other operating systems actually? If it doesn't work on any other mainstream system, then we can safely assume that the hardware is broken, rendering this whole thread pretty much pointless.
That was kind of what I was suggesting, but hadn't found a good guide to illustrate the use of speaker-test and aplay.
But here is one:
https://www.mythtv.org/wiki/Using_ALSA's_speaker-test_utility
It doesn't rely on any desktop sound working. It's also possible to pass options to the audio driver and I read you can get the situation where there are no controls in alsamixer but the hardware is working.
Another suggestion is to get an old outdated iso from when the card did work. Go back to software that you know should work, if the card has become faulty it won't work now.

Re: Music files muted in VLC

Reply #22
Code: [Select]
[[email protected] ~]$ sudo pacman -Su --noconfirm --force --needed alsa-utils alsa-utils-openrc && sudo rc-update add alsasound default
warning: option --force is deprecated; use --overwrite instead                                                                                                                                                                                                                                                                                 
error: could not register 'galaxy-gremlins' database (database already registered)                                                                                                                                                                                                                                                             
warning: alsa-utils-1.1.8-1 is up to date -- skipping                                                                                                                                                                                                                                                                                          
warning: alsa-utils-openrc-20180221-1 is up to date -- skipping                                                                                                                                                                                                                                                                                
:: Starting full system upgrade...                                                                                                                                                                                                                                                                                                             
warning: x264: local (2:155.r0a84d986-2.1) is newer than extra (2:155.r0a84d986-2)                                                                                                                                                                                                                                                             
 there is nothing to do                                                                                                                                                                                                                                                                                                                        
 * service alsasound added to runlevel default
[[email protected] ~]$ sudo openrc                                                                                                                                                                                                                                                                                                           
 * Restoring Mixer Levels ...
 * No mixer config in /var/lib/alsa/asound.state, you have to unmute your card!                                                                                                                                                                                                                                                           [ ok ]
[[email protected] ~]$ sudo mkdir -pv /var/lib/alsa && sudo touch  /var/lib/alsa/asound.state && sudo openrc
[[email protected] ~]$
Quote from: msg=7164 date=1553208502
Code: [Select]
# pacman -S alsa-utils alsa-utils-openrc
# rc-update add alsasound default
You need the alsa service enabled if it has not been done already. The controls and their settings are stored at shutdown by the alsa service in /var/lib/alsa/asound.state so that is not happening properly for some reason.
Some tests with the aplay and speaker-test commands might reveal something.
Totally not hard-bricked, as told to us above ‘‘you’ve to unmute your card!’’, then should mostly be just software-sided issue, so has this already ‘‘unmuted’’ the card?
Artix; OpenRC; SDDM
Plasma 5, LXQt, Lumina, Liri, TheShell, Trinity, Xfce :)

Re: Music files muted in VLC

Reply #23
Code: [Select]
[[email protected] ~]$ sudo speaker-test

speaker-test 1.1.8
                                                                                                                                                                                                                                                                                                                                               
Playback device is default                                                                                                                                                                                                                                                                                                                     
Stream parameters are 48000Hz, S16_LE, 1 channels                                                                                                                                                                                                                                                                                              
Using 16 octaves of pink noise                                                                                                                                                                                                                                                                                                                 
ALSA lib pcm_dmix.c:1108:(snd_pcm_dmix_open) unable to open slave                                                                                                                                                                                                                                                                              
Playback open error: -2,No such file or directory                                                                                                                                                                                                                                                                                              
[[email protected] ~]$ cd /usr/share/alsa && sudo aplay -L                                                                                                                                                                                                                                                                                   
null                                                                                                                                                                                                                                                                                                                                           
    Discard all samples (playback) or generate zero samples (capture)                                                                                                                                                                                                                                                                          
hdmi:CARD=PCH,DEV=0                                                                                                                                                                                                                                                                                                                            
    HDA Intel PCH, HDMI 0                                                                                                                                                                                                                                                                                                                      
    HDMI Audio Output                                                                                                                                                                                                                                                                                                                          
[[email protected] alsa]$ sudo speaker-test -Dplug:spdif                                                                                                                                                                                                                                                                                     
                                                                                                                                                                                                                                                                                                                                               
speaker-test 1.1.8                                                                                                                                                                                                                                                                                                                             
                                                                                                                                                                                                                                                                                                                                               
Playback device is plug:spdif                                                                                                                                                                                                                                                                                                                  
Stream parameters are 48000Hz, S16_LE, 1 channels                                                                                                                                                                                                                                                                                              
Using 16 octaves of pink noise                                                                                                                                                                                                                                                                                                                 
Playback open error: -2,No such file or directory                                                                                                                                                                                                                                                                                              
[[email protected]ia alsa]$
That was kind of what I was suggesting, but hadn't found a good guide to illustrate the use of speaker-test and aplay.
But here is one:
https://www.mythtv.org/wiki/Using_ALSA's_speaker-test_utility
It doesn't rely on any desktop sound working. It's also possible to pass options to the audio driver and I read you can get the situation where there are no controls in alsamixer but the hardware is working.
Another suggestion is to get an old outdated iso from when the card did work. Go back to software that you know should work, if the card has become faulty it won't work now.
Artix; OpenRC; SDDM
Plasma 5, LXQt, Lumina, Liri, TheShell, Trinity, Xfce :)

Re: Music files muted in VLC

Reply #24
I think we need to confirm if the soundcard is broken or not. Have you tried not just other GNU/Linux distros but any other operating systems actually? If it doesn't work on any other mainstream system, then we can safely assume that the hardware is broken, rendering this whole thread pretty much pointless.
For surely the card is not broken, but somewhy always muted on any distro.
Artix; OpenRC; SDDM
Plasma 5, LXQt, Lumina, Liri, TheShell, Trinity, Xfce :)

Re: Music files muted in VLC

Reply #25
How do you know that card is not broken?

Re: Music files muted in VLC

Reply #26
How do you know that card is not broken?
When i've backed up the all data and systems to create an empty GPT, the first thing done is to install GhostBSD first, before all Linux distro, and GhostBSD has hence revived my audio card. Totally hard drive issue. :)
Artix; OpenRC; SDDM
Plasma 5, LXQt, Lumina, Liri, TheShell, Trinity, Xfce :)