Skip to main content
Topic: LUKS encryption don't work with new ISO (Read 66 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

LUKS encryption don't work with new ISO

I've a problem with the last ISO: I'm no longer able to encrypt the root partition and to have a start and running system. Probably there is something wrong in fstab/mtab, I've no idea, but the fact is that, after the installation, completed without errors, the system don't start. I tried also the Mate ISO and all the last available versions, but the problem is present in all the ISO.
I use always LUKS and this make me impossible to activate new Artix installation.

I tried also to change file system (ext4, btrfs, xfs), without success: the error is always the same.

Forgive me if I haven't investigate it, but I'm yet in a hard period that don't permit me to invest time in what I like to do.

Re: LUKS encryption don't work with new ISO

Reply #1
I am by no means an expert but I had a similar problem installing Artix Runit (which I love btw!) on my laptop.  After being unable to install with LUKS on my drive.  I used cfdisk to format my HDD to all free space since I had a previous OS on prior & retried with success using LUKS on ext4.  Just my two cents.