Skip to main content
Topic: AMD GCN4 graphical issue (Read 595 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

AMD GCN4 graphical issue

Hi there,

I'm having problems with graphics since kernel upgrade to 5.2.x only with my newer Acer with AMD A12 / RX540 (amdgpu).
A desktop with FX9590 and another notebook with A10, both with Radeon HD7xxx (radeon) series are all ok.
When it boots it hangs just after initrd load if configured with arch's "early KMS" settings, otherwise it hangs at graphical initiation. The system dies leaving only a thin horizontal color pulsed bar and stay so until poweroff.
My workaround is to downgrade kernel and headers to 5.1.9... I could see in forums around similar problems including in some i915, some of them have fixing so thought if I'm making some mistakes... My 3 machines have basically the same installation of Artix, daily upgraded, lxqt and openrc, all of them were working marvelously until kernel 5.2.
Could someone please help???

Tx in advance

Re: AMD GCN4 graphical issue

Reply #1
Huh, I can try this later on my other machine (similar GPU; RX 550) and see what happens. Just going off a guess here, but it's probably a kernel/driver bug. AMDGPU development is pretty active and goes through a lot of changes so sometimes you get regressions like this.

Re: AMD GCN4 graphical issue

Reply #2
so sometimes you get regressions like this.

Thank you Dudemanguy, maybe the only option for me is to wait...
I cannot see anything helpful in kernel logs,  arch bugs NÂș  63159, 63207 shows similar behavior in intel chipsets. The quantity of so few reports is driving me to think in something particular to affected systems, like some settings or packages combination... maybe something in drm ? Don't know it yet but apparently it is not happening in all machines or forums would be awash with reports.

Re: AMD GCN4 graphical issue

Reply #3
Hmm yeah I just tested early KMS on my RX550 and it worked without any issues. This might be very specific to only your card.

Re: AMD GCN4 graphical issue

Reply #5
5.2.8 is out now if you want to try it. I didn't see anything in the release notes that suggested any changes to amd though.

Re: AMD GCN4 graphical issue

Reply #6
Yes I'll try kernel new versions timely as they arrive... I'll post good news.
Thank you Dudemanguy

Re: AMD GCN4 graphical issue

Reply #7
Updating to kernel 5.2.9.

There was also amd-ucode and linux-firmware updates.

No changes....  :'(

Re: AMD GCN4 graphical issue

Reply #8
kernel 5.3 attempted, all the same: 2 machines ok, one failed.

Next try: kernel 5.4 or artix lxqt openrc image newer than 20190609 (kernel 5.1.4).


Re: AMD GCN4 graphical issue

Reply #9
Light appears at the deep tunnel !!!

Now with kernel 5.4.6 system boots !!! But it hangs dead at the xorg init...

I tried it in xorg-server-1.20.6-2 that received a cleaning process, maybe I need some more  of it  :o