Skip to main content
Topic: Minor bug found - copy/cut buffer vanishes when source is gone.  (Read 391 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

Minor bug found - copy/cut buffer vanishes when source is gone.

when on desktop, openbox, while opening  a file with leafpad and copying some text if I close the leafpad the buffer is gone.  As long as it is open last copied buffer exists, when I close it vanished.  It is not leafpad specific it happens with anything.  I am searching and trying system-tray clipboard pkgs to see if any of them cures this.

I've never seen this happen before artix.  It is as if pkgs start within a container or sandbox.  Is this a side effect of the hardened kernel?

Re: Minor bug found - copy/cut buffer vanishes when source is gone.

Reply #1
I suspect somewhere in desktop configuration there is a "save history" yes/no and that is all it is.
The terminal command history is already exceeding its 500 limit, so that is unrelated.

Re: Minor bug found - copy/cut buffer vanishes when source is gone.

Reply #2
I installed copyQ and the problem is gone.  I suspect the installation turned that clipboard history on but I am still clueless on where that setting is.or why would it be set to off in Artix.  It is amazing how much one would do with a clipboard looking at the copyQ configuration. 

Re: Minor bug found - copy/cut buffer vanishes when source is gone.

Reply #3
when on desktop, openbox, while opening  a file with leafpad and copying some text if I close the leafpad the buffer is gone.  As long as it is open last copied buffer exists, when I close it vanished.  It is not leafpad specific it happens with anything.  I am searching and trying system-tray clipboard pkgs to see if any of them cures this.

I've never seen this happen before artix.  It is as if pkgs start within a container or sandbox.  Is this a side effect of the hardened kernel?

this has been a common problem for a while now and it relates to them screwing around with the x-11 clipboard