Skip to main content
Topic solved
This topic has been marked as solved and requires no further attention.
Topic: Base package conflicts for runit (Read 397 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

Base package conflicts for runit

Hi all,
First post. Installed Artix with runit from the ISOs a couple of months ago. Became my daily driver at home on my Phenom II based PC as it is faster than the Windows 10, 7th Gen Core i5 laptop that I need to use for work. So thank you and I appreciate all the work that has gone into this!

Onto the problem - first one I've encountered btw: can't upgrade/install the base package. First it asks if I want to replace the artix-sysvcompat package, then chose between installing 1) elogind-openrc and 2) elogind-runit. I chose no. 2 as I'm running runit, then:
Code: [Select]
error: failed to commit transaction (conflicting files)
elogind-runit: /etc/runit/runsvdir/default/elogind exists in filesystem
Errors occurred, no packages were upgraded.

If I "--ignore elogind-runit", then it wants me to remove dbus-runit:
Code: [Select]
:: dbus-openrc and dbus-runit are in conflict (init-dbus). Remove dbus-runit? [y/N]

Could not find a solution on the forum. Makes me wonder, is openrc recommended over runit? Should I change?
Thanks in advance!

Re: Base package conflicts for runit

Reply #1
Remove /etc/runit/runsvdir/default/elogind  and proceed with normal update.

After update, readd elogind to runsvdir, if not present after update.

This is basically a file tracking issue in elogind-runit package.

For how long did you not update your system?

Re: Base package conflicts for runit

Reply #2
Thanks very much, that worked. I updated the system last about two weeks ago...