Skip to main content
Topic solved
This topic has been marked as solved and requires no further attention.
Topic: [SOLVED] Troubles with Wireguard: Unknown Device Type Wireguard (wireguard-dkms) (Read 1431 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

[SOLVED] Troubles with Wireguard: Unknown Device Type Wireguard (wireguard-dkms)

I'm trying to set up my vpn (mullvad) using Wireguard. I have (I assume) a valid config file in /etc/wireguard. I have installed wireguard-dkms and wireguard-tools.

When I run
Code: [Select]
wg-quick up mullvad-au1
I get:
Code: [Select]
[#] ip link add mullvad-au1 type wireguard
Error: Unknown device type.
Unable to access interface: Protocol not supported
[#] ip link delete dev mullvad-au1
Cannot find device "mullvad-au1"

When I run
Code: [Select]
modprobe wireguard
I get:
Code: [Select]
 modprobe: FATAL: Module wireguard not found in directory /lib/modules/5.5.2-artix1-1
It seems that this should not be the case.

I have already tried getting it to work with wireguard-arch instead of wireguard-dkms but this did not help.

Re: Troubles with Wireguard: Unknown Device Type Wireguard (wireguard-dkms)

Reply #1
Should use wireguard-dkms and make sure you have the kernel headers installed. If using standard linux kernel, install linux-headers, if linux-lts, install linux-lts-headers and so on.

Re: Troubles with Wireguard: Unknown Device Type Wireguard (wireguard-dkms)

Reply #2
Hello I found this troubleshooting and I hope this helps someone:
As @ndowens mentioned the issue is with the headers and there is one for each distribution, got the same issue with an AWS server and other one with another distribution. After I added the headers for each one the error was solved
Thanks again @ndowens