Skip to main content
Topic: Обновления пакетов Qt5 (Read 257 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

Обновления пакетов Qt5

Сегодня были обновления

qt5-base (5.14.1-1 -> 5.14.2-1)
qt5-styleplugins (5.0.0.20170311-19 -> 5.0.0.20170311-20)
qt5-svg (5.14.2-1)
qt5-declarative (5.14.2-1)
qt5-webchannel (5.14.2-1)
qt5-location (5.14.2-1)
qt5-webengine (5.14.2-1)
qt5-x11extras (5.14.2-1)
qt5-wayland (5.14.2-1)
qt5-base (5.14.2-1 -> 5.14.2-2)
qt5-location (5.14.2-1 -> 5.14.2-2)
qt5-webengine (5.14.2-1 -> 5.14.2-2)
qt5-multimedia (5.14.2-1)
qt5-sensors (5.14.2-1)
qt5-webkit (5.212.0alpha4-4)
qt5-xmlpatterns (5.14.2-1)

и в результате этих обновлений вот что произошло

Code: [Select]
audacious 
QApplication: invalid style override 'gtk' passed, ignoring it.
Available styles: bb10dark, bb10bright, cleanlooks, gtk2, cde, motif, plastique, Windows, Fusion

vlc
VLC media player 3.0.10 Vetinari (revision 3.0.10-0-g7f145afa84)
QApplication: invalid style override 'gtk' passed, ignoring it.
Available styles: bb10dark, bb10bright, cleanlooks, gtk2, cde, motif, plastique, Windows, Fusion

librecad
RS_DEBUG::setLevel(3)
RS_DEBUG: Critical
RS_DEBUG: Errors
RS_DEBUG: Warnings
QApplication: invalid style override 'gtk' passed, ignoring it.
Available styles: bb10dark, bb10bright, cleanlooks, gtk2, cde, motif, plastique, Windows, Fusion

otter-browser
QApplication: invalid style override 'gtk' passed, ignoring it.
Available styles: bb10dark, bb10bright, cleanlooks, gtk2, cde, motif, plastique, Windows, Fusion

Re: Обновления пакетов Qt5

Reply #1
qt5-styleplugins is broken, you need from AUR 5.0.0.20170311-22.
qt5-base-5.15.0-2 fix icons
Qt5ct-0.41-4 is broken too, fix exist and coming soon to archlinux.
Qt5 5.15  broking some UI, actually we can only wait for fix by mainstream.

Downgrade to 5.14. Can in some cases broke system. Better is wait for fix it.


qt5-styleplugins не работает, вам нужно от AUR 5.0.0.20170311-22.
qt5-base-5.15.0-2 исправляет некоторые иконки
Qt5ct-0.41-4 тоже не работает, исправления существуют и скоро появятся в archlinux.
Qt5 5.15 сломал некоторый пользовательский интерфейс, на самом деле мы можем только ждать исправления мейнстримом.

Понижение до 5.14. Может в некоторых случаях сломать систему. Лучше подождать, пока все починят.


Re: Обновления пакетов Qt5

Reply #3
Bad translation  :)  :)
I went say don't downgrade  :)  :)

Re: Обновления пакетов Qt5

Reply #4
Code: [Select]
upgraded qt5-styleplugins (5.0.0.20170311-20 -> 5.0.0.20170311-22)
Исправлено, но не до конца

Code: [Select]
LC_ALL=C vlc
VLC media player 3.0.10 Vetinari (revision 3.0.10-0-g7f145afa84)
QApplication: invalid style override 'gtk' passed, ignoring it.
Available styles: bb10dark, bb10bright, cleanlooks, gtk2, cde, motif, plastique, Windows, Fusion
QObject::~QObject: Timers cannot be stopped from another thread

LC_ALL=C otter-browser
QApplication: invalid style override 'gtk' passed, ignoring it.
Available styles: bb10dark, bb10bright, cleanlooks, gtk2, cde, motif, plastique, Windows, Fusion
propsReply "Method \"GetAll\" with signature \"s\" on interface \"org.freedesktop.DBus.Properties\" doesn't exist\n"
nmReply "Method \"GetDevices\" with signature \"\" on interface \"org.freedesktop.NetworkManager\" doesn't exist\n"
"Object path cannot be empty"

librecad
RS_DEBUG::setLevel(3)
RS_DEBUG: Critical
RS_DEBUG: Errors
RS_DEBUG: Warnings
QApplication: invalid style override 'gtk' passed, ignoring it.
Available styles: bb10dark, bb10bright, cleanlooks, gtk2, cde, motif, plastique, Windows, Fusion

cmake-gui
QApplication: invalid style override 'gtk' passed, ignoring it.
Available styles: bb10dark, bb10bright, cleanlooks, gtk2, cde, motif, plastique, Windows, Fusion
Error: could not load cache

Темно. Раньше было светлее.

Re: Обновления пакетов Qt5

Reply #5
Снова

upgraded qt5-base (5.15.0-5 -> 5.15.1-1)
upgraded qt5-declarative (5.15.0-2 -> 5.15.1-1)
upgraded qt5-location (5.15.0-1 -> 5.15.1-1)
upgraded qt5-svg (5.15.0-1 -> 5.15.1-1)
upgraded qt5-wayland (5.15.0-1 -> 5.15.1-1)
upgraded qt5-webchannel (5.15.0-1 -> 5.15.1-1)
upgraded qt5-webengine (5.15.0-5 -> 5.15.1-1)
upgraded qt5-x11extras (5.15.0-1 -> 5.15.1-1)

Code: [Select]
Cannot mix incompatible Qt library (5.15.0) with this library (5.15.1)

Re: Обновления пакетов Qt5

Reply #6
Снова

upgraded qt5-base (5.15.0-5 -> 5.15.1-1)
upgraded qt5-declarative (5.15.0-2 -> 5.15.1-1)
upgraded qt5-location (5.15.0-1 -> 5.15.1-1)
upgraded qt5-svg (5.15.0-1 -> 5.15.1-1)
upgraded qt5-wayland (5.15.0-1 -> 5.15.1-1)
upgraded qt5-webchannel (5.15.0-1 -> 5.15.1-1)
upgraded qt5-webengine (5.15.0-5 -> 5.15.1-1)
upgraded qt5-x11extras (5.15.0-1 -> 5.15.1-1)

Code: [Select]
Cannot mix incompatible Qt library (5.15.0) with this library (5.15.1)

какие пакеты qt остались в 5.15.0?
Поскольку и artix, и archlinux (оба) обновлены до 5.15.1 -> все пакеты должны быть 5.15.1

Re: Обновления пакетов Qt5

Reply #7
какие пакеты qt остались в 5.15.0?
Поскольку и artix, и archlinux (оба) обновлены до 5.15.1 -> все пакеты должны быть 5.15.1

Code: [Select]
$ qt5ct
QApplication: invalid style override 'gtk' passed, ignoring it.
Available styles: bb10dark, bb10bright, cleanlooks, gtk2, cde, motif, plastique, qt5ct-style, Windows, Fusion
Cannot mix incompatible Qt library (5.15.0) with this library (5.15.1)


$ cmake-gui
QApplication: invalid style override 'gtk' passed, ignoring it.
Available styles: bb10dark, bb10bright, cleanlooks, gtk2, cde, motif, plastique, qt5ct-style, Windows, Fusion
Cannot mix incompatible Qt library (5.15.0) with this library (5.15.1)


$ librecad
RS_DEBUG::setLevel(3)
RS_DEBUG: Critical
RS_DEBUG: Errors
RS_DEBUG: Warnings
QApplication: invalid style override 'gtk' passed, ignoring it.
Available styles: bb10dark, bb10bright, cleanlooks, gtk2, cde, motif, plastique, qt5ct-style, Windows, Fusion
Cannot mix incompatible Qt library (5.15.0) with this library (5.15.1)


$ audacious
QApplication: invalid style override 'gtk' passed, ignoring it.
Available styles: bb10dark, bb10bright, cleanlooks, gtk2, cde, motif, plastique, qt5ct-style, Windows, Fusion
Cannot mix incompatible Qt library (5.15.0) with this library (5.15.1)


$ vlc
VLC media player 3.0.11.1 Vetinari (revision 3.0.11.1-0-g52483f3ca2)
QApplication: invalid style override 'gtk' passed, ignoring it.
Available styles: bb10dark, bb10bright, cleanlooks, gtk2, cde, motif, plastique, qt5ct-style, Windows, Fusion
Cannot mix incompatible Qt library (5.15.0) with this library (5.15.1)

Возможно ещё otter который я удалил.

Re: Обновления пакетов Qt5

Reply #8
probably caused by not updated qt5-styleplugins (this package is obsolete!)

Re: Обновления пакетов Qt5

Reply #9
probably caused by not updated qt5-styleplugins (this package is obsolete!)
:: removing qt5-styleplugins breaks dependency 'qt5-styleplugins' required by artix-gtk-presets
Удалил эти пакеты. Не знаю как это отразится на работу системы, но теперь qt5ct cmake-gui librecad audacious vlc запускаются.

Re: Обновления пакетов Qt5

Reply #10
:: removing qt5-styleplugins breaks dependency 'qt5-styleplugins' required by artix-gtk-presets
Удалил эти пакеты.
but i wrote nothing about remove it ;-) try later pacman -Syu instead
но я ничего не писал об удалении ;-) попробуйте позже pacman -Syu вместо

 

Re: Обновления пакетов Qt5

Reply #11
Обновился qt5-styleplugins. Теперь порядок.